Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-01-04 13:04:23

majestyx
Member
Registered: 2013-12-03
Posts: 18
Website

[Solved] My Mouse, XOrg and XFCE not want to play together

Many Problems whit Icedove, Iceweasel or Bash (at normal work) under XFCE 4.10 / Debian Jessi, I have 8GB RAM. But XFCE feels like 512MB?!

Hint: i swich back from KDE to XFCE. On KDE i don't have this Problems


My "OnBord" VGA: 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

What everything does not work or is very slow: focus of the mouse, click in an inactive window, context menu click reacts only after 5

The problem occurs temporarily. but at least 30 - 40 times a day


#LOGFILE:

[  4599.661] X Protocol Version 11, Revision 0
[  4599.661] Build Operating System: Linux 3.13.0-rc2-patser+ x86_64 Debian
[  4599.661] Build Date: 13 December 2013  10:12:53AM
[  4599.661] xorg-server 2:1.14.5-1 (Maarten Lankhorst <maarten.lankhorst@ubuntu.com>)

#yes i have do this -> "Before reporting problems, check http://wiki.x.org"
#IMHO: DRM sucks!

[  4599.661] (==) ModulePath set to "/usr/lib/xorg/modules"
[  4599.661] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4599.661] (II) Loader magic: 0x7f514c41ad00
[  4599.661] (II) Module ABI versions:
[  4599.662]     X.Org ANSI C Emulation: 0.4
[  4599.662]     X.Org Video Driver: 14.1
[  4599.662]     X.Org XInput driver : 19.1
[  4599.662]     X.Org Server Extension : 7.0
[  4599.662] (II) xfree86: Adding drm device (/dev/dri/card0)
[  4599.663] (--) PCI:*(0:0:2:0) 8086:0102:1043:844d rev 9, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64

#IMHO: Keybord works normaly - Only Problems whit the Mouse. But, XOrg found the right Hardware. I use this Trackball since Kernel 2.xx whitout Problems. I dont need any "special key or funktion" on my Mouse. I use only the 2 Buttons.

[  4599.908] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input14/event14"
[  4599.908] (II) XINPUT: Adding extended input device "ImExPS/2 Logitech Explorer Mouse" (type: MOUSE, id 13)
[  4599.908] (II) evdev: ImExPS/2 Logitech Explorer Mouse: initialized for relative axes.
[  4599.908] (**) ImExPS/2 Logitech Explorer Mouse: (accel) keeping acceleration scheme 1
[  4599.908] (**) ImExPS/2 Logitech Explorer Mouse: (accel) acceleration profile 0
[  4599.908] (**) ImExPS/2 Logitech Explorer Mouse: (accel) acceleration factor: 2.000
[  4599.908] (**) ImExPS/2 Logitech Explorer Mouse: (accel) acceleration threshold: 4
[  4599.908] (II) config/udev: Adding input device ImExPS/2 Logitech Explorer Mouse (/dev/input/mouse0)
[  4599.908] (II) No input driver specified, ignoring this device.
[  4599.908] (II) This device may have been added with another device file.
[  4599.908] (II) config/udev: Adding input device PC Speaker (/dev/input/event10)
[  4599.908] (II) No input driver specified, ignoring this device.
[  4599.908] (II) This device may have been added with another device file.
[  4600.484] (II) evdev: ImExPS/2 Logitech Explorer Mouse: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: Eee PC WMI hotkeys: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: HID 046a:0023: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: HID 046a:0023: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: UVC Camera (046d:081b): Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: Power Button: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: Video Bus: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.484] (II) evdev: Power Button: Close
[  4600.484] (II) UnloadModule: "evdev"
[  4600.686] (EE) Server terminated successfully (0). Closing log file.

#Quest me if like to look to my logfile. i cant attach the file here.

thanks in advanced....
and a Happy GNU Year


“The internet is a reflection of our society and that mirror is going to be reflecting what we see.
If we do not like what we see in that mirror the problem is not to fix the mirror, we have to fix society.” Vint Cerf

Offline

#2 2014-01-04 16:50:09

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,232

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

What everything does not work or is very slow: focus of the mouse, click in an inactive window, context menu click reacts only after 5

On KDE i don't have this Problems

Have you had a look at the Mouse settings at Settings Manager -> Mouse and Touchpad?

The problem occurs temporarily. but at least 30 - 40 times a day

This is interesting. You didn't mention which distro you are using, but when this happens, is there anything in your other log files (.xsession-errors/syslog/journal/etc)?
Also, have a look at your cpu load using "top". Is something possibly hogging all cpu cycles slowing down system response time?

Offline

#3 2014-01-05 15:44:17

majestyx
Member
Registered: 2013-12-03
Posts: 18
Website

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

Settings Manager -> Mouse and .... #facepalm

OK, after i take a look to, i found two device (name) one is my logitech, but the other one: I do not know. The Name is: HDI 046a:0023
IMHO: i must logout/logon on XFCE for the new settings.

My Distro is: Debian Jessi, My CPU Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz & 8GB RAM are enough for XFCE ? wink


“The internet is a reflection of our society and that mirror is going to be reflecting what we see.
If we do not like what we see in that mirror the problem is not to fix the mirror, we have to fix society.” Vint Cerf

Offline

#4 2014-01-06 03:25:14

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,232

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

Your computer is powerful enough for Xfce - no worries there.

Did changing the settings in "Settings Manager -> Mouse and Touchpad" help?

Offline

#5 2014-01-06 10:24:26

majestyx
Member
Registered: 2013-12-03
Posts: 18
Website

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

Moin ToZ, i give you yesterday only a 1/2 answer. sorry. i had a big rsync job on a shell (overnight) now, the second half of my answer:

on settings -> mouse & touch pad i change the device (HDI 046a:0023) to my logitech mouse. but after a logout/login to XFCE the default device in Settings-Mouse & Touch pad was the HDI 046a:0023 again ?!
ok, in the settings->mouse & touchp.. i disable the device HDI 046a:0023.

But, nothing helps sad

i do a "tail -f" on /messages or /syslog ... the only was i found was a ....

rsyslogd was HUPed

https://bugs.launchpad.net/ubuntu/+sour … bug/928404 - at comments somebody write Debian...

since yesterday i have a kernel update -> 3.12-1-amd64 #1 SMP Debian 3.12.6-2 (2013-12-29) x86_64 GNU/Linux

but this has brought no improvement sad


“The internet is a reflection of our society and that mirror is going to be reflecting what we see.
If we do not like what we see in that mirror the problem is not to fix the mirror, we have to fix society.” Vint Cerf

Offline

#6 2014-01-06 14:08:24

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 296

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

Doing a web search for 046a:0023 produces several results. You can probably make more sense out of them with a computer monitor than I can with my little cell phone, lol, but I figure - since that appears to be the odd thing in your equation - that you might learn something useful.

Regards,
MDM

PS   When my laptop was still functioning okay, I had no trouble running XFCE (Mint 14), and it's a 10(+?)-year old Pentium 4 with only 768 megabytes of RAM (and that shared with the graphics), so yes, lol, you have "enough" computer to use XFCE.

Last edited by MountainDewManiac (2014-01-06 14:13:11)

Offline

#7 2014-01-06 17:37:20

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,232

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

majestyx wrote:

on settings -> mouse & touch pad i change the device (HDI 046a:0023) to my logitech mouse. but after a logout/login to XFCE the default device in Settings-Mouse & Touch pad was the HDI 046a:0023 again ?!
ok, in the settings->mouse & touchp.. i disable the device HDI 046a:0023.

But, nothing helps sad

You can also try deleting the ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml file before you login (from a virtual console - Ctrl+Alt+F1). Then when you login again to Xfce, the known devices in Mouse & Touchpad will be reset.

Offline

#8 2014-01-07 09:42:19

majestyx
Member
Registered: 2013-12-03
Posts: 18
Website

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

Moin ToZ and all other readers.....

since "ealier" this morning i can work whit xfce. I'll be watching this
I give tonight again modest


“The internet is a reflection of our society and that mirror is going to be reflecting what we see.
If we do not like what we see in that mirror the problem is not to fix the mirror, we have to fix society.” Vint Cerf

Offline

#9 2014-01-10 15:24:59

majestyx
Member
Registered: 2013-12-03
Posts: 18
Website

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

so, i am testing two days, befor i post this msg.

hint: since 6years! i use the same keyboard & trackball model. whit gnu/linux - whiteout any problem. my cherry keyboard is not plastic. thats very important to me. on my cherry metal i have ""mmx-keys" I've never used...

I replace the keyboard mmx against a standard keyboard (here: logitech plastic) and such a mouse, XFCE works fine..... i hope after the next xorg update/upgrade i can re-use my default "computer cutlery" wink

A BIG Thanks to ToZ and all other helpers....


“The internet is a reflection of our society and that mirror is going to be reflecting what we see.
If we do not like what we see in that mirror the problem is not to fix the mirror, we have to fix society.” Vint Cerf

Offline

#10 2014-01-14 03:13:05

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 296
Website

Re: [Solved] My Mouse, XOrg and XFCE not want to play together

I doubt that this is what's causing your difficulty, but it's always best to make sure.  Run this command in a terminal (You don't need root access for it.) and let us know what the response is:

lspci | grep VGA

This will tell us what VGA card/chipset you're using because ATI and nVidia chipsets need proper, proprietary drivers for best results.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

Board footer

Powered by FluxBB