Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-01-06 20:25:29

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 54

terminal won't stay 'root'

All,

A minor irritant: If I open a terminal then 'su root', after some period of time it drops me back to user 'ray'. Is there any way I can stop that?  Note, if I open terminals using the 'Root Terminal' icon, the terminals stay 'root', which is of course fine.  I have " ... !authenticate" set in my sudoers file, and that seems to work, because if I open, say, GParted I'm not bothered for a PW. Everything is fine except for this loosing of 'root' at a normal terminal.

Offline

#2 2014-01-07 01:04:19

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 210
Website

Re: terminal won't stay 'root'

You don't say which distro you are using but that shouldn't make a difference although it may be a distro issue.
I don't think you need to use 'su root' just 'su' or 'su -' should work. I use 'su -' on Fedora and never have a problem.

Offline

#3 2014-01-07 06:33:36

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 265

Re: terminal won't stay 'root'

Running a terminal "as root" is like, say, su gedit (well, gksu gedit, I suppose) in a non-root terminal. Gedit will be running with root permission as long as it's running.

If you su (et cetera) in a terminal, you're a normal user doing something with root permission. Or superuser permission, whatever, but you are not root user.

Some systems are set up to make you do it every time you want it, some to give you permissions for n amount of time, some for the duration until you close the terminal (maybe even until you log out, I cannot remember for sure).

It is a configurable setting. I'm pretty sure it's generic (available in all distros). I don't remember how to change it. I only read about it because the distro that I used previously required a password for something, a user didn't like that and asked how to change things so es didn't have to enter the password every time (but did have to enter it the first time). Someone else replied with how to do what es wanted and provided additional background.

You might do a web search for something like root (or su, gksu, etc.) permission expiration (time period, etc.). I'm sure it has been mentioned that you'll find several threads on various web forums if you hit upon the correct search terms.

If/when you do find out how to change the setting, others might appreciate it if you posted what you found.

Regards,
MDM

Offline

#4 2014-01-07 16:25:41

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 54

Re: terminal won't stay 'root'

Thanks Gentlemen,

But I'd say that 'su root' means you *are* root, whereas 'sudo ...' is, as you say, just root permission  Anyway I'm running LMDE, and you never know at what 'level' this thing is set. Linux? Debian? Mint? Xfce? Terminal itself?  However this only bothers me with xfce Terminal, nothing else 'looses' the 'su root' after a time, so I'm 'blaming' xfce.  If  I do find a solution,  I will  post it.  And anyway it's not that big a deal, I can always just open another terminal with gksu, and as I said, those stay root.

Last edited by rayandrews (2014-01-07 16:32:19)

Offline

Board footer

Powered by FluxBB