Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-03-10 18:34:20

JRG
Member
Registered: 2014-03-10
Posts: 3

[Solved] Window does not follow mouse-pointer when dragging

When I move a window by left-clicking on the title-bar and holding the mouse button down, the behaviour is hard for me to control.

Specifically, the impression I get is of using a slingshot. When I stop moving the mouse, the window continues to move before coming to rest — almost as if it had momentum and all I'm doing with the click-and-drag is giving it  shove (and friction causes it to come to rest).

I have described it this way because I don't know what this effect is called. Maybe I don't like the effect because I'm no longer a young man, but I suspect I would never have liked it. I've gone through settings and changed most of the parameters to suit my likes (and dislikes smile ), but I cannot find anywhere to turn this effect off.

I've done Internet searches, searched the topics in this forum and done a "search" of the forum — nothing. Perhaps the problem is not knowing the technical term for this behaviour.

Can anyone tell me how to stop this behaviour?
_________________

Distribution: SolydX (201401) — which is the latest release. Reported by SysInfo as "SolydXK 1 (testing)".
Kernel: 3.11-2-amd64
GCC Version: 4.8 (x86.64-linux-gnu)
Memory: 4 GB
Processor: AMD Turion 64 X2 Mobile Technology TL-60 (Dual core, 800 MHz)
Xfce: 4.10 (as reported by "About Xfce")

Offline

#2 2014-03-11 02:12:08

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,132

Re: [Solved] Window does not follow mouse-pointer when dragging

Xfce doesn't have this kind of effect. A few things come to mind that might be causing this:

1. Compiz effects. Have you installed and do you have compiz running? It might come with such an effect.

2. Runaway process. Run "top" in a terminal window and see if you have some process running that it using 100% of the processor. This might be a delay due to limited processing time available for window management.

3. Video driver. What video card do you have and what driver is installed? This command should help:

lspci -k | grep -iA2 VGA

Offline

#3 2014-03-13 23:41:15

JRG
Member
Registered: 2014-03-10
Posts: 3

Re: [Solved] Window does not follow mouse-pointer when dragging

Because of a problem (Firefox + Java - not handling Java plugin), I reverted to 'Linux Mint 16 ("Petra") Xfce 64-bit'. A side effect was that this problem "went away". I'm going to mark this solved (a bit of a misnomer, but...).

The problem occurred under SolydX (Debian-based).

Thank you for replying and attempting to help. I'll come back to this post if I retry SolydX in the future (I really liked it, but the Firefox problem was critical for me).

Offline

Board footer

Powered by FluxBB