Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-03-09 10:31:12

Fronzo
Member
Registered: 2014-03-09
Posts: 7

Max vertically gap problem with terminal

Hi all,
I'm using xfce 4.10 on openSUSE 13.10.

Maximizing terminal window creates a strange gap over it.
I tried to change the number of terminal's rows, desktops margins (workspaces option) and xfce bar height...
I encountered the same problem in the latest LinuxMint.

What sould I do now?

Sorry for my bad english, I often mispell.

Screenshot here

Offline

#2 2014-03-09 15:20:35

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Max vertically gap problem with terminal

That usually happens when you have margin values set in Settings Manager -> Workspaces -> Margins. Try adjusting those values.

Offline

#3 2014-03-10 13:57:23

Fronzo
Member
Registered: 2014-03-09
Posts: 7

Re: Max vertically gap problem with terminal

As I wrote, I've already tried it.
Today I installed terminator, and it does the same thing.

Xfce's mistery...I'll keep updated this post until I find the solution.

Offline

#4 2014-03-10 14:17:47

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Max vertically gap problem with terminal

Can you post back the results of the following commands so we can double-check your settings:

xfconf-query -c xfwm4 -lv
xfconf-query -c xfce4-panel -p /panels -lv

Offline

#5 2014-03-10 14:45:47

Fronzo
Member
Registered: 2014-03-09
Posts: 7

Re: Max vertically gap problem with terminal

Here it is:

los@Host-001:~> xfconf-query -c xfwm4 -lv
/general/activate_action                 bring
/general/borderless_maximize             true
/general/box_move                        false
/general/box_resize                      false
/general/button_layout                   CMH|
/general/button_offset                   0
/general/button_spacing                  0
/general/click_to_focus                  true
/general/cycle_apps_only                 false
/general/cycle_draw_frame                true
/general/cycle_hidden                    true
/general/cycle_minimum                   true
/general/cycle_workspaces                false
/general/double_click_action             maximize
/general/double_click_distance           5
/general/double_click_time               400
/general/easy_click                      Alt
/general/focus_delay                     250
/general/focus_hint                      true
/general/focus_new                       true
/general/frame_opacity                   100
/general/full_width_title                true
/general/inactive_opacity                100
/general/margin_bottom                   0
/general/margin_left                     0
/general/margin_right                    0
/general/maximized_offset                0
/general/mousewheel_rollup               true
/general/move_opacity                    100
/general/placement_mode                  center
/general/placement_ratio                 20
/general/popup_opacity                   100
/general/prevent_focus_stealing          false
/general/raise_delay                     250
/general/raise_on_click                  true
/general/raise_on_focus                  false
/general/raise_with_any_button           true
/general/repeat_urgent_blink             false
/general/resize_opacity                  100
/general/restore_on_move                 true
/general/scroll_workspaces               true
/general/shadow_delta_height             0
/general/shadow_delta_width              0
/general/shadow_delta_x                  0
/general/shadow_delta_y                  -3
/general/shadow_opacity                  50
/general/show_app_icon                   false
/general/show_dock_shadow                false
/general/show_frame_shadow               true
/general/show_popup_shadow               true
/general/snap_resist                     false
/general/snap_to_border                  true
/general/snap_to_windows                 false
/general/snap_width                      10
/general/theme                           Numix
/general/tile_on_move                    true
/general/title_alignment                 right
/general/title_font                      Sans Bold 9
/general/title_horizontal_offset         0
/general/title_shadow_active             false
/general/title_shadow_inactive           false
/general/title_vertical_offset_active    0
/general/title_vertical_offset_inactive  0
/general/toggle_workspaces               false
/general/unredirect_overlays             true
/general/urgent_blink                    false
/general/use_compositing                 true
/general/workspace_count                 4
/general/workspace_names                 <<UNSUPPORTED>>
/general/wrap_cycle                      true
/general/wrap_layout                     true
/general/wrap_resistance                 10
/general/wrap_windows                    false
/general/wrap_workspaces                 false
los@Host-001:~> xfconf-query -c xfce4-panel -p /panels -lv
/panels                           <<UNSUPPORTED>>
/panels/panel-1/autohide          false
/panels/panel-1/background-alpha  100
/panels/panel-1/background-color  <<UNSUPPORTED>>
/panels/panel-1/background-style  0
/panels/panel-1/disable-struts    false
/panels/panel-1/enter-opacity     100
/panels/panel-1/leave-opacity     100
/panels/panel-1/length            100
/panels/panel-1/length-adjust     false
/panels/panel-1/mode              0
/panels/panel-1/plugin-ids        <<UNSUPPORTED>>
/panels/panel-1/position          p=6;x=720;y=13
/panels/panel-1/position-locked   true
/panels/panel-1/size              24

Offline

#6 2014-03-10 16:00:25

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Max vertically gap problem with terminal

Nothing looks out of the ordinary there. Does the problem persist if you use another theme?

Offline

#7 2014-03-16 15:36:13

Fronzo
Member
Registered: 2014-03-09
Posts: 7

Re: Max vertically gap problem with terminal

Here I am.
Yes, the problem remains even by changing the theme.

Offline

#8 2014-03-16 19:10:28

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Max vertically gap problem with terminal

For xfce4-terminal, can you post back your ~/.config/xfce4/terminal/terminalrc file?

Do you have dual screens? If so, can you also post back:

xrandr -q

Last edited by ToZ (2014-03-16 19:10:43)

Offline

#9 2014-03-20 09:46:04

Fronzo
Member
Registered: 2014-03-09
Posts: 7

Re: Max vertically gap problem with terminal

los@LOS-PC:~> cat ~/.config/xfce4/terminal/terminalrc
[Configuration]
MiscAlwaysShowTabs=FALSE
MiscBell=FALSE
MiscBordersDefault=TRUE
MiscCursorBlinks=FALSE
MiscCursorShape=TERMINAL_CURSOR_SHAPE_BLOCK
MiscDefaultGeometry=70x43
MiscInheritGeometry=FALSE
MiscMenubarDefault=TRUE
MiscMouseAutohide=FALSE
MiscToolbarDefault=FALSE
MiscConfirmClose=TRUE
MiscCycleTabs=TRUE
MiscTabCloseButtons=TRUE
MiscTabCloseMiddleClick=TRUE
MiscTabPosition=GTK_POS_TOP
MiscHighlightUrls=TRUE
ColorPalette=#000000;#cc0000;#4e9a06;#c4a000;#3465a4;#75507b;#06989a;#d3d7cf;#555753;#ef2929;#8ae234;#fce94f;#739fcf;#ad7fa8;#34e2e2;#eeeeec
ColorBackground=#2d2d2d2d2d2d
ColorBoldUseDefault=FALSE
ColorSelectionUseDefault=FALSE

No, I always use a single screen. The OS is installed in a USB which I use in many PCs (work, school, home..), however, the single-display config has never been changed.

Offline

#10 2014-03-20 10:31:53

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,171

Re: Max vertically gap problem with terminal

Tried your terminalrc file and it worked okay for me. Any chance I could get a quick look at:

xrandr -q

...just to see if all is okay there?

Offline

#11 2014-03-24 15:52:45

Fronzo
Member
Registered: 2014-03-09
Posts: 7

Re: Max vertically gap problem with terminal

los@LOS-PC:~> xrandr -q
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 8192 x 8192
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       59.9*+   75.0  
   1280x1024      76.0     75.0     72.0     60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
   640x350        70.1  

I really can't understand. I'll try to the openSUSE forums, maybe there's the solution!

Offline

Board footer

Powered by FluxBB