Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-03-16 22:49:52

Ander111
Member
Registered: 2013-03-05
Posts: 17

Puleeeze---a way to remap Ctrl+W?

Hi guys,

Like many of you, I vastly prefer keyboard shortcuts over using the mouse---this is good, right?

For years, I've been using the Ctrl+W shortcut to close files within an app---browsers, text editors, word processors, any app capable of opening multiple documents.

I've now found that here in XFCE (maybe Linux in general?), Ctrl+W closes the entire app. I don't know why it does this. Some apps even show Ctrl+W on their menus for "Close File", not "Quit" (usually Ctrl+Q).

I've found it impossible to break this habit. Consequently, I keep closing entire sets of webpages and documents without intending to. It's quite frustrating.

Is there a way to globally remap Ctrl+W so it closes the current tab or file? Please say yes. You can do anything in Linux, right...? Thanks, Ander

Offline

#2 2014-03-17 02:56:45

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,242

Re: Puleeeze---a way to remap Ctrl+W?

I've now found that here in XFCE (maybe Linux in general?), Ctrl+W closes the entire app.

On my install, Arch + 4.10, Ctrl+w closes the tab, but if it is the last tab, it closes the window (prompting to save if the document needs saving). Sounds logical. I've tried this with:
- firefox
- mousepad
- libreoffice writer.
When did this first start happening? On a new Xfce install?


Perhaps you can give us more info about your setup: distro, Xfce version, apps that are causing this problem?
And have you tried creating a new account on your computer to see if the problem persists with a pristine profile?

Offline

#3 2014-03-17 06:05:25

Ander111
Member
Registered: 2013-03-05
Posts: 17

Re: Puleeeze---a way to remap Ctrl+W?

ToZ wrote:

On my install, Arch + 4.10, Ctrl+w closes the tab, but if it is the last tab, it closes the window (prompting to save if the document needs saving)...

Yes, I understand that behaviour. Again though, a single Ctrl+W closes the whole app here, even with multiple tabs open.

ToZ wrote:

When did this first start happening? On a new Xfce install?

It started happening shortly after I started using Linux Mint XFCE 16. It never happened in 15.

ToZ wrote:

Perhaps you can give us more info about your setup: distro, Xfce version, apps that are causing this problem?

I'm running XFCE 4.10. It's happening with most multi-document apps, including Gedit, Firefox, Chrome—even the Windows text editor I've been using with WINE. Only in LibreOffice apps, for some reason, is Ctrl+W behaving normally and closing only the current document.

ToZ wrote:

And have you tried creating a new account on your computer to see if the problem persists with a pristine profile?

I'd be glad to try that—but first I'll have to figure out how to create a new account, as there's no obvious way—nothing in Settings Manager or the System section of the menu...

Okay, I've found a post here that says to use the "Users and Groups" utility. For some reason, though, Mint XFCE doesn't include it. Okay, I've looked further and learned I can add it by installing gnome-system-apps; doing that...

Okay, I've created a new account. When I log on to it, though, I get the Mint welcome window, then just a mouse pointer and a black screen... Okay, I'm switching to a command line (Ctrl+Alt+F1, etc.) and restarting (sudo shutdown now -r)... (I can't help wondering, what do people new to Linux do when they thrash around with all this? Cold resets, I guess...)

Logging back in to my normal account... Looking online for more solutions... I've Googled "mint xfce create account" (w/o the quotes), but no relevant results...

Checking the XFCE section at the Mint Forum... They say to use adduser at a command line... Okay, I've created a new account that way, but I get the same black screen when I try to use it. I've searched that forum for more details, found nothing... On non-Mint XFCE forums, everyone says the aforementioned methods work fine. I've posted a question on the Mint XFCE forum—it seems amazing to have to do that—but meanwhile, do you have any other ideas? Thanks. [Refraining from making "Welcome to Linux" jokes]

Last edited by Ander111 (2014-03-18 04:40:09)

Offline

#4 2014-03-17 12:00:16

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,242

Re: Puleeeze---a way to remap Ctrl+W?

Did you do an in-place upgrade to Mint 16 or was it a fresh install?

I just installed Mint 16 on a spare computer and it works as advertised, so I believe it is an issue with your profile. I don't know why you get a black screen when you try to login as a new user, hopefully someone at the Mint forums can help you get that sorted out. Out of curiosity, have you tried rebooting and then logging in as the new user as your first login?

In the meantime, to check a few more things with your profile, can you post back a listing of your keyboard shortcuts:

xfconf-query -c xfce4-keyboard-shortcuts -lv

Offline

#5 2014-03-18 05:09:39

Ander111
Member
Registered: 2013-03-05
Posts: 17

Re: Puleeeze---a way to remap Ctrl+W?

ToZ wrote:

Did you do an in-place upgrade to Mint 16 or was it a fresh install?

I installed Mint XFCE 16 RC2, then dist-upgraded when the full release was, er, released.

ToZ wrote:

I just installed Mint 16 on a spare computer and it works as advertised, so I believe it is an issue with your profile. I don't know why you get a black screen when you try to login as a new user, hopefully someone at the Mint forums can help you get that sorted out.

It may be moot now... The only reason I wanted to create a new user was to try your suggestion, to see if Ctrl+W still did what it's doing.

ToZ wrote:

Out of curiosity, have you tried rebooting and then logging in as the new user as your first login?

Just tried it; no difference.

ToZ wrote:

In the meantime, to check a few more things with your profile, can you post back a listing of your keyboard shortcuts:

xfconf-query -c xfce4-keyboard-shortcuts -lv

Here you go:

$ xfconf-query -c xfce4-keyboard-shortcuts -lv
/commands/custom/<Alt>F1                  xfce4-popup-applicationsmenu
/commands/custom/<Alt>F2                  xfce4-appfinder --collapsed
/commands/custom/<Alt>F3                  xfce4-appfinder
/commands/custom/override                 true
/commands/custom/<Primary><Alt>Delete     xflock4
/commands/custom/<Primary><Alt>g          gedit
/commands/custom/<Primary><Alt>p          /home/zippy/Documents/toggle_hide_panel 1
/commands/custom/<Primary>Escape          xfdesktop --menu
/commands/custom/Print                    xfce4-screenshooter
/commands/custom/Super_L                  xfce4-popup-whiskermenu
/commands/custom/<Super>p                 xfce4-display-settings --minimal
/commands/custom/XF86Display              xfce4-display-settings --minimal
/commands/custom/XF86Mail                 exo-open --launch MailReader
/commands/custom/XF86WWW                  exo-open --launch WebBrowser
/providers                                <<UNSUPPORTED>>
/xfwm4/custom/<Alt><Control>End           move_window_next_workspace_key
/xfwm4/custom/<Alt><Control>Home          move_window_prev_workspace_key
/xfwm4/custom/<Alt><Control>KP_1          move_window_workspace_1_key
/xfwm4/custom/<Alt><Control>KP_2          move_window_workspace_2_key
/xfwm4/custom/<Alt><Control>KP_3          move_window_workspace_3_key
/xfwm4/custom/<Alt><Control>KP_4          move_window_workspace_4_key
/xfwm4/custom/<Alt><Control>KP_5          move_window_workspace_5_key
/xfwm4/custom/<Alt><Control>KP_6          move_window_workspace_6_key
/xfwm4/custom/<Alt><Control>KP_7          move_window_workspace_7_key
/xfwm4/custom/<Alt><Control>KP_8          move_window_workspace_8_key
/xfwm4/custom/<Alt><Control>KP_9          move_window_workspace_9_key
/xfwm4/custom/<Alt>Delete                 del_workspace_key
/xfwm4/custom/<Alt>F10                    maximize_window_key
/xfwm4/custom/<Alt>F11                    fullscreen_key
/xfwm4/custom/<Alt>F12                    above_key
/xfwm4/custom/<Alt>F4                     close_window_key
/xfwm4/custom/<Alt>F6                     stick_window_key
/xfwm4/custom/<Alt>F7                     move_window_key
/xfwm4/custom/<Alt>F8                     resize_window_key
/xfwm4/custom/<Alt>F9                     hide_window_key
/xfwm4/custom/<Alt>Insert                 add_workspace_key
/xfwm4/custom/<Alt><Shift>Tab             cycle_reverse_windows_key
/xfwm4/custom/<Alt>space                  popup_menu_key
/xfwm4/custom/<Alt>Tab                    cycle_windows_key
/xfwm4/custom/<Control><Alt>d             show_desktop_key
/xfwm4/custom/<Control><Alt>Down          down_workspace_key
/xfwm4/custom/<Control><Alt>Left          left_workspace_key
/xfwm4/custom/<Control><Alt>Right         right_workspace_key
/xfwm4/custom/<Control><Alt>Up            up_workspace_key
/xfwm4/custom/<Control>F1                 workspace_1_key
/xfwm4/custom/<Control>F10                workspace_10_key
/xfwm4/custom/<Control>F11                workspace_11_key
/xfwm4/custom/<Control>F12                workspace_12_key
/xfwm4/custom/<Control>F2                 workspace_2_key
/xfwm4/custom/<Control>F3                 workspace_3_key
/xfwm4/custom/<Control>F4                 workspace_4_key
/xfwm4/custom/<Control>F5                 workspace_5_key
/xfwm4/custom/<Control>F6                 workspace_6_key
/xfwm4/custom/<Control>F7                 workspace_7_key
/xfwm4/custom/<Control>F8                 workspace_8_key
/xfwm4/custom/<Control>F9                 workspace_9_key
/xfwm4/custom/<Control><Shift><Alt>Left   move_window_left_key
/xfwm4/custom/<Control><Shift><Alt>Right  move_window_right_key
/xfwm4/custom/<Control><Shift><Alt>Up     move_window_up_key
/xfwm4/custom/Down                        down_key
/xfwm4/custom/Escape                      cancel_key
/xfwm4/custom/Left                        left_key
/xfwm4/custom/override                    true
/xfwm4/custom/<Primary>w                  close_window_key
/xfwm4/custom/Right                       right_key
/xfwm4/custom/<Shift><Alt>Page_Down       lower_window_key
/xfwm4/custom/<Shift><Alt>Page_Up         raise_window_key
/xfwm4/custom/<Super>Tab                  switch_window_key
/xfwm4/custom/Up                          up_key

Ah, I see that Ctrl+W is "close_window_key". How can I change that? No commands related to closing tabs or windows are available in Keyboard settings > Application Shortcuts.

Offline

#6 2014-03-18 10:34:18

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,242

Re: Puleeeze---a way to remap Ctrl+W?

The first thing to try is to go to Settings Manager -> Settings Editor and search for it in the xfce4-keyboard-shortcuts channel, highlight it and select "Reset".

If that doesn't work, then from outside of Xfce (don't be logged in - use Ctrl+Alt+F1), delete the entry from ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml (make a backup of this file first before you begin).

Offline

#7 2014-03-18 22:57:49

Ander111
Member
Registered: 2013-03-05
Posts: 17

Re: Puleeeze---a way to remap Ctrl+W?

ToZ wrote:

The first thing to try is to go to Settings Manager -> Settings Editor and search for it in the xfce4-keyboard-shortcuts channel, highlight it and select "Reset".

I tried that, but it had no effect.

ToZ wrote:

If that doesn't work, then from outside of Xfce (don't be logged in - use Ctrl+Alt+F1), delete the entry from ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml (make a backup of this file first before you begin).

I backed up and deleted the file as you suggested. When I logged back in:

• Ctrl+W still closed windows.

• My CapsLock key was locked "on".

So first, I searched for a way to turn off CapsLock. In the process, I learned about Linux's "compose key" feature, which lets you quickly enter symbols by using the key you designate in XFCE's Keyboard > Layout. Cool! Till now, for example, I was typing all this just to enter a single long dash (via Unicode entry):

Ctrl+Shift+u

Fn+Alt+2014

Now it's just a simple key-combination. So, thanks for that!

Moving along... I decided to throw caution to the wind and edit the xml file myself. It seemed pretty obvious; in this line:

<property name="&lt;Primary&gt;w" type="string" value="close_window_key"/>

...I changed "gt;w" to "gt;q". I logged out and back in again—and it worked! Now Ctrl+Q closes windows and Ctrl+W closes the current tab again (having released it, I imagine, to work on a per-app basis). Thanks!

Offline

Board footer

Powered by FluxBB