Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-04-11 10:07:31

tikoti
Member
Registered: 2014-04-11
Posts: 2

xfrun4 doesn' read .bashrc

Hi!

This is kind of an old problem, but I can not find any solution to it

I have my ~/bin folder defined in .bashrc in order to launch certain applications. This works nicely but xfrun4 doesnt seem to read .bashrc and I am unable to launch them with it

Could you give me any hint on how to procced?

Thanks!

Offline

#2 2014-04-11 10:43:10

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,273

Re: xfrun4 doesn' read .bashrc

There was a bug report for this but was marked invalid because:

No bug here.  NULL in envp means "use the current environment."  Likely xfrun4 is getting started by dbus-daemon, which is getting started before the user's PATH is getting set up.  Or, more likely, ~/.bashrc isn't sourced by Xfce's init script.  You'll need to get the directory in PATH via some other means.

Comment #11 here offers a possible workaround.

Offline

#3 2014-04-11 11:06:35

tikoti
Member
Registered: 2014-04-11
Posts: 2

Re: xfrun4 doesn' read .bashrc

I've already checked seen that, but unfortunately the solution proposed doesnt work for me

I've tried to insert in both /etc/profile and ~/.profile but apparently it doesnt read from them either

Offline

#4 2014-04-11 12:38:54

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,273

Re: xfrun4 doesn' read .bashrc

Here is something interesting:

With Arch Linux (xfce4-appfinder version 4.10.1-1 & slim as DM), xfrun4 doesn't find executables in ~/bin.
With Xubuntu 14.04 (xfce4-appfinder version 4.10.1-1 and lightdm as DM), xfrun4 works fine.
It obviously has something to do with the way dbus is started.

However, on my Arch install, I added to the end of /etc/profile:

PATH="~/bin:$PATH"
export PATH

...rebooted, and it started to work as well.

Which distro are you using?

Offline

Board footer

Powered by FluxBB