Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-04-16 02:54:30

dleclair
Member
Registered: 2014-04-16
Posts: 7

can't enable event sounds

I'm a first-time user of XFCE. I'm running version 4.10 on CentOS 6.5 on an HP EliteBook 840 G1 ultrabook with Intel integrated audio.

The sound card is working fine. I'm getting audio when watching youtube videos and I can play audio files with 'aplay' just fine.The problem I'm having is with event sounds. In GNOME the event sounds are working fine but in XFCE all I get are beeps from the PC speaker.

I found several posts online advising to go to 'Appearance' options under the Settings Manager application and then to go to the 'Settings' tab and check the box for 'enable event sounds'.

1. Enable "Event Sounds" in Settings Manager -> Appearance -> Settings

But when I go that menu screen there is no option for enabling event sounds. I've taken a screen capture of what my options screen looks like.
1zoeqnb.jpg

Given that I've confirmed the sound card and driver are working properly, I'm assuming I'm just missing a simple setting somewhere but I'm not sure where to look next.

Any help would be appreciated.

Offline

#2 2014-04-16 03:12:37

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,109

Re: can't enable event sounds

Where did you get the Xfce packages from? The EPEL repo? The problem is that xfce4-settings package wasn't compiled with the "--enable-sound-settings" build option.

Offline

#3 2014-04-16 13:08:29

dleclair
Member
Registered: 2014-04-16
Posts: 7

Re: can't enable event sounds

Ah yes, that must be it. I couldn't find any packages for 4.10 so I downloaded the 4.8 src rpms and the 4.10 tarballs and compiled them from source. I must have missed including the enable-sound-settings option.

I will try that and update this thread with my results.

Offline

#4 2014-04-16 13:41:45

dleclair
Member
Registered: 2014-04-16
Posts: 7

Re: can't enable event sounds

Ok, I've added the enable-sound-settings build flag and indeed it fixed the problem of not seeing the 'Enable event sounds' checkbox in the Appearance menu.

However, now that I have the option set in the 'Appearance' menu, I'm still only getting the PC speaker beeps instead of .wav sounds. For example, when I'm in my terminal screen and I hit backspace at the beginning of the command line I'm getting the PC speaker beep instead of a nicer sound from the sound card. When I click on the 'Drip' line in the 'Sound Preferences' menu I can hear the Drop sound just fine but it never plays when I'm interacting with the UI.

Any suggestions on what  I should look at to troubleshoot this?

29wthle.png

Offline

#5 2014-04-16 14:07:20

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,109

Re: can't enable event sounds

That "Sound Preferences" app in your screenshot is for the gnome environment. I'm pretty sure that it won't work on Xfce. To configure sound effects in Xfce, have a look at this thread. Unfortunately, its a manual process. It works on Arch and Xubuntu and maybe on Fedora. I've never done this with CentOS. You'll be a trail blazer.

Last edited by ToZ (2014-04-16 14:07:44)

Offline

#6 2014-04-17 04:24:27

dleclair
Member
Registered: 2014-04-16
Posts: 7

Re: can't enable event sounds

ToZ,

In your instructions on the other post you say:

"2. Set "xsettings/Net/SoundThemeName" in the Settings Manager (to a sound theme located in /usr/share/sounds)."

I don't see where to set that setting in Settings Manager? Could this be another build option that I missed or is it just hiding on me?

Offline

#7 2014-04-17 10:28:32

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,109

Re: can't enable event sounds

What does the following return?

xfconf-query -c xsettings -lv

I'll look to see if I can find when and where this property is created.

EDIT: Looks like its created when you compile xfce4-settings (see: http://git.xfce.org/xfce/xfce4-settings … ttings.xml). There doesn't seem to be a specific build option to enable this, it should automatically be created.

Last edited by ToZ (2014-04-17 10:35:09)

Offline

#8 2014-04-17 13:25:20

dleclair
Member
Registered: 2014-04-16
Posts: 7

Re: can't enable event sounds

Hmmm...maybe it's working more than I think. I'm pretty sure when I loaded up Thurnderbird this morning that I got a sound out from the sound card. Are there any other kinds of events that I can test to confirm whether it's working or not?

The one test I've been using thus far has been to try backspacing beyond the start of the command line in my terminal window. When I do that all I get is a beep out of the PC speaker so I was just assuming that it wasn't working. But maybe that's not a good enough test.

In any case, here is the output of my xfconf-query:

[dleclair@dleclair-lptp Desktop]$ xfconf-query -c xsettings -lv
/Gtk/ButtonImages               true
/Gtk/CanChangeAccels            true
/Gtk/ColorPalette               black:white:gray50:red:purple:blue:light blue:green:yellow:orange:lavender:brown:goldenrod4:dodger blue:pink:light green:gray10:gray30:gray75:gray90
/Gtk/CursorThemeName            
/Gtk/CursorThemeSize            0
/Gtk/FontName                   Sans 10
/Gtk/IconSizes                  
/Gtk/IMModule                   
/Gtk/IMPreeditStyle             
/Gtk/IMStatusStyle              
/Gtk/KeyThemeName               
/Gtk/MenuBarAccel               F10
/Gtk/MenuImages                 true
/Gtk/ToolbarIconSize            3
/Gtk/ToolbarStyle               icons
/Net/CursorBlink                true
/Net/CursorBlinkTime            1200
/Net/DndDragThreshold           8
/Net/DoubleClickDistance        5
/Net/DoubleClickTime            250
/Net/EnableEventSounds          true
/Net/EnableInputFeedbackSounds  true
/Net/IconThemeName              Mist
/Net/SoundThemeName             default
/Net/ThemeName                  Mist
/Xft/Antialias                  -1
/Xft/Hinting                    -1
/Xft/HintStyle                  hintnone
/Xft/RGBA                       none
[dleclair@dleclair-lptp Desktop]$ xfconf-query -c xsettings -lv
/Gtk/ButtonImages               true
/Gtk/CanChangeAccels            true
/Gtk/ColorPalette               black:white:gray50:red:purple:blue:light blue:green:yellow:orange:lavender:brown:goldenrod4:dodger blue:pink:light green:gray10:gray30:gray75:gray90
/Gtk/CursorThemeName            
/Gtk/CursorThemeSize            0
/Gtk/FontName                   Sans 10
/Gtk/IconSizes                  
/Gtk/IMModule                   
/Gtk/IMPreeditStyle             
/Gtk/IMStatusStyle              
/Gtk/KeyThemeName               
/Gtk/MenuBarAccel               F10
/Gtk/MenuImages                 true
/Gtk/ToolbarIconSize            3
/Gtk/ToolbarStyle               icons
/Net/CursorBlink                true
/Net/CursorBlinkTime            1200
/Net/DndDragThreshold           8
/Net/DoubleClickDistance        5
/Net/DoubleClickTime            250
/Net/EnableEventSounds          true
/Net/EnableInputFeedbackSounds  true
/Net/IconThemeName              Mist
/Net/SoundThemeName             default
/Net/ThemeName                  Mist
/Xft/Antialias                  -1
/Xft/Hinting                    -1
/Xft/HintStyle                  hintnone
/Xft/RGBA                       none
[dleclair@dleclair-lptp Desktop]$ 

Offline

#9 2014-04-17 13:46:06

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,109

Re: can't enable event sounds

/Net/SoundThemeName             default

Yes, its there. You can view it via Settings Manager -> Settings Editor and under "Channel", select "xsettings" and look for it in the right pane.

One of the things that you are going to find is that the default and freedesktop sound themes are woefully lacking. If you look at my post #6 from http://forum.xfce.org/viewtopic.php?id=8618, I've shared a modified Borealis theme that links up better with the supported freedesktop sound events:

/*
We generate these sounds:
dialog-error
dialog-warning
dialog-information
dialog-question
window-new
window-close
window-minimized
window-unminimized
window-maximized
window-unmaximized
notebook-tab-changed
dialog-ok
dialog-cancel
item-selected
link-pressed
link-released
button-pressed
button-released
menu-click
button-toggle-on
button-toggle-off
menu-popup
menu-popdown
menu-replace
tooltip-popup
tooltip-popdown

With respect to thunderbird, it has a setting in preferences that allows you to set the alert notification sound.

Offline

#10 2014-04-17 15:02:24

dleclair
Member
Registered: 2014-04-16
Posts: 7

Re: can't enable event sounds

I've loaded the Borealis theme. I played some of the sounds in VLC so that I had an expectation of what I should hear. If I understand the comment in the source code file you referenced, I should be hearing sounds when I minimize and maximize windows but I don't hear anything.

Offline

#11 2014-04-17 17:23:30

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,109

Re: can't enable event sounds

Lets verify the settings. Can you post back the results of:

xfconf-query -c xsettings -p /Net/SoundThemeName
env | grep GTK_MODULE
ls /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo
which canberra-gtk-play

You should play the sound effects with canberra-gtk-play ala:

canberra-gtk-play -f /usr/share/sounds/Borealis/stereo/desktop-login.ogg

Offline

#12 2014-04-18 12:32:19

dleclair
Member
Registered: 2014-04-16
Posts: 7

Re: can't enable event sounds

Here you go:

[dleclair@dleclair-lptp Desktop]$ xfconf-query -c xsettings -p /Net/SoundThemeName
Borealis
[dleclair@dleclair-lptp Desktop]$ 
[dleclair@dleclair-lptp Desktop]$ 
[dleclair@dleclair-lptp Desktop]$ env | grep GTK_MODULE
[dleclair@dleclair-lptp Desktop]$ 
[dleclair@dleclair-lptp Desktop]$ 
[dleclair@dleclair-lptp Desktop]$ ls /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo
button-pressed.ogg        device-added.ogg        install.sh               README              trash-empty.ogg
button-toggle-off.ogg     device-removed.ogg      K3b_success.ogg          service-login.ogg   uninstall.sh
button-toggle-on.ogg      dialog-error.ogg        Knock.ogg                service-logout.ogg  window-close.ogg
desktop-login.ogg         dialog-information.ogg  Kopete_status.ogg        Startup1_1.ogg      window-maximized.ogg
desktop-logout.ogg        dialog-question.ogg     message-new-instant.ogg  Startup1_2.ogg      window-minimized.ogg
desktop-switch-left.ogg   dialog-warning.ogg      phone-incoming-call.ogg  Startup1_3.ogg      window-unmaximized.ogg
desktop-switch-right.ogg  Exit1_2.ogg             phone-outgoing-busy.ogg  system-ready.ogg    window-unminimized.ogg
[dleclair@dleclair-lptp Desktop]$ 
[dleclair@dleclair-lptp Desktop]$ 
[dleclair@dleclair-lptp Desktop]$ which canberra-gtk-play
/usr/bin/canberra-gtk-play
[dleclair@dleclair-lptp Desktop]$ ^C
[dleclair@dleclair-lptp Desktop]$ 

I am able to play the sounds with canberra-gtk-play.

Offline

#13 2014-04-18 16:38:06

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,109

Re: can't enable event sounds

The GTK_MODULE environment variable is not set. Try adding:

export GTK_MODULES=canberra-gtk-module

...to /etc/environment and rebooting.

If its being properly sourced, "env | grep GTK_MODULE" should return:

GTK_MODULES=canberra-gtk-module

Note: I don't have a centos environment handy to check if /etc/environment is sourced. If the GTK_MODULES variable is still not being set, try creating a file in /etc/profile.d for that purpose.

Offline

Board footer

Powered by FluxBB