Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-04-17 01:07:30

jimwg
Member
Registered: 2011-12-11
Posts: 54

Weather Plug-in Balks After System Re-Install

Greetings,

I am moving a saved back-up Petra Mint Home folder into a fresh Maya XFCE Mint 13 install after a crash. I'm not sure whether my Home folder's XFCE configs has anything to do with it, but after I downloaded XFCE goodies, the weather plug-in balked showing on the panel, requesting I execute it or it'll be automatically removed, and when I clicked either option the weather panel pops out. (this outage also occured before reinstalling my Home folder, using the weather plug-in that was already available from the fresh Mint install proir my downloading goodies -- had I hoped the new goodies weather plugin would "overwrite" the malfunctioning orginal one).

Users told me that weather plug-in .75(?) on down is corrupt and to use the more updated one .82 on up, but I assume that my XFCE goodies download is already updated. Also when advised to update the weather plug-in separately via "sud apt-get install xfce4-weather-plug in" it stated that I have the latest version, though I don't know exactly which that is yet. Ubuntu folks lead me to a Debian repository which supposedly has "dev builds" of .83 but the installation procedures require a PhD. What I don't understand is the weather plug-in worked just fine in my Petra installation (I'm downgrading to Maya on separate issues).

Any assist would be greatly appreciated!

Jim in NYC

Last edited by jimwg (2014-04-17 01:11:53)

Offline

#2 2014-04-17 10:24:01

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,062

Re: Weather Plug-in Balks After System Re-Install

Also when advised to update the weather plug-in separately via "sud apt-get install xfce4-weather-plug in" it stated that I have the latest version, though I don't know exactly which that is yet.

The following command will identify the version for you:

apt-cache policy xfce4-weather-plugin

Ubuntu folks lead me to a Debian repository which supposedly has "dev builds" of .83 but the installation procedures require a PhD.

Which repository would this be? Is it a PPA?

(I'm downgrading to Maya on separate issues).

Maya is based in Ubuntu 12.04 and includes Xfce 4.8 (which also includes the non-working weather plugin). Here are instructions on how to upgrade Xfce to 4.10 using a PPA. Xfce 4.10 will include a newer version of the weather plugin (0.8.3).

Offline

#3 2014-04-17 15:48:17

jimwg
Member
Registered: 2011-12-11
Posts: 54

Re: Weather Plug-in Balks After System Re-Install

apt-cache policy xfce4-weather-plugin
xfce4-weather-plugin:
  Installed: 0.7.4-5~ubuntu12.04.1
  Candidate: 0.7.4-5~ubuntu12.04.1
  Version table:
*** 0.7.4-5~ubuntu12.04.1 0

I am surprised! I thought the goodies package would have an updated plugin version that'd overwrite the older one! Had orginallly updated via  "sudo add-apt-repository ppa:xubuntu-dev/xfce-4.10" "sudo apt-get dist-upgrade" from a Ubuntu site discussion." I'll try your solution! Thanks!

Jim in NYC


I got the instructions

Offline

#4 2014-04-17 18:00:48

jimwg
Member
Registered: 2011-12-11
Posts: 54

Re: Weather Plug-in Balks After System Re-Install

jimwg wrote:

apt-cache policy xfce4-weather-plugin
xfce4-weather-plugin:
  Installed: 0.7.4-5~ubuntu12.04.1
  Candidate: 0.7.4-5~ubuntu12.04.1
  Version table:
*** 0.7.4-5~ubuntu12.04.1 0

I am surprised! I thought the goodies package would have an updated plugin version that'd overwrite the older one! Had orginallly updated via  "sudo add-apt-repository ppa:xubuntu-dev/xfce-4.10" "sudo apt-get dist-upgrade" from a Ubuntu site discussion." I'll try your solution! Thanks!

Jim in NYC

I received this after I hit : sudo add-apt-repository ppa:xubuntu-dev/xfce-4.10  sudo apt-get update

"E:Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/xubuntu-dev-xfce-4_10-precise.list"

Anything I can fix? Also, users say XFCE 4.11 seems to have desktop refinements 4.10 doesn't like desktop background controls and stuff, so I'm trying to Google a way to update to 11 as well but no simple luck!


UPDATE:

I finally got the .83 weather plugin after first erasing XFCE and reinstalling it as per your link's instruction page said. But I think I lost all the XFCE Goodies though -- because I think the bad Weather plug-in is part of the Goodies package. sad

Jim in NYC

Last edited by jimwg (2014-04-17 18:45:29)

Offline

#5 2014-04-17 21:58:14

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,062

Re: Weather Plug-in Balks After System Re-Install

xfce4-goodies is just a collection of xfce packages. You should be able to install it and the new weather plugin should not be updated based on the version number.

If that doesn't work, you can cherry-pick the individual packages from xfce4-goodies that you want and install them individually.

Offline

Board footer

Powered by FluxBB