Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-06-24 08:38:20

nlestat
Member
Registered: 2014-06-24
Posts: 2

Wrong icons in alt-tab switcher for some applications

So for some applications, appears totally random to me, stock icons are displayed in the alt-tab switcher, even though my custom selected ones appear correctly everywhere else within Xfce.

There really doesn't seem to be a rhyme or reason to it, it's just that firefox for example uses my custom icon in alt-tab, and then emacs doesn't. All the same size icons exist for both applications.

Anyone else experienced this?

Last edited by nlestat (2014-06-24 08:38:57)

Offline

#2 2014-06-24 17:09:51

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,132

Re: Wrong icons in alt-tab switcher for some applications

Some X applications don't allow the window manager to set an icon for the window frame or task switcher applications. In my experience, I've seen this happen with the older X apps like xterm, emacs, etc. There is a utility called xseticon that is written to allow you to get around these restrictions.

One more thing to note specifically with emacs is that the icon is forced but can be overriden (you'll still need to use something like xseticon to get the icon that you want). More information here: https://www.gnu.org/software/emacs/manu … ons-X.html.

EDIT: Here is a tutorial with some scripts to show you how this can be done.

Last edited by ToZ (2014-06-24 17:28:49)

Offline

#3 2014-06-25 09:41:38

nlestat
Member
Registered: 2014-06-24
Posts: 2

Re: Wrong icons in alt-tab switcher for some applications

I see. Thanks for the info ToZ.

Offline

Board footer

Powered by FluxBB