Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-06-25 06:15:52

londondaveuk
Member
Registered: 2014-06-25
Posts: 4

Installing icons/pixmaps in user directory problem??

Hi All,

I have installed an icon for a program in ~/.local/share/pixmaps/, xfce4 does not see pixmaps in that directory for some reason (kde4 does).  I tried using 'gtk-update-icon-cache -q -t -f ~/.local/share/pixmaps' but that doesn't solve the problem (there's an error about a theme??).

How do I get xfce4 to find icons/pixmaps in that directory so they will be found in a .desktop file.


Thanks for any help

Offline

#2 2014-06-25 13:20:18

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,242

Re: Installing icons/pixmaps in user directory problem??

~/.local/share/pixmaps is not sourced by the icon spec. Try adding the icons to ~/.icons - that directory is sourced. See: http://standards.freedesktop.org/icon-t … atest.html

Offline

#3 2014-06-26 05:44:26

londondaveuk
Member
Registered: 2014-06-25
Posts: 4

Re: Installing icons/pixmaps in user directory problem??

Thanks ToZ, I will give that a try.

Offline

#4 2014-06-26 08:38:28

londondaveuk
Member
Registered: 2014-06-25
Posts: 4

Re: Installing icons/pixmaps in user directory problem??

Hi,

I copied my icon to ~/.icons directory, the .desktop launcher found the icon but the desktop was not refreshed so does not show it - it just used the default xfce icon. If I edit the launcher, do nothing and then click save, the desktop is refreshed and my icon is shown?

How do I refresh the desktop icons (from the command line)? I have tried 'xfdesktop --refresh' but nothing happens. I am using xubuntu.

Cheers for any help.

Offline

#5 2014-06-26 10:24:29

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,242

Re: Installing icons/pixmaps in user directory problem??

Try:

xfdesktop --reload

Offline

#6 2014-06-28 09:19:26

londondaveuk
Member
Registered: 2014-06-25
Posts: 4

Re: Installing icons/pixmaps in user directory problem??

Hi ToZ,

Tried 'xfdesktop --reload' and nothing happened, xfce4 did not update the icons on the desktop. I am scratching my head - it all works perfectly in kde?

Offline

#7 2014-06-28 11:37:21

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,242

Re: Installing icons/pixmaps in user directory problem??

Which version of Xfce are you running?

Is xfdesktop managing your desktop?

ps -ef | grep xfdesktop | grep -v grep

Offline

#8 2014-06-28 21:59:49

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 308

Re: Installing icons/pixmaps in user directory problem??

Would deleting the thumbnail directory and then loading the desktop directory help?

Regards,
MDM

Offline

Board footer

Powered by FluxBB