Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-05-17 01:54:47

fredsmit
Member
Registered: 2014-05-17
Posts: 12

no tab key - auto completion - in bash

Why is the tab key not working in bash ?

Offline

#2 2014-05-17 05:48:25

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 383

Re: no tab key - auto completion - in bash

From the wealth of information you have provided, I have determined that it's because you're not hitting it hard enough.

If you feel that to be an incorrect diagnosis, maybe you could cough up a little more information. Distro? XFCE version? Bash version? 32- or 64-bit? Et cetera?

Or you could try pressing the tab key twice - that works for me (just checked and verified); perhaps it's seeing a single tab as just a tab and wants a "double-tab" (not to be confused with a double-tap, lol) to initiate the auto-complete routine, IDK.

[EDIT: Strange... I type ba, press the tab key, and have to press it a second time to get a list. But if I type ho, a single press of the tab key turns it into host - and then a second press gives me a list. That appears to be inconsistent behavior. I guess it's time for someone with considerably more brain cells than I have to step in (Toz?), because I've managed to confuse myself. Apologies.]
Regards,
MDM

Last edited by MountainDewManiac (2014-05-17 05:59:17)


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#3 2014-05-17 11:13:22

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,384

Re: no tab key - auto completion - in bash

@fredsmit, make sure you have the bash-completion package installed and double-check that bash is currently your shell. In addition to what MDM has asked for, can you also provide an example?

@MountainDewManiac, as I understand it (and lets see if I can explain it), on the first press of the tab key, bash-completion completes to the point of choice, on the second press, it displays the list. For example, on my system, "ho" can potentially resolve to "hostid", "hostname", "hostnamectl". In all instances, the common part is "host", therefore, the first press will auto-complete to "host" (point of choice). The second press will display the list. In the case of "ba", the third letter differs ("bacman     badblocks  base64     basename   bash       bashbug"), therefore you are already at the point of choice and the first tab press will do nothing. The second will display the choices.

Offline

#4 2014-05-17 13:10:58

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

ubuntu 14-04 ;  When I ssh to the server bash tab works ; the xterm bash started in xfce tab doesn't work - at all ; no matter how many times I tap it ;


simple as that;

Offline

#5 2014-05-17 13:24:07

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

(trusty)root@jade-rev4:~# cat /tmp/shit
ii  gtk2-engines-xfce                               3.0.1-2                                             powerpc      GTK+-2.0 theme engine for Xfce
ii  libxfce4ui-1-0                                  4.11.1-2ubuntu1                                     powerpc      widget library for Xfce - Gtk+2 variant
ii  libxfce4ui-common                               4.11.1-2ubuntu1                                     all          common files for libxfce4ui
ii  libxfce4ui-utils                                4.11.1-2ubuntu1                                     powerpc      Utility files for libxfce4ui
ii  libxfce4util-bin                                4.10.1-1ubuntu1                                     powerpc      tools for libxfce4util
ii  libxfce4util-common                             4.10.1-1ubuntu1                                     all          common files for libxfce4util
ii  libxfce4util6                                   4.10.1-1ubuntu1                                     powerpc      Utility functions library for Xfce4
ii  libxfcegui4-4                                   4.10.0-2                                            powerpc      Basic GUI C functions for Xfce4
ii  xfce-keyboard-shortcuts                         4.11.1-2ubuntu1                                     all          xfce keyboard shortcuts configuration (transitional package)
ii  xfce4                                           4.10.1                                              all          Meta-package for the Xfce Lightweight Desktop Environment
ii  xfce4-appfinder                                 4.10.1-1                                            powerpc      Application finder for the Xfce4 Desktop Environment
ii  xfce4-artwork                                   0.1.1a~git+20110420-1                               all          additional artwork for the Xfce4 Desktop Environment
ii  xfce4-battery-plugin                            1.0.5-2ubuntu1                                      powerpc      battery monitor plugin for the Xfce4 panel
ii  xfce4-clipman                                   2:1.2.5-1                                           powerpc      clipboard history utility
ii  xfce4-clipman-plugin                            2:1.2.5-1                                           powerpc      clipboard history plugin for Xfce panel
ii  xfce4-cpufreq-plugin                            1.1.0-1                                             powerpc      cpufreq information plugin for the Xfce4 panel
ii  xfce4-cpugraph-plugin                           1.0.5-1                                             powerpc      CPU load graph plugin for the Xfce4 panel
ii  xfce4-datetime-plugin                           0.6.2-1ubuntu2                                      powerpc      date and time plugin for the Xfce4 panel
ii  xfce4-dict                                      0.7.0-1                                             powerpc      Dictionary plugin for Xfce4 panel
ii  xfce4-diskperf-plugin                           2.5.4-2ubuntu1                                      powerpc      disk performance display plugin for the Xfce4 panel
ii  xfce4-fsguard-plugin                            1.0.1-2ubuntu1                                      powerpc      filesystem monitor plugin for the Xfce4 panel
ii  xfce4-genmon-plugin                             3.4.0-2                                             powerpc      Generic Monitor for the Xfce4 panel
ii  xfce4-goodies                                   4.10                                                powerpc      enhancements for the Xfce4 Desktop Environment
ii  xfce4-mailwatch-plugin                          1.2.0-1                                             powerpc      mail watcher plugin for the Xfce4 panel
ii  xfce4-mixer                                     1:4.10.0-1ubuntu2                                   powerpc      Xfce mixer application
ii  xfce4-mount-plugin                              0.6.4-2                                             powerpc      mount plugin for the Xfce4 panel
ii  xfce4-netload-plugin                            1.2.0-1                                             powerpc      network load monitor plugin for the Xfce4 panel
ii  xfce4-notes                                     1.7.7-3ubuntu2                                      powerpc      Notes application for the Xfce4 desktop
ii  xfce4-notes-plugin                              1.7.7-3ubuntu2                                      powerpc      Notes plugin for the Xfce4 desktop
ii  xfce4-notifyd                                   0.2.4-2                                             powerpc      simple, visually-appealing notification daemon for Xfce
ii  xfce4-panel                                     4.11.0-0ubuntu1                                     powerpc      panel for Xfce4 desktop environment
ii  xfce4-places-plugin                             1.6.0-1ubuntu1                                      powerpc      quick access to folders, documents and removable media
ii  xfce4-power-manager                             1.2.0-3ubuntu4                                      powerpc      power manager for Xfce desktop
ii  xfce4-power-manager-data                        1.2.0-3ubuntu4                                      all          power manager for Xfce desktop, arch-indep files
ii  xfce4-quicklauncher-plugin                      1.9.4-10ubuntu1                                     powerpc      rapid launcher plugin for the Xfce4 panel
ii  xfce4-screenshooter                             1.8.1-2ubuntu1                                      powerpc      screenshots utility for Xfce
ii  xfce4-sensors-plugin                            1.2.5-2                                             powerpc      hardware sensors plugin for the Xfce4 panel
ii  xfce4-session                                   4.10.1-3ubuntu5                                     powerpc      Xfce4 Session Manager
ii  xfce4-settings                                  4.11.2-1ubuntu2                                     powerpc      graphical application for managing Xfce settings
ii  xfce4-smartbookmark-plugin                      0.4.5-1                                             powerpc      search the web via the Xfce4 panel
ii  xfce4-systemload-plugin                         1:1.1.1-1ubuntu2                                    powerpc      system load monitor plugin for the Xfce4 panel
ii  xfce4-taskmanager                               1.0.1-1                                             powerpc      process manager for the Xfce4 Desktop Environment
ii  xfce4-terminal                                  0.6.3-1ubuntu1                                      powerpc      Xfce terminal emulator
ii  xfce4-timer-plugin                              1.5.0-1                                             powerpc      timer plugin for Xfce panel
ii  xfce4-verve-plugin                              1.0.0-2ubuntu1                                      powerpc      Verve (command line) plugin for Xfce panel
ii  xfce4-volumed                                   0.2.0-0ubuntu1                                      powerpc      volume keys daemon
ii  xfce4-wavelan-plugin                            0.5.11-2ubuntu1                                     powerpc      wavelan status plugin for the Xfce4 panel
ii  xfce4-weather-plugin                            0.8.3-1                                             powerpc      weather information plugin for the Xfce4 panel
ii  xfce4-xkb-plugin                                1:0.7.0-0ubuntu2                                    powerpc      xkb layout switch plugin for the Xfce4 panel
ii  xfdesktop4                                      4.11.6-1ubuntu1                                     powerpc      xfce desktop background, icons and root menu manager
ii  xfdesktop4-data                                 4.11.6-1ubuntu1                                     all          xfce desktop background, icons and root menu (common files)

Offline

#6 2014-05-17 14:15:11

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

The xterm turd uses tab to switch to the next xterm ; and there is no way to configure the behavior ;

Last edited by fredsmit (2014-05-17 16:29:50)

Offline

#7 2014-05-17 17:02:55

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,384

Re: no tab key - auto completion - in bash

xterm is a terminal emulator that ships with X window system (xorg). xfce4-terminal is the terminal emulator that ships with Xfce. Can you confirm which one you are using?

If it is xfce4-terminal, and the tab key is moving you to the next terminal tab, have a look at the menu. Next to the "Next Tab" and "Previous Tab" menu entries, is "tab" shown as the shortcut accelerator? If so, follow the instructions here to change that accelerator. I believe the defaults are Ctrl+PgUp for Previous and Ctrl+PgDn for Next.

Offline

#8 2014-05-18 14:00:29

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

xfce4-terminal ; There is no reason  xfce4-terminal should use the  tab to change window focus to another  xfce4-terminal;

Offline

#9 2014-05-18 14:15:13

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

ToZ wrote:

xterm is a terminal emulator that ships with X window system (xorg). xfce4-terminal is the terminal emulator that ships with Xfce. Can you confirm which one you are using?

If it is xfce4-terminal, and the tab key is moving you to the next terminal tab, have a look at the menu. Next to the "Next Tab" and "Previous Tab" menu entries, is "tab" shown as the shortcut accelerator? If so, follow the instructions here to change that accelerator. I believe the defaults are Ctrl+PgUp for Previous and Ctrl+PgDn for Next.



Those directions point to : http://docs.xfce.org/xfce/xfce4-setting … nd_buttons

There is no configuration menu for this action on the desktop;

Offline

#10 2014-05-18 15:42:07

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,384

Re: no tab key - auto completion - in bash

Those directions point to : http://docs.xfce.org/xfce/xfce4-setting … nd_buttons

Yes. The section of interest is titled "Enable editable accelerators".

There is no configuration menu for this action on the desktop;

Here is how to do it:

1. Settings Manager >> Appearance >> Settings Tab >> check the "Enable editable accelerators" checkbox.
2. With xfce4-terminal open, at least one extra tab enabled, and the menubar visible, hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut).
3. With the mouse still hovering over the "Previous tab" menu entry, press another menu shortcut (if you want one).
4. Repeat for the "Next tab" menu entry.

Offline

#11 2014-05-18 21:20:45

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

ToZ wrote:

Those directions point to : http://docs.xfce.org/xfce/xfce4-setting … nd_buttons

Yes. The section of interest is titled "Enable editable accelerators".

There is no configuration menu for this action on the desktop;

Here is how to do it:

1. Settings Manager >> Appearance >> Settings Tab >> check the "Enable editable accelerators" checkbox.
2. With xfce4-terminal open, at least one extra tab enabled, and the menubar visible, hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut).
3. With the mouse still hovering over the "Previous tab" menu entry, press another menu shortcut (if you want one).
4. Repeat for the "Next tab" menu entry.


There is no"manager " choice under the "settings " pulldown.


Why is a terminal program doing what the window manager does .. changing focus using tab key.  And why does the default behaviour have it turned on?

Under the "ab " pulldown for the terminal program.. the choices are shaded out.

Offline

#12 2014-05-19 00:06:47

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,384

Re: no tab key - auto completion - in bash

fredsmit wrote:

There is no"manager " choice under the "settings " pulldown.

Settings Manager
---> Appearance
--------> Settings Tab
------------> "Enable editable accelerators"
(or Alt+F2 and run):

xfce4-appearance-settings

...and look on the "Settings" tab.

Why is a terminal program doing what the window manager does .. changing focus using tab key.

I don't know. Its not the default. Perhaps the distro you use changed it?

Under the "ab " pulldown for the terminal program.. the choices are shaded out.

Make sure you have at least one tab open to enable them.

Offline

#13 2014-05-19 12:46:57

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

ToZ wrote:
fredsmit wrote:

There is no"manager " choice under the "settings " pulldown.

Settings Manager
---> Appearance
--------> Settings Tab
------------> "Enable editable accelerators"
(or Alt+F2 and run):

xfce4-appearance-settings

...and look on the "Settings" tab.

Why is a terminal program doing what the window manager does .. changing focus using tab key.

I don't know. Its not the default. Perhaps the distro you use changed it?

Under the "ab " pulldown for the terminal program.. the choices are shaded out.


Make sure you have at least one tab open to enable them.

I found this appearance stting . After I enabled that setting and closing the utility I don't see the behaviour changed..

This doesn't answer why the terminal widow is doing this behaviour .

Offline

#14 2014-05-19 13:24:03

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

I installed xfce on another server and the terminal window accepts no input ; When it is launched stdin is ignored;

Offline

#15 2014-05-19 14:01:58

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,384

Re: no tab key - auto completion - in bash

fredsmit wrote:

I found this appearance stting . After I enabled that setting and closing the utility I don't see the behaviour changed..

After the setting is enabled, you need to also (as per a previous post):

2. With xfce4-terminal open, at least one extra tab enabled, and the menubar visible, hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut).
3. With the mouse still hovering over the "Previous tab" menu entry, press another menu shortcut (if you want one).
4. Repeat for the "Next tab" menu entry.

Offline

#16 2014-05-19 14:12:19

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

fredsmit wrote:
ToZ wrote:

Those directions point to : http://docs.xfce.org/xfce/xfce4-setting … nd_buttons

Yes. The section of interest is titled "Enable editable accelerators".

There is no configuration menu for this action on the desktop;

Here is how to do it:

1. Settings Manager >> Appearance >> Settings Tab >> check the "Enable editable accelerators" checkbox.
2. With xfce4-terminal open, at least one extra tab enabled, and the menubar visible, hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut).
3. With the mouse still hovering over the "Previous tab" menu entry, press another menu shortcut (if you want one).
4. Repeat for the "Next tab" menu entry.


There is no"manager " choice under the "settings " pulldown.


Why is a terminal program doing what the window manager does .. changing focus using tab key.  And why does the default behaviour have it turned on?

Under the "ab " pulldown for the terminal program.. the choices are shaded out.





2. With xfce4-terminal open, at least one extra tab enabled, and the menubar visible, hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut).
3. With the mouse still hovering over the "Previous tab" menu entry, press another menu shortcut (if you want one).
4. Repeat for the "Next tab" menu entry.


None of this works; "Hovering " over the shaded "Previous Tab" does nothing;

Offline

#17 2014-05-19 15:59:28

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,384

Re: no tab key - auto completion - in bash

"hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut)."

Offline

#18 2014-05-20 13:25:01

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

ToZ wrote:

"hover your mouse over the "Previous tab" menu entry and press the backspace key (this should delete the shortcut)."


No change ;

Offline

#19 2014-05-22 23:27:01

fredsmit
Member
Registered: 2014-05-17
Posts: 12

Re: no tab key - auto completion - in bash

I installed Roxterm and it behaves the same way and the tab can't be disabled in that either

Offline

#20 2014-07-07 01:35:51

leomcsnarf
Member
Registered: 2014-07-07
Posts: 2

Re: no tab key - auto completion - in bash

For some reason... you need to do these few steps... it doesn't make sense, but do it. Okay...

#1 settings manager/window manager, clear shortcut for "switch window for same application"
#2 $  sudo apt-get --purge remove bash-completion
#3 $  sudo apt-get install bash-completion

It should now work. It does seem that for apt-get install it doesn't want to autocomplete, maybe so you don't install things you don't mean to and you have to know what application that you want to be installing, but it does work for installed applications. This is something that put me off a little too. There are a few thing tweaks you need to make to Xfce but all desktop environments are like that and I love how smooth Xfce is...

Offline

#21 2014-10-29 11:29:57

Champal
Member
Registered: 2014-10-29
Posts: 1

Re: no tab key - auto completion - in bash

Hi, old post but this can help other people.

CTRL+i works like TAB for autocomplete

And to disable terminal switchnig : Source edwinorc  @ http://ubuntuforums.org/showthread.php? … st11107297

I accidentally discovered a fix for this while trying to solve a different problem.

edit
~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

find the line

<property name="&lt;Super&gt;Tab" type="string" value="switch_window_key"/>

and change it to

<property name="&lt;Super&gt;Tab" type="empty"/>

reboot or whatever and then tab will work properly!

I have no idea why but when using vnc this file seems to override tab's normal behaviour and makes it into a switch window key.

Champal

Offline

Board footer

Powered by FluxBB