Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-09-04 01:45:39

AussieRoy
Member
Registered: 2014-09-03
Posts: 2

[Solved] xfce4-display-settings starts numerous instances with no user input

I have a Dell XPS-15 Laptop (Model No: L-501X) which has been used successfully with previous versions of Xubuntu (versions 13.10 and earlier), Linux Mint-XFCE, and Debian Stable with XFCE for over three years.  Recently, I upgraded this laptop to Xubuntu 14.04 and found that an unusual problem is now occurring. 

After completion of the login process, numerous instances of "xfce4-display-settings" are started (and continue to be started) with no keyboard input by the user.  Xfce4-display-settings will be often be started fifty or more times in as little as a minute, and instances continue to be started as quickly as you can close them. If I leave the laptop to see what happens, it will eventually (after an hour or so) slow down to a non-responsive state with thousands of instances of xfce4-display-settings running.   The following is the output of a ps -aef | grep xfce4-display:

royg@royg-Galago-UltraPro:~$ cat ps*
grace     5662     1  0 11:17 ?        00:00:00 xfce4-display-settings --minimal
grace     5664     1  0 11:17 ?        00:00:00 xfce4-display-settings --minimal
grace     5691     1  0 11:17 ?        00:00:00 xfce4-display-settings --minimal
grace     5708     1  0 11:19 ?        00:00:00 xfce4-display-settings --minimal
grace     5754     1  1 11:20 ?        00:00:00 xfce4-display-settings --minimal
grace     5756     1  1 11:20 ?        00:00:00 xfce4-display-settings --minimal
grace     5758     1  1 11:20 ?        00:00:00 xfce4-display-settings --minimal
grace     5763  5727  0 11:21 pts/2    00:00:00 grep --colour=auto xfce4-display
royg@royg-Galago-UltraPro:~$

Thinking that this may have been a problem with the first iteration of Xubuntu 14.04, I recently tried  doing a clean install of Xubuntu 14.04.1, and the same error occurs.  I then tried the latest version of Linux Mint-XFCE, and the same problem occurs in Mint-XFCE.  (I haven't yet had a chance to try the latest Debian Stable with XFCE).

The Dell Laptop has an Nvidia GT-435M video card in it.  I have tried both the Nouveau Driver and the Nvidia-331 proprietary driver.  Neither driver has any impact on thsi problem.  I am only using the Laptop's internal screen.  I do not have a monitor connected to the HDMI output. 
Downgrading the OS to Xubuntu 13.10 stops this problem from occurring, but is not a satisfactory long term solution.

EDITED at 11:58 04 Sep 2014
I've just found hundreds of the following errors in Xorg.0.log:

[  3617.083] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[  3617.083] (II) NVIDIA(GPU-0):     stereo.
[  3617.087] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[  3617.087] (II) NVIDIA(GPU-0):     stereo.

Any suggestions regarding how to further diagnose this problem, or ideally, how to fix this problem ?

Regards,

Roy

Last edited by AussieRoy (2014-09-04 02:04:20)

Offline

#2 2014-09-04 20:18:17

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,245

Re: [Solved] xfce4-display-settings starts numerous instances with no user input

If you go to Settings Manager >> Keyboard >> Application Shortcuts, there should be a shortcut to "xfce4-dispaly-settings --minimal" that points to XF86Display. Try removing that shortcut.

If this stops the display settings from starting up, then you'll need to find out why your laptop is continuously emitting the XF86Display event

Offline

#3 2014-09-04 23:41:17

AussieRoy
Member
Registered: 2014-09-03
Posts: 2

Re: [Solved] xfce4-display-settings starts numerous instances with no user input

Many thanks ToZ.

Your solution solved the problem :-)     Seems like the keyboard has developed a fault.  But, with that keyboard shortcut removed, the laptop now works great with XUbuntu 14.04.1 installed.

Thanks for the quick response.  It's very much appreciated.

Regards,

Roy

Offline

#4 2014-09-04 23:54:54

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 296
Website

Re: [Solved] xfce4-display-settings starts numerous instances with no user input

Your next step is to clean out your keyboard, thoroughly.  If that doesn't help, talk to Dell, especially if the laptop's still under warranty.


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

Board footer

Powered by FluxBB