Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-12-20 11:49:01

TasmaniaDave
Member
Registered: 2016-12-20
Posts: 2

XFCE will not start at log in

I have XFCE 4.12 on Ubuntu Studio 16.04, all updates installed.

It began misbehaving recently. I cannot think of anything I did that might have caused the problem i.e. did not play with XFCE configuration. Maybe an update might have done it?

I’ve tried to fix the problem as best I can but am now at a loss. Help!!

When I log in the following happens;
-    A terminal window opens;
-    keyboard input does not work on some log-ins but does work after other log-ins;
-    mouse pointer works & can select in the terminal;
-    mouse right button menu does not work;
-    desk top icons are absent;
-    the desktop background image is larger than it should be;

I can recover by;
-    logging in repeatedly until keyboard input happens to work;
-    issuing the command
        xfwm4 --daemon –replace (as the user affected by the problem).

XFCE behaved normally for a new user I created during trhoubeshootng.

Therefore I thought (incorrectly) that the problem might be fixed by forcing XFCE to create a new default configuration for the user that was in trouble (renamed /home/david/.config/xfce4/ to … xfce4_bak & restarted the computer).

So, no answer yet. Anyone able to help?

Now for a quick look around the system in case it helps.

XFCE version: 4.12.
OS: UbuntuStudio 16.04.
Kernel:  4.4.0-53-lowlatency #74-Ubuntu SMP PREEMPT Fri Dec 2 17:03:30 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

With XFCE running normally and a terminal window open the following processes are running;
    xfce4-session
    xfce4-panel
    xfce4-power-man
    xfce4-volumed
    xfce4-terminal
    xfwm4

The following environment variables exist when XFCE is running normally;
    XDG_MENU_PREFIX=xfce-
    XDG_DATA_DIRS=/usr/share/ubuntustudio:/usr/share/xfce4:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop:/usr/share
    UPSTART_JOB=startxfce4
    COLORTERM=xfce4-terminal

Using information in a forum post;

    http://forum.xfce.org/viewtopic.php?id=11227

I found the following configs, scripts & folders but could not have damaged them as I did not know about them earlier & in many cases they are not writeable by a normal user. The first two helped me to learn more about XFCE but not to fix the problem;
-    /usr/bin/startxfce4 (first script to run, calls /etc/xdg/xfce4/xinitrc)
    /etc/xdg/xfce4/xinitrc
    /usr/share/xfwm4/defaults
    /etc/xfce64/defaults.list
    /etc/xdg/xdg-ubuntustudio/xfce4/
    /etc/xdg/xdg-ubuntustudio/autostart/xfce4-tips-autostart.desktop
    /home/david/.cache/xfce4/ (transient data from apps)

Offline

#2 2016-12-20 12:53:27

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,273

Re: XFCE will not start at log in

Hello and welcome.

Since it works fine with a new user that you created, I would guess that your current user's cache is messed up (as it would cause the issues that you are seeing). Before you log in (from a virtual tty), delete your user's ~/.cache/session directory. It will be re-created on the next login with the default set up startup components.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2016-12-20 20:44:46

TasmaniaDave
Member
Registered: 2016-12-20
Posts: 2

Re: XFCE will not start at log in

Problem solved, thank you. I'm impressed - you replied about an hour after I posted smile

Best Christmas wishes from sunny Tasmania, Australia.

Offline

Board footer

Powered by FluxBB