Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-04-30 18:06:29

Nate
Member
Registered: 2011-04-05
Posts: 2

Xfce unstable with zaphodheads on Slackware 14.2

For several years I have run two monitors with independent desktops setting up a screen0 and screen1 with a custom xorg.conf using Debian/Devuan. For a few years I did this with a dual-port ATI video card and now am doing the same thing with the onboard Intel VGA adapter that has DVI and VGA outputs on Devuan since the latter part of 2015 on a Lenovo M73 tower. For all this time my desktop has been the various versions of Xfce from at least Debian 5 through to Devuan 1.0rc which has worked very well and has been rock solid, in some case with an uptime of a couple months or longer logged into the desktop.

Friday night I booted this machine into Slackware 14.2 for the first time, brought it up to date, copied my minimal xorg.conf over from the Devuan partiition and then the fun began. Initially, starting Xfce with startxfce brought on all manner of weirdness of being unable to setup panels on the other screen, and programs only starting on screen0 and so on. Later I reconfigured inittab to start in run level 4 (which starts Kdm on Slackware) and Xfce behaved quite well, for a while. After about a half hour or so and setting up a panel for screen1, I clicked on its menu button and the screens almost became possessed! The panels started flashing, the background images disappeared for a bit and then returned and the panels never returned although Xfwm4 continued to work. Right clicking on the desktop would not bring up a menu so I got out using Ctl-Alt-Backspace. Further attempts to go back into Xfce from kdm resulted in being presented with a dialog that stated the panel was running in kiosk mode and user customization was disabled. Huh? I will note that I had deleted all of the Xfce settings between the runs of trying to use startxfce4 and booting into run level 4.

I also tried KDE which fared a little better but still suffered from the issue of programs not starting on the screen I wanted them to and so on. In frustration I booted back into Devuan where I am again enjoying the independent desktops with Xfce.

The reason I started using zaphodheads is because otherwise the only choices seem to be extending the desktop across both screens or mirrored displays. Neither is a useful choice for me as my workflow is to have amateur radio related programs running on the monitor attached to screen1 as it sits directly in front of my main operating position while the "main" monitor attached to screen0 is off to the right side of the desk. If Xfce could be set up for independent desktops on each screen without the need for configuring zaphodheads in xorg.conf that would be ideal, but doesn't seem to be possible. Doing so doesn't seem to be possible with KDE either.

If it matters, I am using the Slackware 4.4.38 kernel and modules with Xfce 4.12, etc. and Xorg 1.18.3 . On Devuan I am running its 3.16.39 kernel and modules, Xfce 4.10 and Xorg 1.16.4.

I can post any config and log files if it will help diagnose the craziness I saw with Xfce. For now I am looking for ideas of anything I may have overlooked, but overall I didn't try anything on the Slackware installation that I wasn't already doing with success on the Devuan installation.

Last edited by Nate (2017-04-30 18:07:06)

Offline

Board footer

Powered by FluxBB