Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-07-07 05:34:21

isaac.dvory
Member
Registered: 2017-07-07
Posts: 6

Keyboard Layout/extra languages

I've got the following setup:
VPS server, using Debian 8 with xfce4.
I'm using tightvnc to connect to 5 different desktops (displays) with different users.

I require a German, French & English keyboard but I can't understand how to add them...
English works fine , its the default, what do I do with the rest?

Here is a screenshot of the VNC https://s16.postimg.org/ooha1jrad/Capturevnc.png
Screenshot of "Keyboard Layout" plugin: https://s15.postimg.org/e0ebdhd3f/de-vnc.png (notice everything is disabled).


I have no idea what else to do... how can I write in German / French?

Last edited by isaac.dvory (2017-07-07 05:34:33)

Offline

#2 2017-07-07 06:55:34

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 426
Website

Re: Keyboard Layout/extra languages

Have you installed the locale packages for those languages?

You will probably need to check with Debian what the actual packages are.

Offline

#3 2017-07-07 07:24:46

isaac.dvory
Member
Registered: 2017-07-07
Posts: 6

Re: Keyboard Layout/extra languages

Yes, I have installed locales-all, I selected german an french in  dpkg-reconfigure locales

Offline

#4 2017-07-07 10:50:34

Jerry3904
Member
Registered: 2013-11-09
Posts: 546

Re: Keyboard Layout/extra languages

Have you added them to the keyboard? 

  • Click Start Menu > Settings > All Settings > Keyboard, Layout tab.

  • Uncheck Use system defaults, then click on the +Add button at the bottom

  • Select one at a time the keyboard(s) you want available.

To switch we use a nice keyboard switcher that fits in the Notification Area, but Xfce has its own panel plugin "Keyboard Layouts."


MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

#5 2017-07-07 11:11:25

isaac.dvory
Member
Registered: 2017-07-07
Posts: 6

Re: Keyboard Layout/extra languages

Unfortunately the "Add" option is disabled:

https://s2.postimg.org/nk4f3peyh/keyboard-vnc.png

Offline

#6 2017-07-07 12:00:03

isaac.dvory
Member
Registered: 2017-07-07
Posts: 6

Re: Keyboard Layout/extra languages

I have add a small breakthrough (although it doesn't really help me).
I found out that I can write in all the languages that I have installed on my main machine (windows 7) while I'm in "Terminal emulator" in the VNC , but I still can't write in these languages when I'm in the Chromuim browser for example.

Offline

#7 2017-07-07 12:47:17

Jerry3904
Member
Registered: 2013-11-09
Posts: 546

Re: Keyboard Layout/extra languages

isaac.dvory wrote:

Unfortunately the "Add" option is disabled:

https://s2.postimg.org/nk4f3peyh/keyboard-vnc.png

Does your setup require root privileges to do this? If so, then open a terminal and run

gksu xfce4-keyboard-settings

MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

#8 2017-07-10 09:28:10

isaac.dvory
Member
Registered: 2017-07-07
Posts: 6

Re: Keyboard Layout/extra languages

I didn't have that installed, I installed and ran the commend, got this: Xlib:  extension "RANDR" missing on display ":1.0".

Offline

#9 2017-07-17 05:17:20

isaac.dvory
Member
Registered: 2017-07-07
Posts: 6

Re: Keyboard Layout/extra languages

any other ideas?

Offline

#10 2017-07-17 11:47:48

Jerry3904
Member
Registered: 2013-11-09
Posts: 546

Re: Keyboard Layout/extra languages

Nope, don't really understand your system--sorry.


MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

Board footer

Powered by FluxBB