Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-05-22 05:39:31

ricAtCo
Member
Registered: 2017-05-22
Posts: 2

How do I enable italics in xfce4-terminal?

Hi.

I use VIM and Markdown extensively to make notes and such. I recently moved from another linux distro, and I found out that the terminal in Xubuntu by default does not show italics. It has an option to enable bold in the preferences, but not italics.

How do I go about this?

I tried to search but couldn't find much info.

Using xfce4-terminal 0.6.3 (Xfce 4.12)
$TERM outputs xterm
Font in use is Fira Mono (it has an italic variation installed, yes), though it also did not work on the default DujaVu Sans Mono Book.

Offline

#2 2017-05-22 06:57:30

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 429
Website

Re: How do I enable italics in xfce4-terminal?

I don't know if it will help but that is an old version of the terminal. 0.8.5.1 was just released. Updating to a more recent version may help as it uses a newer version of VTE and GTK

Offline

#3 2017-05-22 07:02:22

ricAtCo
Member
Registered: 2017-05-22
Posts: 2

Re: How do I enable italics in xfce4-terminal?

ozjd wrote:

I don't know if it will help but that is an old version of the terminal. 0.8.5.1 was just released. Updating to a more recent version may help as it uses a newer version of VTE and GTK

I'm on the default Xfce desktop environment that comes with Xubuntu 16.04 LTS. I didn't realize I'm so far behind!

If I install version 0.8.5.1 from a tar file, will it break anything else? I'm kinda new to this -- and this will pretty much be my first installation from a tar file.

Offline

#4 2017-05-22 07:15:41

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 429
Website

Re: How do I enable italics in xfce4-terminal?

I'm not sure on Xubuntu versions but I think that means it was released more than 12 months ago. I would be surprised if someone hasn't made more recent packages available. I know there are plenty of Xubuntu users on here so hopefully someone can point you in the right directions.

Offline

#5 2017-05-22 09:58:43

Jerry3904
Member
Registered: 2013-11-09
Posts: 549

Re: How do I enable italics in xfce4-terminal?

We have Xfce 4.12 but include xfce4-terminal 0.8.0 that our packagers have compiled from the GIT source. in that version, at least, you can right-click the terminal > Preferences, Appearance tab, and select any one of the italic fonts.

If this does not work for your version, you are welcome to try the deb from our repos.

Last edited by Jerry3904 (2017-05-22 18:21:03)


MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

#6 2017-07-14 04:44:34

lassehp
Member
Registered: 2012-07-02
Posts: 3

Re: How do I enable italics in xfce4-terminal?

Jerry3904 wrote:

We have Xfce 4.12 but include xfce4-terminal 0.8.0 that our packagers have compiled from the GIT source. in that version, at least, you can right-click the terminal > Preferences, Appearance tab, and select any one of the italic fonts.

If this does not work for your version, you are welcome to try the deb from our repos.

Forgive me if I am being dense, but it seems to me, you are saying it is possible to switch to an italic font. Obviously it is, but I  believe the issue here is support of italic control code with "\e[3m" in the same way as bold "\e[1m"? At least that's the reason I searched and found this thread. rxvt-unicode and mlterm support it, but they don't quite work as well together with XFCE4.

If there is a newer version of xfce4-terminal with support for this, where can we find the repos you are refering to? I can't seem to find  any deb package. (Apologies for being dense again, it's early morning and I haven't slept well.)

/Lasse

Offline

#7 2017-07-14 11:02:32

Jerry3904
Member
Registered: 2013-11-09
Posts: 549

Re: How do I enable italics in xfce4-terminal?

The general page is here:

https://mxlinux.org/community-repo

The package xfce4-terminal 0.8.0 is in the Test repo for now:

http://mxrepo.com/mx/testrepo/pool/test … -terminal/


MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

#8 2017-07-22 14:35:06

f2404
Member
From: Florida, USA
Registered: 2016-06-17
Posts: 11
Website

Re: How do I enable italics in xfce4-terminal?

Jerry3904 wrote:

The general page is here:

https://mxlinux.org/community-repo

The package xfce4-terminal 0.8.0 is in the Test repo for now:

http://mxrepo.com/mx/testrepo/pool/test … -terminal/

Are you planning on upgrading terminal version? 0.8.6 has just been released.

Offline

#9 2017-07-22 19:04:42

Jerry3904
Member
Registered: 2013-11-09
Posts: 549

Re: How do I enable italics in xfce4-terminal?

We'll certainly be looking at it...


MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

#10 2017-07-22 19:08:24

f2404
Member
From: Florida, USA
Registered: 2016-06-17
Posts: 11
Website

Re: How do I enable italics in xfce4-terminal?

lassehp wrote:

Forgive me if I am being dense, but it seems to me, you are saying it is possible to switch to an italic font. Obviously it is, but I  believe the issue here is support of italic control code with "\e[3m" in the same way as bold "\e[1m"? At least that's the reason I searched and found this thread. rxvt-unicode and mlterm support it, but they don't quite work as well together with XFCE4.

If there is a newer version of xfce4-terminal with support for this, where can we find the repos you are refering to? I can't seem to find  any deb package. (Apologies for being dense again, it's early morning and I haven't slept well.)

Lasse, I just checked, and italic ("\e[3m") is working fine for me on version 0.8.6.

Offline

Board footer

Powered by FluxBB