Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-09-01 12:53:34

archie728
Member
Registered: 2017-09-01
Posts: 2

How to remove section(?) from applications menu

AZs15YT.png

How can I remove the section with "No applications found"? After installation, there was "Log out" (and probably "About") option, but i hid it because i didn't use it.

Offline

#2 2017-09-02 10:11:36

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,749

Re: How to remove section(?) from applications menu

Hello and welcome.

How did you hide those options? Did you use a menu editor utility? If so, which one?

Can you post back your ~/.config/menus/xfce-applications.menu file? There's probably something in there that's not right.

Also see: https://wiki.xfce.org/howto/customize-menu.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2017-09-02 12:03:24

archie728
Member
Registered: 2017-09-01
Posts: 2

Re: How to remove section(?) from applications menu

ToZ wrote:

How did you hide those options?

I edited .desktop files acording to xfce wiki: https://wiki.xfce.org/howto/customize-m … nu_entries

~/.config/menus/xfce-applications.menu

<?xml version="1.0" ?>
<!DOCTYPE Menu
  PUBLIC '-//freedesktop//DTD Menu 1.0//EN'
  'http://standards.freedesktop.org/menu-spec/menu-1.0.dtd'>
<Menu>
	<Name>Xfce</Name>
	<MergeFile type="parent">/etc/xdg/menus/xfce-applications.menu</MergeFile>
	<Menu>
		<Name>Other</Name>
		<Exclude>
			<Filename>xfce4-about.desktop</Filename>
		</Exclude>
		<AppDir>/home/unknown/.local/share/applications</AppDir>
		<Exclude>
			<Filename>exo-file-manager.desktop</Filename>
		</Exclude>
		<Exclude>
			<Filename>xfce4-session-logout.desktop</Filename>
		</Exclude>
		<Exclude>
			<Filename>exo-mail-reader.desktop</Filename>
		</Exclude>
		<Exclude>
			<Filename>xfce4-run.desktop</Filename>
		</Exclude>
		<Exclude>
			<Filename>exo-terminal-emulator.desktop</Filename>
		</Exclude>
		<Exclude>
			<Filename>exo-web-browser.desktop</Filename>
		</Exclude>
	</Menu>
</Menu>

/etc/xdg/menus/xfce-applications.menu

<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
  "http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
    <Name>Xfce</Name>

    <DefaultAppDirs/>
    <DefaultDirectoryDirs/>
    <DefaultMergeDirs/>

    <Include>
        <Category>X-Xfce-Toplevel</Category>
    </Include>

    <Layout>
        <Filename>xfce4-run.desktop</Filename>
        <Filename>exo-terminal-emulator.desktop</Filename>
        <Filename>exo-file-manager.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Filename>exo-web-browser.desktop</Filename>
        <Separator/>
        <Menuname>Settings</Menuname>
        <Separator/>
        <Merge type="all"/>
        <Separator/>
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Layout>

    <Menu>
        <Name>Settings</Name>
        <Directory>xfce-settings.directory</Directory>
        <Include>
            <Category>Settings</Category>
        </Include>

        <Layout>
            <Filename>xfce-settings-manager.desktop</Filename>
            <Separator/>
            <Merge type="all"/>
        </Layout>

        <Menu>
            <Name>Screensavers</Name>
            <Directory>xfce-screensavers.directory</Directory>
            <Include>
                <Category>Screensaver</Category>
            </Include>
        </Menu>
    </Menu>

    <Menu>
        <Name>Accessories</Name>
        <Directory>xfce-accessories.directory</Directory>
        <Include>
            <Or>
                <Category>Accessibility</Category>
                <Category>Core</Category>
                <Category>Legacy</Category>
                <Category>Utility</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>exo-file-manager.desktop</Filename>
                <Filename>exo-terminal-emulator.desktop</Filename>
                <Filename>xfce4-about.desktop</Filename>
                <Filename>xfce4-run.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Development</Name>
        <Directory>xfce-development.directory</Directory>
        <Include>
            <Category>Development</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Education</Name>
        <Directory>xfce-education.directory</Directory>
        <Include>
            <Category>Education</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Games</Name>
        <Directory>xfce-games.directory</Directory>
        <Include>
            <Category>Game</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Graphics</Name>
        <Directory>xfce-graphics.directory</Directory>
        <Include>
            <Category>Graphics</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Multimedia</Name>
        <Directory>xfce-multimedia.directory</Directory>
        <Include>
            <Category>Audio</Category>
            <Category>Video</Category>
            <Category>AudioVideo</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Network</Name>
        <Directory>xfce-network.directory</Directory>
        <Include>
            <Category>Network</Category>
        </Include>
        <Exclude>
            <Or>
                <Filename>exo-mail-reader.desktop</Filename>
                <Filename>exo-web-browser.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Office</Name>
        <Directory>xfce-office.directory</Directory>
        <Include>
            <Category>Office</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>System</Name>
        <Directory>xfce-system.directory</Directory>
        <Include>
            <Or>
                <Category>Emulator</Category>
                <Category>System</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>xfce4-session-logout.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

</Menu>

Offline

#4 2017-09-02 16:00:54

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,749

Re: How to remove section(?) from applications menu

Looks like you're using an older version of Xfce/xfce4-panel (most probably 4.10). It was a bug back then but has been since been fixed.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB