Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-05-15 00:44:19

yoasif
Member
Registered: 2013-05-15
Posts: 1

Is there any way to disable shadows behind maximized windows?

I'd like to enable the "show shadows under regular windows" option in the compositor tab in the window manager tweaks settings panel.

However, enabling this option when using full screened windows produces an odd looking shadow behind my top panel (I'm running dual panels, gnome2 style. top panel is semitransparent.).

I'd like a way to customize the shadow behavior so it acts like "hide frame of windows when maximized" in the accessibility tab in the window manager tweaks panel, where I could "hide shadows of windows when maximized".

If this isn't configurable via xconf or similar, should I add an enhancement request?

Thanks for the help!

Last edited by yoasif (2013-05-15 00:52:09)

Offline

#2 2017-10-16 16:19:40

tezzz
Member
Registered: 2014-11-15
Posts: 6

Re: Is there any way to disable shadows behind maximized windows?

Same question.

Offline

#3 2017-10-16 16:25:15

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,874

Re: Is there any way to disable shadows behind maximized windows?

Does unchecking "Show shadows under dock windows" help?


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#4 2017-10-16 19:30:46

tezzz
Member
Registered: 2014-11-15
Posts: 6

Re: Is there any way to disable shadows behind maximized windows?

ToZ wrote:

Does unchecking "Show shadows under dock windows" help?

No. How to reproduce: alpha level to 0 in the panel settings and then maximize any window.

Offline

#5 2017-10-16 23:36:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,874

Re: Is there any way to disable shadows behind maximized windows?

What am I looking for? By unchecking the drop shadow box, the drop shadow disappears and the maximimzed window (still) looks okay. But maybe I'm not seeing what you are.

Before:
1bd7c86bf71e2258ec8ac05684f11a87e.png

After:
27050e8a0cfb526f4b7ca72a6e8bd5752.png

Can you post some screenshots?


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#6 2017-10-17 11:53:46

tezzz
Member
Registered: 2014-11-15
Posts: 6

Re: Is there any way to disable shadows behind maximized windows?

ToZ wrote:

Can you post some screenshots?

Shadows disabled: https://i.imgur.com/HvZ6qQy.png

Shadows enabled: https://i.imgur.com/RkYG80R.png

Desktop wallpaper https://cdn.fedoramagazine.org/wp-conte … 07/f26.jpg

Offline

#7 2017-10-17 20:17:01

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,874

Re: Is there any way to disable shadows behind maximized windows?

I see. The shadow of the maximized window is overlapping the panel.

There is no configuration option for this, so you'll need to create an enhancement request if you want a setting in the code.

As an optional workaround, you could create a script that uses wmctrl to monitor whether a window goes full screen and auto-disable/enable the setting as required. Something like:

#!/bin/bash

while true
do
	FULLSCREEN=0

	for WIN in $( wmctrl -l | awk '{print $1}' )
	do
		xprop -id $WIN | grep "_NET_WM_STATE_MAXIMIZED_HORZ, _NET_WM_STATE_MAXIMIZED_VERT" > /dev/null 2>&1 && FULLSCREEN=1
	done	

	if [ $FULLSCREEN -eq 1 ]
	then
		xfconf-query -c xfwm4 -p /general/show_frame_shadow -s false
	else
		xfconf-query -c xfwm4 -p /general/show_frame_shadow -s true
	fi

	sleep 1
done

exit 0

Adjust the sleep value as required to make the script more responsive.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#8 2017-10-18 10:55:38

tezzz
Member
Registered: 2014-11-15
Posts: 6

Re: Is there any way to disable shadows behind maximized windows?

Thanks.

Offline

Board footer

Powered by FluxBB