Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-12-11 13:43:27

batman1978
Member
Registered: 2017-12-11
Posts: 2

Applications launching on wrong screen.

I am using Debian 9
xfce4 version is 4.12

I have 2 screens setup.

I am using separate xserver for each screen.

When I launch xfce4-terminal from screen2 it launches on screen1.

thunar is launching correctly

Can someone point me to the correct configuration to fix this behavior?

Thanks

Offline

#2 2017-12-12 01:07:52

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,516

Re: Applications launching on wrong screen.

Hello and welcome.

Try launching xfce4-terminal without registering with the dbus session message bus:

xfce4-terminal --disable-server

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2017-12-16 01:42:15

batman1978
Member
Registered: 2017-12-11
Posts: 2

Re: Applications launching on wrong screen.

ToZ wrote:

Try launching xfce4-terminal without registering with the dbus session message bus:

xfce4-terminal --disable-server

This worked. 

I am looking into how to default this from registering with dbus session I guess.

Offline

#4 2017-12-16 03:17:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,516

Re: Applications launching on wrong screen.

I don't see a configuration option to do this.

You could create an alias to start xfce4-terminal in this manner. Something like:

alias xfterm='xfce4-terminal --disable-server

...or create an override as /usr/local/bin/xfce4-terminal with the content:

#!/bin/bash
/usr/bin/xfce4-terminal --disable-server

...and make the file executable.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB