Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-12-23 00:57:05

xfce4life
Member
Registered: 2017-12-23
Posts: 1

Thunar issues with NFS Mount

Hi There,

I've just switched my storage server over to using nfs and I've noticed some peculiarities with Thunar. Firstly because my nfs export is mounted natively, it's not being picked up as external storage - this is causing Thunar to set up trash folders all over the place. Is there any way to disable wastebasket functionality, but only for a particular mount?

Secondly and this one is annoying me no end - for some reason Thunar's defaulting to copying files, when dragging them into folders on my nfs export. I'm not dragging across filesystems either this happens when dragging from parent to a child directory. The nfs export itself is one big partition/zfs dataset - so there shouldn't be any cross filesystem issues there.

On my local drive I'm experiencing no issues with drag/drop - am I missing something?

Thanks in advance -

Offline

#2 2017-12-23 15:23:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,761

Re: Thunar issues with NFS Mount

Hello and welcome.

Thunar uses gvfs to manage trash folders. I just tested a nfs mount and you are correct, it does create a trash folder on the remote mount. I googled around and couldn't find anything specific. You could create a bug report against thunar and/or gvfs and see what the developers think.

As for the second issue, I cannot replicate this on my system. From within the nfs mount, files are moved, but I don't have a zfs filesystem. If possible, can you try it with another file manger (nautilus, nemo, pcmanfm) and see if the problem is replicated with those apps?

Offline

Board footer

Powered by FluxBB