Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-12-25 05:25:50

bergentroll
Member
Registered: 2017-12-25
Posts: 5

Sound effects again

I am on Arch, and I want to turn on the sound effects.
I just:

  • Turned on "Event Sounds" in Settings Manager -> Appearance -> Settings;

  • Installed the libcanberra and libcanberra-pulse packages;

  • Have exported GTK_MODULES="canberra-gtk-module";

  • Turned up "System Sounds" in pavucontrol;

But I still have no any sound effects.
What's wrong with this?

Last edited by bergentroll (2017-12-25 05:37:17)

Offline

#2 2017-12-25 14:00:55

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,753

Re: Sound effects again

Hello and welcome.

Here is a reference thread.

Can you post back the results of:

xfconf-query -c xsettings -lv | grep -i sound
env | grep GTK_MODULE
ls /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo
which canberra-gtk-play

Offline

#3 2017-12-25 15:25:25

bergentroll
Member
Registered: 2017-12-25
Posts: 5

Re: Sound effects again

$ xfconf-query -c xsettings -lv | grep -i sound
/Net/EnableEventSounds          true
/Net/EnableInputFeedbackSounds  true
/Net/SoundThemeName             freedesktop
$ env | grep GTK_MODULE
GTK_MODULES=canberra-gtk-module:canberra-gtk-module
$ ls /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo
alarm-clock-elapsed.oga         dialog-warning.oga
audio-channel-front-center.oga  message-new-instant.oga
audio-channel-front-left.oga    message.oga
audio-channel-front-right.oga   network-connectivity-established.oga
audio-channel-rear-center.oga   network-connectivity-lost.oga
audio-channel-rear-left.oga     phone-incoming-call.oga
audio-channel-rear-right.oga    phone-outgoing-busy.oga
audio-channel-side-left.oga     phone-outgoing-calling.oga
audio-channel-side-right.oga    power-plug.oga
audio-test-signal.oga           power-unplug.oga
audio-volume-change.oga         screen-capture.oga
bell.oga                        service-login.oga
camera-shutter.oga              service-logout.oga
complete.oga                    suspend-error.oga
device-added.oga                trash-empty.oga
device-removed.oga              window-attention.oga
dialog-error.oga                window-question.oga
dialog-information.oga
$ which canberra-gtk-play
/usr/bin/canberra-gtk-play

Offline

#4 2017-12-25 17:41:37

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,753

Re: Sound effects again

The freedesktop theme doesn't have many sound effect sounds that work with the libcanberra implementation. I modified an existing Borealis sound theme so that it would generate more sound effects (https://www.dropbox.com/s/bfyk05r4y8qog … lis.tar.gz). Or you can create your own sound theme based on the event names documented in the first link of this post.

But give my edited version of Borealis a try first. See if you get more sound events.

Edit: Here is another sound theme that seems to have many of the effects.

Offline

#5 2017-12-26 15:21:00

bergentroll
Member
Registered: 2017-12-25
Posts: 5

Re: Sound effects again

Oh, thank you! Sounds work now!
Tell me else please, does xfce4-terminal supports "bell"?

Last edited by bergentroll (2017-12-26 15:22:19)

Offline

#6 2017-12-27 02:18:48

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,753

Re: Sound effects again

bergentroll wrote:

Tell me else please, does xfce4-terminal supports "bell"?

Have a read through the bug report that lead to the audible bell being added. It looks like there is more information there.

Offline

#7 2017-12-27 05:12:46

bergentroll
Member
Registered: 2017-12-25
Posts: 5

Re: Sound effects again

Oh, got it. Thank you for information!

Offline

Board footer

Powered by FluxBB