Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-01-11 10:54:54

Devuan
Member
Registered: 2018-01-10
Posts: 8

Xfce drag/drop problem

Hello:

I have a problem with my Xfce installation in Devuan 1.0.

It is a standard 'out of the box' Devuan installation.

This is a two card (Nvidia FX 370 and FX 580) setup driving three monitors.
Video drivers are Nvidia using X.Org server in Xinerama mode.

The browser I am using is the default Devuan one, Firefox 52.5.2 (64-bit) ESR.

PROBLEM

When I try to do a drag&drop operation from the Firefox address bar (to anywhere), the browser will crash, bringing up a window with data to send to Firefox.
The same thing happens with the browser in safe mode.

This is the entry in syslog when the crash occurs:
---
Jan  7 18:48:34 devuan kernel: [ 3330.666686] Chrome_ChildThr[6335]: segfault at 0 ip 0000565170884d6c sp 00007fa6d3afe3e0 error 6 in plugin-container[565170880000+1b000]
---

From the crash report, there are two lines that indicate (?) there may be something going on with X11:

---
AbortMessage: ###!!! ABORT: Request 141.8: BadWindow (invalid Window parameter); 3 requests ago: file /build/firefox-esr-wI7Jwe/firefox-esr-52.5.2esr/toolkit/xre/nsX11ErrorHandler.cpp, line 147

Request 141.8: BadWindow (invalid Window parameter); 3 requests agoxpcom_runtime_abort(###!!! ABORT: Request 141.8: BadWindow (invalid Window parameter); 3 requests ago: file /build/firefox-esr-wI7Jwe/firefox-esr-52.5.2esr/toolkit/xre/nsX11ErrorHandler.cpp, line 147)
---

To rule out add-on or about:config problems, ie. anything outside the standard browser setup, I completely uninstalled it and installed it again, purging all related files.

The problem subsists.

Some relevant data:

groucho@devuan:~$ uname -a
Linux devuan 3.16.0-4-amd64 #1 SMP Debian 3.16.51-3 (2017-12-13) x86_64 GNU/Linux
groucho@devuan:~$ 
groucho@devuan:~$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  340.102  Mon Jan 16 13:06:29 PST 2017
GCC version:  gcc version 4.8.4 (Debian 4.8.4-1) 
groucho@devuan:~$ 
groucho@devuan:~$ xdpyinfo | grep version
version number:    11.0
X.Org version: 1.16.4
groucho@devuan:~$

As far as I can make out, all my Xfce is 4.10.

groucho@devuan:~$ xfwm4 --version
Xlib:  extension "RANDR" missing on display ":0.0".
	This is xfwm4 version 4.10.1 (revision 3918e6b) for Xfce 4.10
	Released under the terms of the GNU General Public License.
	Compiled against GTK+-2.24.25, using GTK+-2.24.25.

	Build configuration and supported features:
	- Startup notification support:                 Yes
	- XSync support:                                Yes
	- Render support:                               Yes
	- Xrandr support:                               Yes
	- Embedded compositor:                          Yes
	- KDE systray proxy (deprecated):               No
groucho@devuan:~$ 
groucho@devuan:~$ xfdesktop --version
Xlib:  extension "RANDR" missing on display ":0.0".
This is xfdesktop version 4.10.2, running on Xfce 4.10.
Built with GTK+ 2.24.18, linked with GTK+ 2.24.25.
Build options:
    Desktop Menu:        enabled
    Desktop Icons:       enabled
    Desktop File Icons:  enabled
groucho@devuan:~$ 
groucho@devuan:~$ xfce4-panel --version
Xlib:  extension "RANDR" missing on display ":0.0".
xfce4-panel 4.10.1 (Xfce 4.10)

Copyright (c) 2004-2011
	The Xfce development team. All rights reserved.

Please report bugs to <http://bugzilla.xfce.org/>.
groucho@devuan:~$ 
groucho@devuan:~$ xfce4-session --version
Xlib:  extension "RANDR" missing on display ":0.0".
xfce4-session 4.10.1 (Xfce 4.10)

Copyright (c) 2003-2012
	The Xfce development team. All rights reserved.

Please report bugs to <http://bugs.xfce.org/>.
groucho@devuan:~$ 
xfce4-appfinder 4.10.1 (Xfce 4.10)

Copyright (c) 2004-2011
	The Xfce development team. All rights reserved.

Please report bugs to <http://bugzilla.xfce.org/>.
groucho@devuan:~$ 

I have been able to circumvent the problem by disabling "display compositing" in Xfce.
ie: Settings --> Window Manager Tweaks --> Compositor --> uncheck "enable display compositing", which can only be done with the browser shut down.
ie: if I try to do it with the browser open, it is not possible to uncheck the enable display compositing box.

But there's definitely something going on.

I had Firefox open when I opened Window Manager Tweaks --> Compositor and when I attempted to uncheck "enable display compositing", it would not hold.
Insisting made every window freeze to the extent of having a totally unresponsive desktop with the only way out being a hard reboot.
Noy even Ctl+Alt+Del to log out would respond.

So, once rebooted, I went directly to the settings panel (without starting FF) only to find that compositing was unchecked.

Apparently this drag&drop issue would seem to be common to both Devuan and Ubuntu (Debian based distributions) where Nvidia propietary drivers are being used in a 2 card 2+n monitor setup within a Xfce desktop environment.

It would seem that using the Nouevau drivers does not produce this issue but (in my case) generates severe problems with the XOrg server which were eliminated by using the Nvidia drivers.

See this post:
https://dev1galaxy.org/viewtopic.php?pid=7074#p7074

Note:
I tried to see about reporting this as a bug in sourceforge but could not figure out how to do it properly, I find it is rather over my head as I am not at all familiar with programming.

If there is any other information needed, please ask and I will post it right away.

Thanks in advance,

D.

Last edited by Devuan (2018-03-01 16:34:25)

Offline

Board footer

Powered by FluxBB