Xfce Forum

Sub domains

You are not logged in.

#1 2018-01-13 13:35:02

Registered: 2018-01-07
Posts: 4

Clipman actions don't work

I have clipman 1.4.2.
I tried to use its actions feature in order to get some more or less quick way of calling xfce4-dict for selected text, instead of manual dict start -> select -> paste to dict window.

In order to get clipman actions somehow, i tried to toggle on/off auto-copy selection, use manual/auto actions, change Ctrl key behavior and try with/without it; after reading one previous bug report, tried to enable some certain actions to work only on copy (with default buffer).

Usually, when i just select something in xfce4-terminal (must trigger "Text" pattern), it did not work.
However, i had one exception in xfce4-appfinder compact mode - that time i had auto actions, and menu appeared when i typed comand. It happened several times, but not each after other (sometimes it did not). It was set to not appear when Ctrl is held (as i wrote, its toggle was useless). My expectation in this case, is that menu should appear each time, something new is selected. May be it was so, however, problem appeared even with commands xfce4-popup-clipman*.

When i try xfce4-popup-clipman, menu appears only sometimes.
For xfce4-popup-clipman-actions, while something is selected, usually in terminal as well, i never go any actions menu. I tried to select simple words, jpg file names (to enable image-related actions in menu. Sometimes it opened items menu - not actions - just like xfce4-popup-clipman.

Does anyone yet help this bug?
I assume it to be confirmed, before to report. Last report about clipman actions is found from november in 2016.
Commit/tag for 1.4.2 is dated by july 2017 - doesn't look outdated.

I have from gui libs: gtk+-3.22, libxfce4ui-4.13.4, libxfce4util-4.13.1, glib-2.50.3

Last edited by nick87720z (2018-01-13 13:36:12)


Board footer

Powered by FluxBB