Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-01-17 18:18:30

unni
Member
Registered: 2018-01-17
Posts: 11

[SOLVED] xfce4 mouse cursors

Hi.
I'm trying to set a new mouse cursor theme but so far I've been unable to get it to work.
I've followed every advice I could find, like changing the index.theme files in both ~/.config/default and /usr/share/icons/default and still it is not working.

After rebooting it returns to the default adwaita theme, with some windows displaying a mix of cursors that I don't really know where they are.

Changing it in Settings/Mouse and Touchpad temporarily sets the right icons, but after a restart it defaults again. If I just logout and login it keeps the correct theme.

I've been reading about this on the internet while I tried getting the thing to work and apparently lots of people have this problem too.

I'm running Arch Linux 64-bit.
Can anyone offer a suggestion?
Thank you!

Last edited by unni (2018-01-17 21:48:35)

Offline

#2 2018-01-17 18:43:18

alcornoqui
Member
Registered: 2014-07-28
Posts: 314

Re: [SOLVED] xfce4 mouse cursors

I don't know how to solve the issue, but have you seen this 2013 related thread?

What version of Xfce are you running?

xfce4-about -V

Offline

#3 2018-01-17 18:47:03

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

I'm running 4.12.1.

Yes, I saw that thread. Tried to follow it with no success.
Anyway, thanks for the suggestion

Offline

#4 2018-01-17 19:03:06

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,849

Re: [SOLVED] xfce4 mouse cursors

On my Arch system here, just changing it in Settings Manager > Mouse & Touchpad works and it survives a reboot (though I am running the newest development versions of all of the Xfce packages). I will test it on a vanilla Arch + 4.12 later tonight.

In the meantime, do you have anything in your startup files (~/.Xdefaults, ~/.Xresources) or your GTK configuration files (~/.gtkrc-2.0, ~/.config/gtk-3.0/settings.ini) that may be affecting it?

Offline

#5 2018-01-17 19:38:54

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

As far as I can tell I don't have anything that might conflict.

I've left everything pretty much on standard settings since installation.

I've tried with several pointer themes and it happens with all of them.

This is not a very serious issue, it's just annoying that something apparently so simple is not working...
Anyway, your help is much appreciated!

Offline

#6 2018-01-17 20:17:47

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,849

Re: [SOLVED] xfce4 mouse cursors

Try creating a secondary account on your computer and trying there. Let's try to at least rule out a profile issue.

Offline

#7 2018-01-17 21:22:00

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

Created another account and it works properly! Thanks for the suggestion.

Now what can the issue be? Permissions?

Offline

#8 2018-01-17 21:48:14

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

OK! Found the fix!

I didn't have the "Save session for future logins" checked, and apparently that needs to be checked for the cursor theme to take effect.

So what I did was change to the new cursor theme, then restarted with the "Save session" turned on for the change to take effect. After that I can revert to my previous "Save session" off setting.

Is it supposed to work like this or should this be filed as a bug?

Thank you once more so much for your help

Last edited by unni (2018-01-17 21:49:14)

Offline

#9 2018-01-18 00:01:24

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,849

Re: [SOLVED] xfce4 mouse cursors

unni wrote:

OK! Found the fix!

I didn't have the "Save session for future logins" checked, and apparently that needs to be checked for the cursor theme to take effect.

Hmmm, that doesn't make sense. Try this:
- log out of Xfce
- switch over to text console (probably Ctrl+Alt+F1
- delete the contents of ~/.cache/sessions
- log back in again via the GUI

Try changing the cursor theme but keep the Saved Session unchecked. Restart and see if it holds.

Offline

#10 2018-01-18 01:17:16

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

ToZ wrote:

Hmmm, that doesn't make sense. Try this:
- log out of Xfce
- switch over to text console (probably Ctrl+Alt+F1
- delete the contents of ~/.cache/sessions
- log back in again via the GUI

Try changing the cursor theme but keep the Saved Session unchecked. Restart and see if it holds.

Just tried and it doesn't work.

Apparently it needs a session with the cursors theme saved to keep them. The only file I have now in the ~/.cache/sessions dir is xfce4-session-unni:0 (unni being my username) along with a thumbs dir.

I've tried working the contents of the session file but I couldn't figure out which setting has to do with the cursors

Offline

#11 2018-01-18 01:38:20

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,849

Re: [SOLVED] xfce4 mouse cursors

That is odd. I just tested on my Arch/Xfce 4.12 and Xubuntu 16.04 systems and both just required the change in the Mouse & Touchpad settings (Xubuntu also required a log out and back in again). In both cases, the save session checkbox was unchecked.

Really weird.

Offline

#12 2018-01-18 01:55:35

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

I really don't know what could be preventing the cursor theme to stay persistent, but whatever it is the saved session must be overriding it...

Do you think this warrants a bug report?

Offline

#13 2018-01-18 02:03:58

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,849

Re: [SOLVED] xfce4 mouse cursors

unni wrote:

Do you think this warrants a bug report?

Not unless we can replicate it via a set series of steps. Otherwise it will be too difficult to deal with.

Offline

#14 2018-01-18 11:48:24

unni
Member
Registered: 2018-01-17
Posts: 11

Re: [SOLVED] xfce4 mouse cursors

I found another fix.

I've manually added the cursor theme to the ~/.Xresources file. I've added the following lines:

Xcursor.theme:    theme-name
Xcursor.size:    16
Xcursor.theme_core:    1

I'm leaving this solution here for anyone having the same issue.

Last edited by unni (2018-01-18 11:48:44)

Offline

Board footer

Powered by FluxBB