Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-01-13 13:35:02

nick87720z
Member
Registered: 2018-01-07
Posts: 7

Some clipman actions don't work (was: Clipman actions don't work)

I have clipman 1.4.2.
I tried to use its actions feature in order to get some more or less quick way of calling xfce4-dict for selected text, instead of manual dict start -> select -> paste to dict window.

In order to get clipman actions somehow, i tried to toggle on/off auto-copy selection, use manual/auto actions, change Ctrl key behavior and try with/without it; after reading one previous bug report, tried to enable some certain actions to work only on copy (with default buffer).

Usually, when i just select something in xfce4-terminal (must trigger "Text" pattern), it did not work.
However, i had one exception in xfce4-appfinder compact mode - that time i had auto actions, and menu appeared when i typed comand. It happened several times, but not each after other (sometimes it did not). It was set to not appear when Ctrl is held (as i wrote, its toggle was useless). My expectation in this case, is that menu should appear each time, something new is selected. May be it was so, however, problem appeared even with commands xfce4-popup-clipman*.

When i try xfce4-popup-clipman, menu appears only sometimes.
For xfce4-popup-clipman-actions, while something is selected, usually in terminal as well, i never go any actions menu. I tried to select simple words, jpg file names (to enable image-related actions in menu. Sometimes it opened items menu - not actions - just like xfce4-popup-clipman.

Does anyone yet have this bug?
I assume it to be confirmed, before to report. Last report about clipman actions is found from november in 2016.
Commit/tag for 1.4.2 is dated by july 2017 - doesn't look outdated.

I have from gui libs: gtk+-3.22, libxfce4ui-4.13.4, libxfce4util-4.13.1, glib-2.50.3

Update: the error was in regexp, which whose string was "[A-Za-z0-9]", as i did not know, that after characters - some count specifier most go - any of [.?+*].

Last edited by nick87720z (2018-02-26 11:39:34)

Offline

#2 2018-01-19 00:47:06

alcornoqui
Member
Registered: 2014-07-28
Posts: 267

Re: Some clipman actions don't work (was: Clipman actions don't work)

This bug is all I can find, sorry.

I actually don't use Clipman actions and had a very vague idea of how they worked, but I'm starting to see how helpful they can be, so thank you for that, and good luck with your issue!

Offline

#3 2018-01-20 20:35:04

nick87720z
Member
Registered: 2018-01-07
Posts: 7

Re: Some clipman actions don't work (was: Clipman actions don't work)

Yes, that is bug report, after which i tried to set actions to work only with default buffer).

Offline

#4 2018-02-26 11:18:01

nick87720z
Member
Registered: 2018-01-07
Posts: 7

Re: Some clipman actions don't work (was: Clipman actions don't work)

Hello again.
I eventually discovered source of troubles. Looks like i did not know all rules in regexp creation.
I created "Text" section with regexp "[A-Za-z0-9]" and action "Translate", running xfce4-dict on it.
Caveat there, is that regexp should be "[A-Za-z0-9]+" (i.e. needs specifier, for what amount of chars is selected).
As result, i did not get any menu. Now it is all ok, and since Ctrl behaviour set to "Press to prevent menu popup", it appears stable each time i select something smile
(probably will change back to "Hold Ctrl to popup menu").

Finally implemented another idea - open file action, using exo-open, for path, selected in anywhere (could be path from terminal or passive url text, selected in browser). For now regexp is this: "[^ ]+" - don't know, does it cover all possible char sequences in file paths or urls.

Offline

#5 2018-02-26 11:52:45

nick87720z
Member
Registered: 2018-01-07
Posts: 7

Re: Some clipman actions don't work (was: Clipman actions don't work)

For images group i can't get working regexp.
Initial regexp is this: "(http|ftp).+\.(jpg|png|gif)"
Looks like it is only for web urls, not for local files, but in this case it matches to "httpfdsjfdsfhjks.png".
I changed it to match to any image file name, not just url: ".+\.(jpg|png|gif)"
Then i tried ".+\.png" and ".+png".

Nothing of this works.
When i select "/usr/share/gnuplot/5.2/demo/bldg.png", it matches only to File regexp - "[^ ]+".

I tested almost all action groups (i mean those, bound to same regexp, like image, text, long url).
Besides own defined, i got existing working: long url (with url shortening action) and bugs (for text like "bug #ID" - actions to open xfce or gnome bug with such name).

Last edited by nick87720z (2018-02-26 11:53:16)

Offline

Board footer

Powered by FluxBB