Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-01-23 11:16:41

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 21

Annoying window behaviour (SOLVED)

Since moving from Devuan to PCLinuxOS (both using XFCE), I find myself plagued by a new window behaviour which I find most annoying:

When I move a window to the top of the desktop, it automatically maximises, and I find myself unable to have a non-maximised window in that position.

I also find windows moving from one workspace to another if I get to a side edge of the screen.

I have looked in vain in the Windows Manager, Window Manager Tweaks and Desktop of the XGCE Settings.

Is there a way to stop these annoying behaviours ?

Last edited by rolgiati (2018-01-23 17:33:42)

Offline

#2 2018-01-23 16:19:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,074

Re: Annoying window behaviour (SOLVED)

When I move a window to the top of the desktop, it automatically maximises, and I find myself unable to have a non-maximised window in that position.

Have a look at Settings Manager > Window Manager Tweaks > Accessibility tab, specifically the following settings:

  • Hide frame of window when maximized

  • Hide title of windows when maximized

  • Automatically tile windows when moving toward the screen edge

...and adjust to suit.

I also find windows moving from one workspace to another if I get to a side edge of the screen.

If you want to restrict window movement to the current workspace and not allow wrapping, then Settings Manager > Window Manager > Advanced tab, and uncheck "Wrap workspaces when reaching the screen edge > With a dragged window".


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2018-01-23 17:32:49

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 21

Re: Annoying window behaviour (SOLVED)

That did it, thank you for your kind help.

Offline

Board footer

Powered by FluxBB