Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-01-25 23:43:44

aus9
Member
From: Perth, Australia
Registered: 2018-01-11
Posts: 19

[SOLVED] xfwm4 depends libwnck version 2 not 3 series

Hi

sorry to trouble you again

our repo has libwnck version 3.20.1

xfwm4 dev branch version 4.13.0 gives the following error at configure stage

checking for libwnck-1.0 >= 2.22... not found
*** The required package libwnck-1.0 was not found on your system.
*** Please install libwnck-1.0 (atleast version 2.22) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

but I have libwnck-dev installed (v 3.20.1) as

cat /usr/local/lib/pkgconfig/libwnck-3.0.pc
prefix=/usr/local
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Name: libwnck
Description: Window Navigator Construction Kit library
Version: 3.20.1
Requires: glib-2.0 gobject-2.0 gtk+-3.0
Requires.private: x11 pango cairo libstartup-notification-1.0 xres
Libs: -L${libdir} -lwnck-3
Cflags: -I${includedir}/libwnck-3.0

so compile is looking for libwnck-1.0 not 3.0

This is a puzzlement as in our last discussion xfdesktop compiles well with the gtk3 patch using a higher version of libwnck.

Do you know if git supports the higher version?

Altho I have built a libwnck to that version, my distro maintainer is reluctant to have 2 versions in the repo.

thanks for reading.

Last edited by aus9 (2018-01-26 12:02:04)

Offline

#2 2018-01-26 00:16:40

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,858

Re: [SOLVED] xfwm4 depends libwnck version 2 not 3 series

xfwm4 didn't bump libwnck dependency to 3.0 until after 4.13.0 - for it's GTK3 migration. See: https://git.xfce.org/xfce/xfwm4/commit/ … 04386456c9.

The different components of Xfce have been migrated at different times. You are getting the packages during the middle of this migration where they are not in sync with their external dependencies - in this case xfwm4 & xfdesktop with libwnck.

Ediit: xfce4-panel also depends on libwnck.

Edit2: and xfce4-session, xfdashboard, xfce4-pulseaudio-plugin, xfce4-kbd-plugin, xfce4-taskmanager.

Last edited by ToZ (2018-01-26 00:22:40)

Offline

#3 2018-01-26 04:40:04

aus9
Member
From: Perth, Australia
Registered: 2018-01-11
Posts: 19

Re: [SOLVED] xfwm4 depends libwnck version 2 not 3 series

excellent that it will happen, reluctant to build from git at this stage

however doing a git clone for that package I can see that our repo version of libwnck appears to be supported as

 cat configure.ac.in | grep wnck
m4_define([wnck_minimum_version], [3.14])
XDT_CHECK_PACKAGE([LIBWNCK], [libwnck-3.0], [wnck_minimum_version])

If you don't mind, I won't mark this as solved at this stage?

Offline

#4 2018-01-26 11:43:32

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,858

Re: [SOLVED] xfwm4 depends libwnck version 2 not 3 series

Yes, if you git clone xfwm4, you will get the GTK3-migrated code (still a work in progess) which also includes the bump in libwnck to minimum 3.14.

If you grab the 4.13.0 archive file, the bump has not yet happened.

If your distro isn't willing to ship libwnck 1.0, then you won't be able to build xfwm4 4.13.0.

Offline

#5 2018-01-26 12:01:08

aus9
Member
From: Perth, Australia
Registered: 2018-01-11
Posts: 19

Re: [SOLVED] xfwm4 depends libwnck version 2 not 3 series

Yeah I think that is it.

Its just a timing issue, will now mark as solved as I think when the dev say 4.13.1 comes out I will be back on submission track

thanks for your understanding and knowledge

Last edited by aus9 (2018-01-26 12:03:03)

Offline

Board footer

Powered by FluxBB