Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-03-01 16:31:58

Devuan
Member
Registered: 2018-01-10
Posts: 10

[Solved] LinSSID permission problem

Hello:

My system runs Devuan with the default XFCE desktop environment.

groucho@devuan:~$ uname -a
Linux devuan 3.16.0-5-amd64 #1 SMP Debian 3.16.51-3+deb8u1 (2018-01-08) x86_64 GNU/Linux
groucho@devuan:~$ 

I've installed LinSSID 2.7 to be able to fine tune the channel setting I use for my wireless.

The problem is that it will not run from 'Menu' -> 'Internet' -> LinSSID.

A usual window for running administrative tasks pops-up (because of iwscan needing root access) and when I enter the PW and continue, the window closes but LinSSID does not opne, it stalls/waits for a while and then nothing else.

It seems that there is no problem with the root PW as it is accepted with no problems. ie: by the authentication pop-up, 'su' and 'gksu'.

It's just that for some reason LinSSID will not start from the desktop.

dmesg says nothing about this:

groucho@devuan:~$ dmesg | tail
[   41.481701] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   45.256823] wlan0: authenticate with b4:75:0e:c7:5f:33
[   45.469805] wlan0: send auth to b4:75:0e:c7:5f:33 (try 1/3)
[   45.485188] wlan0: authenticated
[   45.485202] ath9k_htc 1-2:1.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   45.485205] ath9k_htc 1-2:1.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   45.488011] wlan0: associate with b4:75:0e:c7:5f:33 (try 1/3)
[   45.497313] wlan0: RX AssocResp from b4:75:0e:c7:5f:33 (capab=0x411 status=0 aid=2)
[   45.503799] wlan0: associated
[   45.503809] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
groucho@devuan:~$ 

I can only run it successfully from the terminal using 'su' or 'gksu'.

Even though (in both cases) it starts and runs properly, there's some authentication failed output on the terminal when I close the application:

groucho@devuan:~$ gksu linssid
Xlib:  extension "RANDR" missing on display ":0.0".
Xlib:  extension "RANDR" missing on display ":0.0".
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
groucho@devuan:~$ 

I know about the "RANDR" missing as it is disabled by the X server.

root@devuan:/home/groucho# cat /var/log/Xorg.0.log | grep WW
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    28.862] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[    28.862] (WW) NVIDIA:     is an unsupported configuration.  The driver will continue
[    28.862] (WW) NVIDIA:     to load, but may behave strangely.
[    28.862] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[    28.862] (WW) NVIDIA:     X server.
root@devuan:/home/groucho# 

But I have no idea of the authentication protocols or if it matters.

I have installed gnome-system-tools to have a GUI for groups and users management but I do not see a group for LinSSID.

I'd appreciate a lead on this, I've had no takers on the Devuan forum.

Thanks in advance,

A.

Last edited by Devuan (2018-03-26 18:26:30)

Offline

#2 2018-03-01 17:50:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,372

Re: [Solved] LinSSID permission problem

Not really an Xfce issue, but try changing the linssid desktop file (usually /usr/share/applications/linssid.desktop) to use gksudo (which should work given that sudo works). Change the line that reads:

Exec=linssid

...to read:

Exec=gksudo linssid

...and authenticate using your user password when prompted.

Note that you should use gksudo instead of gksu in this instance because it will pass all the proper display variables.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2018-03-01 21:26:40

Devuan
Member
Registered: 2018-01-10
Posts: 10

Re: [Solved] LinSSID permission problem

Hello:

ToZ wrote:

... Not really an Xfce issue ...

OK   =-)
I thought that since I was starting it from the desktop it was (in some way) Xfce related.

ToZ wrote:

... try changing the linssid desktop file ...

Yes, it's in usr/share/applications

ToZ wrote:

Change the line ... ...to read:

Exec=gksudo linssid

...and authenticate using your user password when prompted.

The line already reads 'gksudo linssid' and the owner of the file is root.

When I try to start the app, I 'do' get the pop-up asking for the PW and it 'is' accepted.
The problem is that the damn thing won't start.

I have a faint memory of once (another distro, many moons ago) having started a graphics application from the terminal with 'sudo' instead of 'gksudo' and having a permissions issue after that but I cannot recall how I fixed it.

Anything else I could try?

Thanks in advance,

D.

Last edited by Devuan (2018-03-01 21:33:21)

Offline

#4 2018-03-02 00:28:46

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,372

Re: [Solved] LinSSID permission problem

Xfce uses the Desktop Entry Specification for defining application menu entires and the menu spec for creating menus. As does Mate, Gnome, etc. So if there is a problem with the application menu entry, there is a strong likelihood that it's not because of the DE being used. Can you post back the full contents of the /usr/share/applications/linssid.desktop file?

Does running it in a terminal like:

gksudo linssid

...work? Do you get any messages in the terminal window?

And as for the potential permission issue, make sure that you own all of the files in your root directory (especially .Xauthority and .ICEauthority). Post back the results of the following command:

ls -al $HOME | grep authority

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#5 2018-03-02 10:03:36

Devuan
Member
Registered: 2018-01-10
Posts: 10

Re: [Solved] LinSSID permission problem

Hello:

ToZ wrote:

... it's not because of the DE being used.

I see ...

ToZ wrote:

Can you post back the full contents of the /usr/share/applications/linssid.desktop file?

Of course:

[Desktop Entry]
Version=2.7
Name=LinSSID
GenericName=
Comment=Find local wireless attach points
Exec=gksudo linssid
Icon=/usr/share/pixmaps/linssid48.png
Terminal=false
Type=Application
Categories=Application;Network
Name[en]=LinSSID
Keywords=Network;Wireless;WiFi;Monitor;Channel;Power
ToZ wrote:

Does running it in a terminal like:

gksudo linssid

...work? Do you get any messages in the terminal window?

No.
gksudo does not work.

I am able to run it successfully from the terminal as root and using gksu.
Even though (in both cases) it starts and runs properly, there's some authentication failed output on the terminal:

groucho@devuan:~$ gksu linssid
Xlib:  extension "RANDR" missing on display ":0.0".
Xlib:  extension "RANDR" missing on display ":0.0".
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
groucho@devuan:~$ 
ToZ wrote:

... make sure that you own all of the files in your root directory (especially .Xauthority and .ICEauthority).
Post back the results of the following command:

ls -al $HOME | grep authority

OK.

-rw-------  1 groucho groucho       954 Mar  2 06:40 .ICEauthority
-rw-------  1 groucho groucho        51 Mar  2 06:40 .Xauthority
groucho@devuan:~$ 

Edit:
Apparently using gksu instead of gksudo solves the problem and LinSSID will run properly.
ie:

[Desktop Entry]
Version=2.7
Name=LinSSID
GenericName=
Comment=Find local wireless attach points
Exec=gksu linssid
Icon=/usr/share/pixmaps/linssid48.png
Terminal=false
Type=Application
Categories=Application;Network
Name[en]=LinSSID
Keywords=Network;Wireless;WiFi;Monitor;Channel;Power

As to why this is so I have the idea that it is a permission probles of some sort.
ie: with respect to LinSSID, gksudo is clearly not enough while gksu is.

I'm a novice with all this but I think that it has to do with LinSSID needing to run iwscan which in turn needs root authorization.

groucho@devuan:~$ sudo iw
[sudo] password for groucho: 
Sorry, user groucho is not allowed to execute '/sbin/iw' as root on devuan.
groucho@devuan:~$ 
groucho@devuan:~$ su
Password: 
root@devuan:/home/groucho# iw
Usage:    iw [options] command
Options:
    --debug        enable netlink debugging
    --version    show version (3.17)
Commands:
    help [command]
    event [-t] [-r] [-f]
--- snip ---

I this right or is there something amiss?

Thanks in advance,

D.

Last edited by Devuan (2018-03-02 11:10:39)

Offline

#6 2018-03-02 12:12:39

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,372

Re: [Solved] LinSSID permission problem

Okay. It looks like sudo is the issue. Is it properly set up? Does your user have membership in the right group?


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#7 2018-03-02 17:01:57

Devuan
Member
Registered: 2018-01-10
Posts: 10

Re: [Solved] LinSSID permission problem

Hello:

ToZ wrote:

Okay. It looks like sudo is the issue.

So it seems.

ToZ wrote:

Is it properly set up?
Does your user have membership in the right group?

No ...

I recall the Devuan setup script asked if I would use su or sudo and, remembering that my other setup (PCLinuxOS) does not set up sudo by default, I decided to do the same.

Which is the main reason this issue cropped up.  =-/
I've had a look at the .desktop file for LinSSID in PCLinux and it uses exec=gksu linssid.
Something I should have done from the start.

Thank you very much for your help/patience in this matter, I have learnt something new.

Best,

D.

Offline

Board footer

Powered by FluxBB