Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-03-12 22:47:28

aklaing
Member
Registered: 2018-03-12
Posts: 2

How to change key bindings for xfce-terminal ?

I have used the instructions quoted below for an older version of xfce-terminal on xubuntu 16.04 and it worked.  The source is on the last line of the quote.
I have just upgraded to xubuntu 18.04 LTS beta (daily build as of March 12), and the instructions below don't seem to work anymore.
Any ideas how I could get this to work?

# use the following to create keybindings for
# the xfce terminal.
#
# Start (Mouse) Button -> Settings -> Appearance -> Settings (fourth tab) -> CHECK the Third checkbox under "Menus and Buttons" ie "Enable Editable Accelerators"
#
# Create a terminal, and use menu to create an extra tab in it.
#
# Open the menu item for "Tabs", and hover over each of the first four items, and while hovering, type your preferred keyboard shortcut.
#
# Source/Credit:
# http://docs.xfce.org/faq
# http://docs.xfce.org/xfce/xfce4-setting … nd_buttons

Thank you,

Ambrose

Offline

#2 2018-03-12 23:13:35

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,625

Re: How to change key bindings for xfce-terminal ?

Hello and welcome.
You're probably using a gtk3 build of xfce4-terminal. The "hover and change accelerator" is a GTK2 feature.

To change the keyboard shortcuts in a gtk3 build of xfce4-terminal, edit the file ~/.config/xfce4/terminal/accels.scm, find the action/shortcut you want to change, remove the leading ";" (semicolon) from the line and change the shortcut at the end of line.

Save the file and quit all instances of and restart xfce4-terminal.

Offline

#3 2018-03-13 16:05:21

aklaing
Member
Registered: 2018-03-12
Posts: 2

Re: How to change key bindings for xfce-terminal ?

Thank you -- your advice resolved the issue!
Best regards

Offline

Board footer

Powered by FluxBB