Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-04-10 01:51:11

ccarminati
Member
Registered: 2018-04-10
Posts: 4

Most apps not running

I have ubuntu 16.04.24 and xfce4 runs just fine with startx command.

Some apps (browser for example) give me input/output errors.

Others like virt-manager (virtual machine manager) wont start but no errors. Clicking on most apps does nothing.

Gnome compatibility is running.

Any ideas?

CC.

Offline

#2 2018-04-10 01:56:47

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,174

Re: Most apps not running

Input/Output errors are generally a sign of a failing hard drive. Now would be the time to back up any important data that you have.

Try running the apps that won't start in a terminal window and post back the exact error messages. For virt-manager, try:

virt-manager --no-fork --debug

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2018-04-10 02:01:48

ccarminati
Member
Registered: 2018-04-10
Posts: 4

Re: Most apps not running

virt-manager --no-fork --debug
[Mon, 09 Apr 2018 21:59:51 virt-manager 138331] DEBUG (cli:256) Launched with command line: /usr/share/virt-manager/virt-manager --no-fork --debug
[Mon, 09 Apr 2018 21:59:51 virt-manager 138331] DEBUG (virt-manager:143) virt-manager version: 1.3.2
[Mon, 09 Apr 2018 21:59:51 virt-manager 138331] DEBUG (virt-manager:144) virtManager import: <module 'virtManager' from '/usr/share/virt-manager/virtManager/__init__.pyc'>

In regards to input/output errors... If I use xfce terminal - no errors. Gnome Terminal in/out error...

Last edited by ccarminati (2018-04-10 02:07:15)

Offline

#4 2018-04-10 02:26:35

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,174

Re: Most apps not running

Check the status of your hard drive. See: https://help.ubuntu.com/community/Smartmontools.

Can you show an example of the input/output error that a browser generates in gnome-terminal? Copy and paste the full output.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#5 2018-04-10 02:36:43

ccarminati
Member
Registered: 2018-04-10
Posts: 4

Re: Most apps not running

If I select gnome terminal as preferred app...  when I click on it I get "Failed to execute default terminal emulator Input/output error"

Same message for browser.

Changing default terminal to xfce4 terminal opens just fine. Doesnt look like hd issue...

Most apps , like disk usage analizer, virt manager, gedit, etc ...clicking on them returns no result...does nothing...

https://www.linuxquestions.org/question … 1523311305

Last edited by ccarminati (2018-04-10 02:40:50)

Offline

#6 2018-04-10 02:46:56

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,174

Re: Most apps not running

ccarminati wrote:

Changing default terminal to xfce4 terminal opens just fine. Doesnt look like hd issue...

I'm not so sure that you can make that assumption - input/output errors are a general sign that a hard drive is failing. The failure may not happen all at once and may affect different areas of the hard drive - and it may initially seem to affect some apps but not others. See what smartmontools says, from my link above, on the status of your hard drive.

Edit:

Most apps , like disk usage analizer, virt manager, gedit, etc ...clicking on them returns no result...does nothing...

Don't click on them. Run them manually in the xfce4-terminal window and post back error messages.

Also look at ~/.xsession-errors (or ~/.cache/upstart/startxfce4.log) - I'm not sure which file that version of ubuntu uses.

Last edited by ToZ (2018-04-10 02:48:58)


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#7 2018-04-10 03:03:55

ccarminati
Member
Registered: 2018-04-10
Posts: 4

Re: Most apps not running

Running gedit on terminal - no result
Running firefox on terminal - no result
Running calendar on terminal - runs fine
Running filezilla on terminal - runs fine


cat  ~/.xsession-errors
Xsession: X session started for root at Sun Apr  8 22:46:12 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for root at Sun Apr  8 22:46:51 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for root at Sun Apr  8 23:09:09 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for root at Sun Apr  8 23:09:44 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for root at Sun Apr  8 23:16:05 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for charles at Mon Apr  9 12:43:39 EDT 2018
localuser:charles being added to access control list
Can't save user-dirs.dirs
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for root at Mon Apr  9 12:43:53 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for root at Mon Apr  9 12:44:14 EDT 2018
localuser:root being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0

locate startxfce4.log : file doesnt exist.

Offline

Board footer

Powered by FluxBB