Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-08-07 06:28:35

johnywhy
Member
Registered: 2011-10-09
Posts: 151

[Solved] Make clicks in scrollbar page down, not jump?

Most desktops and apps scroll by one-screen, when you click in the scroll-lane above or below the scrollbox.
But in my xfce, in several apps (not all), the page jumps to the relative page-location-- even if it's a jump of many pages, or less than one page.

wwM2xrJ.png

Last edited by johnywhy (2018-08-23 23:11:50)


Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

#2 2018-08-07 13:05:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,740

Re: [Solved] Make clicks in scrollbar page down, not jump?

If you are talking about gtk3 apps, see: https://blog.gtk.org/2017/10/11/a-scrolling-primer/. For firefox, see: http://kb.mozillazine.org/Ui.scrollToClick.

Online

#3 2018-08-07 18:48:03

johnywhy
Member
Registered: 2011-10-09
Posts: 151

Re: [Solved] Make clicks in scrollbar page down, not jump?

great! the setting is:
gtk-primary-button-warps-slider

i believe i put that into ~/.config/gtk-3.0/settings.ini, correct?
is there a gui to edit that, or a gui for this particular setting?

THX

Last edited by johnywhy (2018-08-07 18:48:56)


Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

#4 2018-08-07 21:41:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,740

Re: [Solved] Make clicks in scrollbar page down, not jump?

johnywhy wrote:

i believe i put that into ~/.config/gtk-3.0/settings.ini, correct?

Yes.

is there a gui to edit that, or a gui for this particular setting?

No. You have to do it manually. And log out and back in again for it to take effect.

Online

#5 2018-08-08 00:02:05

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,000

Re: [Solved] Make clicks in scrollbar page down, not jump?

johnywhy wrote:

Most desktops and apps scroll by one-screen, when you click in the scroll-lane above or below the scrollbox.
But in my xfce, in several apps (not all), the page jumps to the relative page-location-- even if it's a jump of many pages, or less than one page.

Whichever developer it was that came up with that change to something so basic (and perfectly useful as it was) ought to have the next home improvement person he/she hires suddenly decide to knock a hole in the developer's roof "because, hey, it's a lot easier than doing something useful, and the developer is obviously someone who thinks change has a value all by itself, regardless of the thing being changed or what said thing gets changed to."

I know this was not an Xfce developer's decision, because that team appears to understand that one makes a change for a reason, and doesn't seem to throw a bunch of "garbage changes" into their work just so they can (attempt to) justify their existence.

In my honest opinion, of course. It's times like this that make me wish the Xfce team was large enough that it could spare the (likely many) hours it'd take to create their own toolkit instead of (the) reality (of having a very small developer team) forcing them to use the twaddle that is GTK. We all understand the term "code-bloat" even those of us who've never coded. Here's one that should be discussed: Developer-bloat. That's where you have people on your team that have so little useful contributions to make - or care so little about doing so - that they've actually got the time to do stuff like this. Is your product perfect and final? No? Then stop screwing around wasting time actively making it worse!

But, really, I just wanted to post so that I could state:

ToZ, thank you very much (again) for posting the links/help. I'd forgotten where they were, lol.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#6 2018-08-08 00:43:30

johnywhy
Member
Registered: 2011-10-09
Posts: 151

Re: [Solved] Make clicks in scrollbar page down, not jump?

MountainDewManiac wrote:

Developer-bloat. That's where you have people on your team that have so little useful contributions to make - or care so little about doing so - that they've actually got the time to do stuff like this.

Great post, and i agree!

And yes, THANKS tOz FOR BEING AWESOME.

Last edited by johnywhy (2018-08-11 17:00:47)


Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

#7 2018-08-11 09:44:59

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,000

Re: [Solved] Make clicks in scrollbar page down, not jump?

I was actually returning to this thread to apologize for that little rant, but thank you.

I'm sorry for the rant, folks. It was ill-considered, in that it was off-topic, IMHO.

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#8 2018-08-11 18:56:54

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,740

Re: [Solved] Make clicks in scrollbar page down, not jump?

There is a lot of "Thanks ToZ" going around. No need to thank me. I'm doing what I enjoy.

Online

#9 2018-08-23 23:10:44

johnywhy
Member
Registered: 2011-10-09
Posts: 151

Re: [Solved] Make clicks in scrollbar page down, not jump?

Solution:
Edit (or create) the file:

~/.config/gtk-3.0/settings.ini

And add the following:

[Settings]
gtk-primary-button-warps-slider = false

https://askubuntu.com/a/296406


Mint 19 xfce, 4.15.0-29-generic #31-Ubuntu SMP, x86_64 x86_64 x86_64 GNU/Linux

Offline

Board footer

Powered by FluxBB