Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-25 19:39:46

schnappi
Member
Registered: 2018-04-16
Posts: 15

"Go to containing folder" in Firefox downloads open Catfish

When click "Go to containing folder" for an item in Firefox downloads (right click a downloaded item to see this option) am taken to Catfish File Search rather than the containing folder.

Confirmed this is not a Firefox issue by replicating with different Firefox profile but not sure if this is necessarily an XFCE issue. Doesn't occur on desktop but does occur on laptop that started using more recently.

Tried removing Catfish (sudo pacman -Rnssu catfish) to see what would happen but go this error (all below is probably an Arch issue though):

checking dependencies...
warning: removing catfish from target list
warning: removing python-cairo from target list
warning: removing python-pexpect from target list
warning: removing python-ptyprocess from target list
warning: removing python-xdg from target list
there is nothing to do.

Offline

#2 2018-07-25 20:41:54

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,846

Re: "Go to containing folder" in Firefox downloads open Catfish

You have a mixed up mime association. Try resetting it so that directories are opened by your file manager of choice:

xdg-mime default exo-file-manager.desktop inode/directory

Offline

#3 2018-08-01 17:18:17

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: "Go to containing folder" in Firefox downloads open Catfish

Thanks. Ran the above command as both user and sudo. Still having same issue but have not yet tried closing programs or logging in/ out and restarting. All of which hopefully will be final step in resolving mime association mix-up.

Offline

#4 2018-08-01 18:34:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,846

Re: "Go to containing folder" in Firefox downloads open Catfish

If it doesn't, post back:

xdg-mime query default  inode/directory

Now that I look at my system, it points to Thunar-folder-handler.desktop.

Maybe also try:

xdg-mime default Thunar-folder-handler.desktop inode/directory

Offline

#5 2018-08-01 18:54:26

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: "Go to containing folder" in Firefox downloads open Catfish

Ran both without success. Am running Arch. Secondly would restarting a program/ logging in and out be necessary to reset mime associations?

Looking through this now as well: https://wiki.archlinux.org/index.php/De … plications

Last edited by schnappi (2018-08-01 18:55:33)

Offline

#6 2018-08-01 21:18:57

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,846

Re: "Go to containing folder" in Firefox downloads open Catfish

schnappi wrote:

Ran both without success. Am running Arch. Secondly would restarting a program/ logging in and out be necessary to reset mime associations?

No. It should be automatic. Those commands work here for me (also Arch). The effect is immediate.

Do you have xdg-utils installed?

Can you post back the results of the following:

xdg-mime query default inode/directory

Also:

grep "inode/directory" ~/.config/mimeapps.list

and:

grep "inode/directory" /usr/share/applications/mimeinfo.cache

Offline

#7 2018-08-02 16:08:13

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: "Go to containing folder" in Firefox downloads open Catfish

Thunar-folder-handler.desktop

inode/directory=Thunar-folder-handler.desktop

inode/directory=catfish.desktop;Thunar-folder-handler.desktop;

Third result is suspect.

xdg-utils is installed.

@ToZ thanks for help so far.

Last edited by schnappi (2018-08-02 16:09:37)

Offline

#8 2018-08-02 17:13:38

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,846

Re: "Go to containing folder" in Firefox downloads open Catfish

The third one is default - local can override. What does the following return:

grep "inode/directory" ~/.local/share/applications/mimeinfo.cache

Offline

#9 2018-08-03 23:21:23

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: "Go to containing folder" in Firefox downloads open Catfish

/home/user/.local/share/applications/mimeinfo.cache: No such file or directory

At some point during this process the issue has been solved in Firefox. Palemoon (binary not package) continues to have same issue. Prior to ToZ's suggestions the issue occurred in both Firefox and Palemoon binary version.

Offline

#10 2018-08-11 08:11:28

tulliana
Member
From: Turkey
Registered: 2018-08-11
Posts: 1
Website

Re: "Go to containing folder" in Firefox downloads open Catfish

Open the Xfce Settings Manager


Click on Prefferred Applications
arch_archman_xfcepreferred_applications.png

Scroll to the Utilities tab and select the thunar or other file manager again
arch_archman_xfcepreferred_applications_thunar.png


check back now please..

Last edited by tulliana (2018-08-11 08:12:39)


Archman GNU/Linux Developer
http://archman.org/en

Offline

#11 2018-08-24 21:19:19

schnappi
Member
Registered: 2018-04-16
Posts: 15

Re: "Go to containing folder" in Firefox downloads open Catfish

Still not functioning correctly. Greatly appreciate the prompt help, but going to let this issue go. Not a big deal.

Offline

#12 2018-09-01 21:59:12

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 163

Re: "Go to containing folder" in Firefox downloads open Catfish

Firefox has issues opening linux files in correct app. I have deb files set to open in firefox with gdebi but it always open them with my chess program (scidb) nothing fixes it

Offline

Board footer

Powered by FluxBB