Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-10-11 22:07:40

isosdeb
Member
Registered: 2018-10-11
Posts: 1

Problemas con SRIPTS sh en thunar

Normalmente para ejecutar con doble click un archivo sh en thunar suelo colocar "usar una orden personalizada" : xfce4-terminal -x y es suficiente para que trabaje. tengo varias computadoras con debian buster y lo configuré igualmente y funciona sin problema, pero esta vez no puedo hacer que funcione. Simplemente no sucede nada. Agradezco la ayuda.

Offline

#2 2018-10-11 22:36:50

alcornoqui
Member
Registered: 2014-07-28
Posts: 305

Re: Problemas con SRIPTS sh en thunar

¡Hola isosdeb, bienvenido al foro! He traducido tu mensaje al inglés, así será más fácil que encontremos una respuesta.

[here's isosdeb question, translated into english, can you help?]

Normally to execute with double click an .sh file in Thunar I use a custom action:

xfce4-terminal -x

and that's enough for it to work. I have several computers with Debian Buster equally configured and it works without problem, but this time I can not make it work. Nothing just happens. I appreciate the help.

Offline

#3 2018-10-11 22:50:12

alcornoqui
Member
Registered: 2014-07-28
Posts: 305

Re: Problemas con SRIPTS sh en thunar

Creo que encontré algo, en este hilo:

Hacer que los scripts de shell se ejecuten así a través de Thunar o desde el escritorio fue considerado un riesgo de seguridad (era demasiado fácil ejecutar un script por error), por lo que la funcionalidad paso a estar desactivada de forma predeterminada. Puedes volver a habilitar esa funcionalidad habilitando la clave misc-exec-shell-scripts-by-default. Para hacerlo, crea la clave a través del Editor de Configuración (xfce4-settings-editor), o ejecuta el siguiente comando:

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true

Offline

Board footer

Powered by FluxBB