Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-11-08 16:39:16

jgilmore
Member
Registered: 2018-11-08
Posts: 4

xfconf-query not seeing xfce4-settings-editor settings.

I'm pretty sure I know how this is supposed to work:

xfconf-query --create -t string -c "xfce4-keyboard-shortcuts" -p "/commands/custom/<Super><Ctrl>KP_Page_Down" -s "$0 3"

But it does nothing. More precisely, I can create shortcuts using "xfce4-settings-editor" and they work. And *seem* to be accessing the same namespace.

But I can't see those settings with xfconf-query! And things set using xfconf-query have no effect!

I tried

(for channel in `xfconf-query`;do for prop in `xfconf-query -c "$channel" -l`; do echo -n "$prop" "=== "; xfconf-query -c "$channel" -p "$prop";done;done )| grep Super

and the hotkeys set using the settings editor (which work) don't show up *at* *all* but the ones (which don't work) that I've set using xfconf-query *do*.

WTF!

Anyway, details:

xfwm4 -V
    This is xfwm4 version 4.12.4 (revision 7844952) for Xfce 4.12
    Released under the terms of the GNU General Public License.
    Compiled against GTK+-2.24.31, using GTK+-2.24.32.

    Build configuration and supported features:
    - Startup notification support:                 Yes
    - XSync support:                                Yes
    - Render support:                               Yes
    - Xrandr support:                               Yes
    - Embedded compositor:                          Yes
    - KDE systray proxy (deprecated):               No

ps ax | grep sett
18231 ?        Ssl    0:00 xfsettingsd --display :0.0 --sm-client-id 25daf1883-95c9-4118-851b-5278fa462a8a
22593 ?        Sl     0:00 xfce4-settings-editor
23493 pts/0    S+     0:00 grep --color=auto sett

I'm stumped for the next step here. How do I get xfconf-query to point at the same database/namespace that xfce4-settings-editor does? 'Cause far as I can tell? Yeah, they're not talking to each other at all.

**edit: grammar

Last edited by jgilmore (2018-11-08 16:46:51)

Offline

#2 2018-11-08 21:14:25

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,769

Re: xfconf-query not seeing xfce4-settings-editor settings.

Hello and welcome.

Okay. I've been looking at this today and have found something interesting (and confusing).
- On Xfce 4.12 (Xubuntu 18.04), I can replicate this problem.
- On Xfce 4.13 (xfsettingsd version 4.13.4 on Xubuntu 18.10), I can replicate this problem.
- However, on the latest development release, 4.13 (on Arch, xfsettingsd version 4.13.5), it works fine. But only if I create two entries: one for <Primary> and one for <Ctrl>.

Not sure what to make of this, but definitely some sort of bug at work here. Perhaps create a bug report.

Offline

#3 2018-11-08 21:50:46

jgilmore
Member
Registered: 2018-11-08
Posts: 4

Re: xfconf-query not seeing xfce4-settings-editor settings.

What did you see exactly?

Did you test the visibility of hotkeys created using the editor, or just if hotkeys created using xfconf-query work?

If you create the key using xfce4-settings-editor, can you SEE them with xfconf-query? 'Cause that's the thing that's really blowing my mind. And maybe think that xfconf-query is looking and editing something somewhere else that happens to be completely disconnected.


Obviously, my question was unclear. I'm seeing:
1. hotkeys created with the editor are invisible to xfconf-query.
2. hotkeys created with xfconf-query are non-functional.

Both are problems, and maybe/probably are functions of some root underlying cause.

I noticed the <Primary> thing when creating hotkeys using the editor. You say neither one worked by itself? That's more than a little strange.

If this is a bug (and somethings going on here for sure) then while it may not be fixed in the latest development release, it's at least morphed?

Offline

#4 2018-11-08 23:34:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,769

Re: xfconf-query not seeing xfce4-settings-editor settings.

jgilmore wrote:

Did you test the visibility of hotkeys created using the editor, or just if hotkeys created using xfconf-query work?

I only tested creating the shortcut with xfconf-query. In all cases it showed up immediately in the settings editor. Using the third system, changes made in the settings editor are reported by xfconf-query. I'll see if I can test the other two systems.

I noticed the <Primary> thing when creating hotkeys using the editor. You say neither one worked by itself? That's more than a little strange.

Yeah, that is the really strange part.

If this is a bug (and somethings going on here for sure) then while it may not be fixed in the latest development release, it's at least morphed?

Thats what it looks like.

Offline

#5 2018-11-09 13:47:50

jgilmore
Member
Registered: 2018-11-08
Posts: 4

Re: xfconf-query not seeing xfce4-settings-editor settings.

ToZ wrote:
jgilmore wrote:

Did you test the visibility of hotkeys created using the editor, or just if hotkeys created using xfconf-query work?

I only tested creating the shortcut with xfconf-query. In all cases it showed up immediately in the settings editor. Using the third system, changes made in the settings editor are reported by xfconf-query. I'll see if I can test the other two systems.

Ok, so what you're saying here is that my system probably has some weird misconfiguration somewhere that's casing this to happen. Because it's very consistent on my system that hotkeys added by either tool are totally invisible to the other tool. And since you've tested it and non seen that behavior on a (fairly closely) matching system.... Yeah.

So what might be causing that? Where might xfconf-query be pointing that's "wrong" and how to I fix it?

Offline

#6 2018-11-09 13:54:18

jgilmore
Member
Registered: 2018-11-08
Posts: 4

Re: xfconf-query not seeing xfce4-settings-editor settings.

Bug report created:

https://bugzilla.xfce.org/show_bug.cgi?id=14861

Would you double-check that? I'd hate for my bug creating script to fail against the latest development release, and I haven't built it.

Offline

#7 2018-11-09 19:42:14

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,769

Re: xfconf-query not seeing xfce4-settings-editor settings.

Validated in 18.04 (Xfce 4.12) that creating keyboard shortcuts in the settings editor are visible via xfconf-query. They don't work though.

Regarding the visibility of xfconf-query changes in the settings editor, can you try the same test with a secondary account on your computer?

Offline

Board footer

Powered by FluxBB