Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-01-08 07:04:04

FateRover
Member
Registered: 2018-08-26
Posts: 32

how to enable gtk3 theme

i use xfce4.12 ,i noticed  xfce always set gtk2 theme as default though the theme  contain  GTK2 and GTK3 parts

Offline

#2 2019-01-08 15:31:04

juky
Member
Registered: 2018-12-18
Posts: 5

Re: how to enable gtk3 theme

Slt ,
you must enter the following command: replacing xxxxxx with the name of the theme used.
(gtk : )

gsettings set org.gnome.desktop.interface gtk-theme xxxxxx

(wm theme : )

gsettings set org.gnome.desktop.wm.preferences theme xxxxxx

bye

Last edited by juky (2019-01-08 15:34:11)

Offline

#3 2019-01-08 18:19:10

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,384

Re: how to enable gtk3 theme

@juky, I don't see how that will work for Xfce.

@Faterover, if I understand correctly, make sure that the theme that you are using has both gtk2 (a gtk-2.0 folder) and gtk3 (a gtk-3.xx folder) components and that the theme supports the version of GTK3 that you have installed. Test with the Greybird theme - it will be most up to date.

Also ensure that you don't have any errant entries in ~/.gtkrc-2.0, ~/.config/gtk-3.0/gtk.css or ~/.config/gtk-3.0/settings.ini.

Offline

#4 2019-01-08 20:16:49

juky
Member
Registered: 2018-12-18
Posts: 5

Re: how to enable gtk3 theme

Slt,
sorry, i misunderstood google translate ....
these commands are useful to make maj screenfetch for example!
@ +

Offline

#5 2019-01-09 04:28:34

FateRover
Member
Registered: 2018-08-26
Posts: 32

Re: how to enable gtk3 theme

installed  graybird theme, but neofetch   still show  under gtk2

Offline

#6 2019-01-09 11:36:11

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,384

Re: how to enable gtk3 theme

FateRover wrote:

installed  graybird theme, but neofetch   still show  under gtk2

Please post back the results of the following commands:

xfconf-query -c xsettings -p /Net/ThemeName
cat ~/.gtkrc-2.0
cat ~/.config/gtk-3.0/gtk.css
cat ~/.config/gtk-3.0/settings.ini
ls -l "/usr/share/themes/$(xfconf-query -c xsettings -p /Net/ThemeName)"
xfconf-query -c xfwm4 -p /general/theme

Offline

#7 2019-01-09 11:59:09

FateRover
Member
Registered: 2018-08-26
Posts: 32

Re: how to enable gtk3 theme

"没有那个文件或目录"   mean  no such file or direction

bad@Badmin:~$ xfconf-query -c xsettings -p /Net/ThemeName
Greybird
bad@Badmin:~$ cat ~/.gtkrc-2.0
cat: /home/bad/.gtkrc-2.0: 没有那个文件或目录
bad@Badmin:~$ cat ~/.config/gtk-3.0/settings.ini
cat: /home/bad/.config/gtk-3.0/settings.ini: 没有那个文件或目录
bad@Badmin:~$ ls -l "/usr/share/themes/$(xfconf-query -c xsettings -p /Net/ThemeName)"
总用量 60
drwxr-xr-x 2 root root  4096 1月   9 19:54 gnome-shell
-rw-r--r-- 1 root root 19182 12月  3 11:02 Greybird.emerald
drwxr-xr-x 4 root root  4096 1月   9 19:54 gtk-2.0
drwxr-xr-x 4 root root  4096 1月   9 19:54 gtk-3.0
-rw-r--r-- 1 root root   229 12月  3 11:02 index.theme
drwxr-xr-x 2 root root  4096 1月   9 19:54 metacity-1
drwxr-xr-x 2 root root  4096 1月   9 19:54 plank
-rw-r--r-- 1 root root   162 12月  3 11:02 ubiquity-panel-bg.png
drwxr-xr-x 2 root root  4096 1月   9 19:54 unity
drwxr-xr-x 2 root root  4096 1月   9 19:54 xfce-notify-4.0
drwxr-xr-x 2 root root  4096 1月   9 19:54 xfwm4
bad@Badmin:~$ xfconf-query -c xfwm4 -p /general/theme
Greybird
bad@Badmin:~$ cat ~/.config/gtk-3.0/gtk.css
cat: /home/bad/.config/gtk-3.0/gtk.css: 没有那个文件或目录
bad@Badmin:~$ neofetch
       _,met$$$$$gg.          bad@Badmin 
    ,g$$$$$$$$$$$$$$$P.       ---------- 
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux buster/sid x86_64 
 ,$$P'              `$$$.     Kernel: 4.19.0-1-amd64 
',$$P       ,ggs.     `$$b:   Uptime: 7 mins 
`d$$'     ,$P"'   .    $$$    Packages: 1514 (dpkg) 
 $$P      d$'     ,    $$P    Shell: bash 4.4.23 
 $$:      $$.   -    ,d$$'    Resolution: 1920x1080 
 $$;      Y$b._   _,d$P'      DE: Xfce 
 Y$$.    `.`"Y$$$$P"'         WM: Xfwm4 
 `$$b      "-.__              WM Theme: Greybird 
  `Y$$                        Theme: Greybird [GTK2] 
   `Y$$.                      Icons: Numix-White [GTK2] 
     `$$b.                    Terminal: xfce4-terminal 
       `Y$$b.                 Terminal Font: Monospace 12 
          `"Y$b._             CPU: Intel i5-4590 (4) @ 3.700GHz 
              `"""            GPU: NVIDIA GeForce GTX 750 Ti 
                              Memory: 1183MiB / 15960MiB 

Last edited by FateRover (2019-01-09 12:01:34)

Offline

#8 2019-01-09 14:07:58

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,384

Re: how to enable gtk3 theme

Ok, I see. That is just the way that NeoFetch is reporting it our. I'm not sure why it does that. Perhaps you can ask their developers.

Offline

#9 2019-01-09 15:49:42

FateRover
Member
Registered: 2018-08-26
Posts: 32

Re: how to enable gtk3 theme

the neofetch show the wrong info?but if i download themes  contain  gtk2 and gtk3 component  from xfce-look and place them  in .themes folder,xfce always treat them as  gtk2  themes, if i  delete the gtk2 folder of the  themes, they will  disappeared in the xfce4-appearance-settings list

Offline

Board footer

Powered by FluxBB