Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-04-26 01:57:53

Mellowbob
Member
Registered: 2011-10-16
Posts: 164

Todo after update to ubuntu 19.04

I've been running xfce4 on top of a ubuntu install for some time and recently updated to 19.04. I've had to make some minor changes, but 2 interesting (to me) things were to add the following to my session->autostart.

1. Enable screen locker. It just worked out of the box before,
2. And an entry (could not just click this) for xfce4-notifyd, with:
       /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
as the command. Again, this just worked before.

A bit of head scratching, but it seems to be fine now. We might want to list other things for folks to consider after an "upgrade".

Last edited by Mellowbob (2019-04-26 02:05:31)

Offline

#2 2019-04-26 02:10:08

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,825

Re: Todo after update to ubuntu 19.04

Mellowbob wrote:

2. And an entry (could not just click this) for xfce4-notifyd, with:
       /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
as the command. Again, this just worked before.

xfce4-notifyd should now be auto-started by systemd. What does the following return for you?

systemctl --user status xfce4-notifyd.service

Offline

#3 2019-04-26 16:49:13

Mellowbob
Member
Registered: 2011-10-16
Posts: 164

Re: Todo after update to ubuntu 19.04

Yeah, I tried systemd first and started by checking to see if the file was in
   /usr/lib/systemd/user/xfce4-notifyd.service

and, yes, it is:

    [Unit]
Description=XFCE notifications service

[Service]
Type=dbus
BusName=org.freedesktop.Notifications
ExecStart=/usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd

So, I make sure that xfce-notifyd is not running and do

  bob$ systemctl --user status xfce4-notifyd.service
● xfce4-notifyd.service - XFCE notifications service
   Loaded: loaded (/usr/lib/systemd/user/xfce4-notifyd.service; static; vendor preset: ena
   Active: inactive (dead)

and I lose my nice notifies sad

I would have thought that this should all just magically work.

Offline

#4 2019-04-27 02:51:38

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,825

Re: Todo after update to ubuntu 19.04

Mellowbob wrote:

I would have thought that this should all just magically work.

It should.

Try:

systemctl --user enable xfce4-notifyd.service
systemctl --user start xfce4-notifyd.service

Test right away and again after a restart (to see if starts automatically).

If it still doesn't work, then run again:

systemctl --user status xfce4-notifyd.service

...to see if there are any error messages.

Offline

#5 2019-04-28 02:08:48

Mellowbob
Member
Registered: 2011-10-16
Posts: 164

Re: Todo after update to ubuntu 19.04

Before going down this rabbit hole to far ... seems there is a problem right off the top:

bob$ systemctl --user enable xfce4-notifyd.service
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.

Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

Does this show something missing? I just checked and xfce4-notifyd is installed (well, of course it is otherwise none of this would be working, would it?).

Offline

#6 2019-04-28 16:07:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,825

Re: Todo after update to ubuntu 19.04

Sorry for the delay. I've been looking into this and have come to the conclusion that I do not understand systemd as much as I should.

I have a xubuntu 18.10 to 19.04 upgrade and xfce4-notifyd starts automatically when I log in (though I do get the same error message as you if I try to manually enable the service - meaning it should be handled automatically by systemd). Same happens on my Arch machine.

Are there any messages in your journal?

journalctl --user -b 0 -u xfce4-notifyd

...or specifically to notifications:

journalctl -b 0 | grep notification

Here are some links that I've come across that are of interest:
- conflicting notification service
- another conflicting notification service
- bluetooth service interfering
- missing "org.freedesktop.Notification.service" file

Can you look at each one to see if they are the culprit?

Offline

#7 2019-04-28 16:50:29

Mellowbob
Member
Registered: 2011-10-16
Posts: 164

Re: Todo after update to ubuntu 19.04

This is from a clean reboot

ps aux | grep xfce4-notify
bob       2348  0.0  0.3 368528 25232 ?        Sl   09:41   0:00 /usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd
bob       3136  0.0  0.0   8412  2424 pts/1    S+   09:44   0:00 grep --color=auto xfce4-notify

This was started by my startup session.

bob$ journalctl --user -b 0 -u xfce4-notifyd
-- Logs begin at Thu 2018-05-24 21:00:47 MST, end at Sun 2019-04-28 09:42:09 MST. --
-- No entries --

bob$ journalctl -b 0 | grep notification

--- nothing

I will wade though the links to see if anything lights up ... but it is working now ...

Offline

Board footer

Powered by FluxBB