Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-05-16 22:12:05

whereisnomad
Member
Registered: 2019-05-12
Posts: 5

Prevent Keyboard/Trackpad from Waking Screen

I'm trying to keep input from the trackpad or keyboard from "waking" the screen BACKLIGHT when I turn it off via the Fn+F6 shortcut.
I need this function without actually disabling the keyboard/trackpad as i'm need to allow input and actual computer function with the backlight off. To ultimately, I want to be able to use the computer without the screen backlight on.

To be clear, I don't want to turn the SCREEN off, just the backlight.

My use-case is that I've installed a Pixel Qi screen that can be activated in an e-paper-like mode. This works perfectly using the Fn+F6 shortcut except moving the trackpad or using the keyboard wakes it back up. With the backlight off, the lcd image is actually still visible, and so I need the computer "on" rather than in sleep mode.

I tried the "cat /proc/acpi/wakeup" disabling (described here: http://shallowsky.com/blog/linux/kernel … keup.html) but it actually had no impact (ASIDE: ANYONE KNOW WHY THIS WOULD HAVE NO EFFECT?)

I'm running latest version of Linux Mint, XFCE, 64 bit on an Acer Aspire One.

I've posted this question elsewhere with the approach of trying to disable the backlight itself, but wondering if attacking from the I/O side might be more effective.

Thanks for any/all assistance!

Offline

#2 2019-05-17 01:14:14

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,445

Re: Prevent Keyboard/Trackpad from Waking Screen

That article is 10 years old and it applies to sleep wakeups, which isn't exactly what you are trying to do here.

What is Fn+F6 on your keyboard?
Try the running the following command in a terminal window:

xev | awk -F'[ )]+' '/^KeyPress/ { a[NR+2] } NR in a { printf "%-3s %s\n", $5, $8 }'

...and press Fn+F6. Does anything display in the terminal window? If not, then Xorg doesn't recognize the keystroke and it must be handled at a driver or maybe even bios level.

If its handled at the the driver or bios level, you might be able to get this to work using xrandr. You can turn devices on or off using the --off parameter (and creating a keyboard shortcut toggle to do so). With the Qi screen plugged in, what does the following command return:

xrandr --listactivemonitors

Offline

#3 2019-05-17 18:29:37

whereisnomad
Member
Registered: 2019-05-12
Posts: 5

Re: Prevent Keyboard/Trackpad from Waking Screen

ToZ wrote:

That article is 10 years old and it applies to sleep wakeups, which isn't exactly what you are trying to do here.

What is Fn+F6 on your keyboard?
Try the running the following command in a terminal window:

xev | awk -F'[ )]+' '/^KeyPress/ { a[NR+2] } NR in a { printf "%-3s %s\n", $5, $8 }'

...and press Fn+F6. Does anything display in the terminal window? If not, then Xorg doesn't recognize the keystroke and it must be handled at a driver or maybe even bios level.

If its handled at the the driver or bios level, you might be able to get this to work using xrandr. You can turn devices on or off using the --off parameter (and creating a keyboard shortcut toggle to do so). With the Qi screen plugged in, what does the following command return:

xrandr --listactivemonitors

Thanks for the reply!
Per your instructions, the Fn+F6 isn't recognized as a keystroke, so it much be at driver or bios level.
Aside, the Qi screen is the only screen being used; it was a replacement installed in the laptop itself, not an external.

The strange thing is that through every terminal method I've tried, the lowest backlight brightness setting is just "dim," not off so if i could just bring the backlight (not the brightness) down, it would work. I was able to bring the brightess completely off via terminal, but i still had the "black glow" of the backlight.

Hmm...

Offline

#4 2019-05-17 22:58:32

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,445

Re: Prevent Keyboard/Trackpad from Waking Screen

What does "xrandr --MONITOR --off" do? (Where MONITOR is one of the ones listed in "xrandr --listactivemonitors".

Offline

#5 2019-05-17 23:35:44

whereisnomad
Member
Registered: 2019-05-12
Posts: 5

Re: Prevent Keyboard/Trackpad from Waking Screen

It seems to turn the LCD image as well as backlight off, rendering the screen completely blank. With the Pixel Qi screen, however, when I evoke Fn+F6 it only turns the backlight off and because of the "transflective" nature of the screen, it's like looking at e-paper screen. The lcd image is still visible.

Basically need the same command but just for and isolating the backlight.

Thanks for leaning in!

Last edited by whereisnomad (2019-05-17 23:36:22)

Offline

Board footer

Powered by FluxBB