Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-08-07 10:03:24

jllprod
Member
Registered: 2019-08-06
Posts: 3

mp3 issue with Xfburn

Hello everyone,
I'm currently encountering an issue with Xfburn :
I tried to create an audio CD out of mp3 files victor.
I've selected the mp3 files and added them to y composition.
Then, I've ran the burning in automatic writing mode (where there are two options : SAO and TAO).
The burning went well, but on my player, I get distorted sound.
I've tried again, but before, I've converted the mp3 to wav files, using Audacity, and this time, the CD was audible.
On the main user interface in Xfburn, there is a button "Gstreamer transcoder", that pops up a message about the "good", "bad" and "ugly" libraries.
Both are installed, but it made no change, if I use directly the mp3 files, the audio CD is inaudible.
Is it a known issue ? Did I installed something wrong ?

Offline

#2 2019-08-07 10:45:00

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,991

Re: mp3 issue with Xfburn

Which distro are you using?

Which version of xfburn are you running?

xfburn -V

Run xfburn in a terminal window and post back any output that appears in the terminal window.

You can also run gstreamer in debug mode. This will generate alot of information, but might yield something useful:

GST_DEBUG=4 xfburn

(Valid GST_DEBUG settings are listed here)

Offline

#3 2019-08-07 21:26:53

jllprod
Member
Registered: 2019-08-06
Posts: 3

Re: mp3 issue with Xfburn

Hi and sorry for the delayed answer !
So ...
xfburn version 0.5.5 for Xfce 4.12
    built with GTK+-2.24.32, linked with GTK+-2.24.32.
    GStreamer support (built with 1.14.4, linked against 1.15.90)
About the debug mode ... I get plenty of info, but I didn't find something explicit...
Here is what happens when I add a mp3 file :

** Message: 23:25:21.216: Using UDEV
** Message: 23:25:24.981: Using Transcodeur GStreamer transcoder.
0:00:13.929231768  8572 0x5578b336f990 WARN                 basesrc gstbasesrc.c:3600:gst_base_src_start_complete:<source> pad not activated yet
0:00:13.929495049  8572 0x5578b336f990 WARN                 basesrc gstbasesrc.c:3600:gst_base_src_start_complete:<source> pad not activated yet

(in warning mode)

I forgot !
Xubuntu 19.04.
Thank you for your help !!

Last edited by jllprod (2019-08-07 21:27:35)

Offline

#4 2019-08-07 21:55:08

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,991

Re: mp3 issue with Xfburn

Does the same happen if you use other burning software like brasero or k3b?

Offline

#5 2019-08-22 20:00:49

mss
Member
Registered: 2019-08-22
Posts: 1

Re: mp3 issue with Xfburn

I'm seeing the exactly the same distorted sound issue on Manjaro Linux with this version of xfburn:

$ xfburn -V
xfburn version 0.5.5 for Xfce 4.14
    built with GTK+-2.24.31, linked with GTK+-2.24.32.
    GStreamer support (built with 1.12.4, linked against 1.16.0)

I then installed Brasero (3.12.2+62+gbd1a4d5b-1) and burned the same mp3 files on a CD. That CD works as expected, no distorted sound.

Offline

#6 2019-08-22 22:37:59

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,991

Re: mp3 issue with Xfburn

Perhaps it is best then to create a bug report against xfburn.

Offline

Board footer

Powered by FluxBB