Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-08-20 14:23:38

Aravisian
Member
Registered: 2019-08-17
Posts: 132

(Solved) Panel - uncheck show button labels.

On my panel, text titles appear as pop up windows by the icons when you get the mouse near them or click them. They also love to appear but not disappear. Rather than going away, they trail around my desktop sticking in funny places or just hovering over the icon on the panel. They seem to chase the mouse cursor.
I gather that in the old days, you would open Panel Preferences, go to the Items Tab, then Windows and uncheck "show button labels."
There is no windows section under the Items tab on my Panel Preferences. There is no "show button labels" option to check or uncheck. Something was updated (i.e. Changed, functionality removed, then called an update)? Or is it a DockbarX interference thing?
I honestly would prefer that there be no text pop up telling me the icons title as I already know them all_ I put them there, chose their icons and for several, I made the icons. It's superfluous... But I wouldn't mind them if they behaved.
How can I solve this issue? Is there a way of (preferred) destroying them, smashing the eggs in their nests and ensuring their extinction? Or... is there a way of keeping them from wandering all over my desktop and pinning themselves down in the middle of a conky?

EDIT: FiGures I would find something finally- after I ask. But it did not solve the issue.
I found an Old Revision of Panel,
https://docs.xfce.org/xfce/xfce4-panel/ … 1564034183
that showed where to find Windows Buttons. You must add it to the panel. I did that, Unchecked the option, restarted the panel, but the button labels remain.

Last edited by Aravisian (2019-08-20 14:55:06)

Offline

#2 2019-08-20 14:47:14

alcornoqui
Member
Registered: 2014-07-28
Posts: 473

Re: (Solved) Panel - uncheck show button labels.

I think what you call labels are actually called tooltips. This thread has instructions to disable them.

That said, the thread is a bit old and it seems like similar instructions for GTK3 reference other file, considering the GTK2 > GTK3 migration.

Offline

#3 2019-08-20 14:57:49

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Panel - uncheck show button labels.

Fast...

Think, maybe, you could get hired on at HP? Or something? Such places what could use such quickness.

Marked as solved- read the other thread. So, I was searching for the right answer with the wrong search terms.
Your suggestion worked perfectly. I do not use Chromium, so I don't know (Or care) if it has side effects there. I'll be wary of any other side effects.
And... Thanks.

Offline

#4 2019-08-20 14:59:31

ctac
Member
Registered: 2017-05-08
Posts: 40

Re: (Solved) Panel - uncheck show button labels.

Not sure it's what you look for but try :
Settings - Desktop - icons and uncheck Show icon tooltips

Offline

#5 2019-08-20 15:05:33

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Panel - uncheck show button labels.

ctac wrote:

Not sure it's what you look for but try :
Settings - Desktop - icons and uncheck Show icon tooltips

Ctac, I never even noticed that setting and I crawled all over the settings manager thoroughly many times. If ever anyone feels embarrassed that they couldn't solve a problem only to find it was a simple solution in GUI settings, remember that.
However, this one didn't work.
I went ahead and tried it out: I removed alcornoqui's suggestion of adding "gtk-enable-tooltips = 0" to the ~/.gtkrc-2.0 file and saved the file, then went to Settings, Desktop, Icons and unchecked the one about tooltips.
That really seems like it should work. Oddly, it didn't. The tooltips were back. I tried restarting panel, then log out, etc.
I replaced the "gtk-enable-tooltips = 0" to the ~/.gtkrc-2.0 file and now they are gone again.
In the other thread, it mentioned that was depreciated and ignored- so that setting must be what they are referring to.
But thanks for teaching me something new.:D

Offline

#6 2019-08-21 15:07:07

ctac
Member
Registered: 2017-05-08
Posts: 40

Re: (Solved) Panel - uncheck show button labels.

Strange,
If you speek about tooltip like that :
tykAr9QM_o.jpg
It' s OK here on debian testing and OpenBSD 6.5
I can't give you more help.

Offline

#7 2019-08-21 23:35:11

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: (Solved) Panel - uncheck show button labels.

ctac wrote:

Strange,
If you speek about tooltip like that :
https://images2.imgbox.com/07/d5/tykAr9QM_o.jpg
It' s OK here on debian testing and OpenBSD 6.5
I can't give you more help.

ctac, you are right- I have never seen that large tooltip as in your screenshot.
The ones that were misbehaving for me were on the panel only and they showed the title of the item docked on the panel. In misbehaving, they began appearing anywhere on my dekstop and staying there.
Fortunately, the solution offered by alcornoqui worked to resolve that.

So, I am not sure if we are talking of the same thing that operates a little differently on our builds or two different things. But now that I am wondering, I will work on finding out:D
Looking at your screenshot, I am confident that I would not want large full details tooltips deciding for me to tell me information, either. Chances are that I already know what it is telling me and if I don't know, I will ask it to tell me case by case basis. So you have helped a great deal by teaching me more of the system I am using. wink Now I know what to look for if I make a build and see tooltips like you display instead of having another problem to solve later on.
Never be shy with input.

Offline

Board footer

Powered by FluxBB