Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-09-17 19:00:06

theOtherCharles
Member
Registered: 2018-01-05
Posts: 28

Menu Icon on XFCE 4.12.5 (Debian 10 Buster)

I maintain a small gtk2 program for use with gpsd and gps receivers, called gnome-gps. https://github.com/charlescurley/gnome-gps It has an icon for use in menus. That icon has worked well with past versions of XFCE4, including on Debian 7, 8, and 9 (stretch). Now, on XFCE 4.12, the menu entry shows up in the right place, but no icon.

What should I change to make this work? More generally, is there a guide somewhere to making menu icons for XFCE4 and other compatible desktops?

Offline

#2 2019-09-17 23:52:45

Aravisian
Member
Registered: 2019-08-17
Posts: 132

Re: Menu Icon on XFCE 4.12.5 (Debian 10 Buster)

theOtherCharles wrote:

I maintain a small gtk2 program for use with gpsd and gps receivers, called gnome-gps. https://github.com/charlescurley/gnome-gps It has an icon for use in menus. That icon has worked well with past versions of XFCE4, including on Debian 7, 8, and 9 (stretch). Now, on XFCE 4.12, the menu entry shows up in the right place, but no icon.

What should I change to make this work? More generally, is there a guide somewhere to making menu icons for XFCE4 and other compatible desktops?

Can you find any help here:
https://developer.gnome.org/gdk-pixbuf/ … emory.html
"gdk_pixbuf_new_from_inline has been deprecated since version 2.32 and should not be used in newly-written code. Create a GdkPixbuf from a flat representation that is suitable for storing as inline data in a program."

Offline

#3 2019-09-18 18:21:18

theOtherCharles
Member
Registered: 2018-01-05
Posts: 28

Re: Menu Icon on XFCE 4.12.5 (Debian 10 Buster)

Aravisian wrote:

Thanks, but not what I was looking for. I have the icon in the window decorations. I'm missing the icon that accompanies the menu entry. That is a separate file, as specified in the .desktop file.

Last edited by theOtherCharles (2019-09-18 18:30:59)

Offline

#4 2019-09-18 18:46:15

MrEen
Member
Registered: 2019-04-19
Posts: 77

Re: Menu Icon on XFCE 4.12.5 (Debian 10 Buster)

Just a shot in the dark. Could size be the issue? That icon is 114x46.

Offline

#5 2019-09-18 23:31:15

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,877

Re: Menu Icon on XFCE 4.12.5 (Debian 10 Buster)

I just installed this app on my buster vm and the icon shows up just fine. A little strange that it shows up in the Graphics category (I would of thought System or Accessories), but it does display. I've tested both the applications menu and the whiskermenu. It also shows up in the desktop menu. The applicationsmenu squares up the icon, the other two show it with it's correct dimensions.

Is your system fully updated? Can you try with a secondary account on your computer to rule out any account-based issues?

Offline

#6 2019-09-19 18:41:43

theOtherCharles
Member
Registered: 2018-01-05
Posts: 28

Re: Menu Icon on XFCE 4.12.5 (Debian 10 Buster)

ToZ wrote:

I just installed this app on my buster vm and the icon shows up just fine. A little strange that it shows up in the Graphics category (I would of thought System or Accessories), but it does display.

Interesting. On my systems, it shows up under Accessories, and nowhere else. But according to my git log, it did at one time show up under Graphics. The change is as follows:

charles@hawk:~/versioned/gnome-gps$ git diff b4b76767cb307be05193c281975ce33c6dd868c5 028ffaf1502dc86e9688f4eacfba71a06f0999c7
diff --git a/src/gnome-gps.desktop b/src/gnome-gps.desktop
index 294bb0b..f5c6bf9 100644
--- a/src/gnome-gps.desktop
+++ b/src/gnome-gps.desktop
@@ -6,4 +6,4 @@ Exec=/usr/local/bin/gnome-gps
 Icon=/usr/share/gnome-gps/gnome-gps.logo.png
 Terminal=false
 Type=Application
-Categories=Utility;Graphics;
+Categories=Graphics;
charles@hawk:~/versioned/gnome-gps$
ToZ wrote:

I've tested both the applications menu and the whiskermenu. It also shows up in the desktop menu. The applicationsmenu squares up the icon, the other two show it with it's correct dimensions.

I have no idea what a "whisker menu" is, so I can't comment on that.

I take it the application menu is the one you get when you right click on the desktop, or go to the "Applications menu" in one or more of the XFCE panels.

ToZ wrote:

Is your system fully updated? Can you try with a secondary account on your computer to rule out any account-based issues?

Updated daily.

On a fresh installation of buster (July 19), I created a new account with "adduser". The gnome-gps menu entry shows up under accessories, with no icon.

Offline

Board footer

Powered by FluxBB