Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-10-16 12:39:28

albertfanta11
Member
Registered: 2019-10-16
Posts: 6

How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

As title explains, for the most part.

I recently installed Ubuntu on my laptop and it's been pretty clean so far; only problem being that the trackpad is disabled while typing. This makes even the lightest desktop games unplayable which is really unfortunate. With Gnome's settings, this feature is easily toggle-able (and I did).

Most of the threads relating to this topic were about disabling the trackpad while typing so it's quite odd mine is disabled to begin with.

Is there a way to maybe transfer pointer settings from Gnome to XFCE? Or to allow typing in XFCE from within it?

Thanks for reading and any help is appreciated.

Offline

#2 2019-10-17 00:02:05

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

Hello and welcome.

If you go to Settings Manager > Mouse and Touchpad and on the Device tab, do you have an option for your touchpad? If so, select the touchpad and on the Touchpad tab there is an option to toggle on or off the disabling of the touchpad while you type.

Offline

#3 2019-10-19 16:07:10

albertfanta11
Member
Registered: 2019-10-16
Posts: 6

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

Unfortunately, there is no available option in XFCE settings to disable trackpad while typing.

Offline

#4 2019-10-19 20:54:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

VUks3RO.png

Which distro are you using? Do you have the synaptics driver installed (or are you using libinput)?

Offline

#5 2019-10-19 23:08:49

albertfanta11
Member
Registered: 2019-10-16
Posts: 6

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

iHNxjLu.png

I am using Ubuntu.

How do I check whether i am using libinput or synaptics?

Also, I tried running sudo apt install xserver-xorg-input.synaptics in terminal - read somewhere that this can fix it - but unfortunately this didn't work either. Or did it work? I can't really understand this error message:

AAGhv0t.png

"you have held broken packages"

Last edited by albertfanta11 (2019-10-19 23:29:58)

Offline

#6 2019-10-19 23:57:48

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

albertfanta11 wrote:

How do I check whether i am using libinput or synaptics?

Your Xorg.0.log file will tell you.

Also, I tried running sudo apt install xserver-xorg-input.synaptics in terminal - read somewhere that this can fix it - but unfortunately this didn't work either. Or did it work? I can't really understand this error message:

Sorry, but I don't use Ubuntu enough to advise how to fix this.

Edit: The accepted answer in this thread shows a manual method to do it. Unfortunately, Xfce doesn't currently display libinput settings. See this bug report.

Last edited by ToZ (2019-10-20 00:10:24)

Offline

#7 2019-10-20 00:09:36

albertfanta11
Member
Registered: 2019-10-16
Posts: 6

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

This is strange. I have no Xorg 0 log file in /var/log/. I have one on my PC but not on my laptop (with the trackpad issue). Both use Ubuntu with XFCE desktop.

Also, no worries. Any help is welcome :DD

Offline

#8 2019-10-20 00:11:20

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

I just posted an edit to my previous post. Have a look at those links.

Your Xorg log file might be in ~/.local/share/xorg.

Edit: another bug report.

Last edited by ToZ (2019-10-20 00:13:04)

Offline

#9 2019-10-20 00:14:22

albertfanta11
Member
Registered: 2019-10-16
Posts: 6

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

Okay: I believe the touchpad is using libinput drivers, not synaptik.

Offline

#10 2019-10-20 00:15:15

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

One way to deal with this is to remove the libinput driver and install the synaptics one - and you'll get the previous configuration settings back.

Or manually adjust the libinput settings.

Offline

#11 2019-10-20 00:36:56

albertfanta11
Member
Registered: 2019-10-16
Posts: 6

Re: How to keep trackpad enabled in XFCE4 & Ubuntu while typing?

Thank you so much. I read the fix, followed the steps, and now cursor moves while typing!

(the fix that you linked)

Last edited by albertfanta11 (2019-10-20 00:37:25)

Offline

Board footer

Powered by FluxBB