Xfce Forum

Sub domains

You are not logged in.

#1 2011-06-11 04:47:37

Registered: 2011-05-06
Posts: 2

xfwm4 doesn't start

I am running Mageia Linux with Xfce version 4.8.

If I save a session with any applications included, xfwm4 doesn't start.  I can start it in a terminal, but the run command still doesn't respond to Alt+F2.  Instead, I see the code for the keystroke in the terminal.  As a test, I logged in as another user with a blank session, then added my applications (gkrellm, gdeskcal and a terminal.) It started behaving the same way.  I can set the config not to save the session, but it gets saved anyway.

I can get around this by deleting the session files in ~/.cache/sessions, but that fix doesn't last beyond the current session.  In practice, it means that on each bootup, I have to log in with another WM, delete the session files, log out then log in to Xfce.  From looking around, this seems to be a recurring problem, but one deletion of the session files seems to fix it.  In my case, it doesn't.

Any suggestions?



#2 2011-06-14 08:28:11

Registered: 2011-02-04
Posts: 15

Re: xfwm4 doesn't start

Did you try adding xfwm4 to Settings Manager->Session and Startup->Application Autostart?


#3 2011-06-14 19:43:57

Registered: 2011-06-14
Posts: 1

Re: xfwm4 doesn't start

Thank you for your post.
I also use mageia1 with xfce and had the same problem : no more control panel, no more desktop, no more menu, no more windows.
I would never have thought that this problem should come from ".cache/sessions/" files. So I did the "rm .cache/sessions/*" and everything became normal.
I have disabled session automatic save and xfce works fine.

So, for your problem, why do you want to save your session ?


Board footer

Powered by FluxBB