Xfce Forum

Sub domains

You are not logged in.

#1 2013-02-24 22:30:42

Registered: 2013-02-24
Posts: 2

[Solved] libxfce4panel-1.0.so.4 no such file - Xfce 4.10 from source

I'm running xubuntu 12.04, and just compiled and installed xfce 4.10 from the sources followwing the building guide

I have followed all the steps and everything has gone well (or so I believed)
However, after restarting and logging in, there was no panel, and upon trying to start the panel manually from console, this is what happens:

~$ xfce4-panel 
xfce4-panel: error while loading shared libraries: libxfce4panel-1.0.so.4: cannot open shared object file: No such file or directory

The $PREFIX variable was set up as "/usr/local" and if I try to "find" libxfce4panel-1.0.so i get this:

# find / -iname '*libxfce4panel-1.0.so*'

The rest of the desktop seems to be working fine and running xfce 4.10 as i noticed some differences in several places.

Does anyone know how to solve this, and if there might be other problems related to libraries that can not be found (but are now getting off unnoticed)?

Thanks in advance!

Also, in xfce4-settings-manager there are no settings to manage, I can see four categories: Personal, Hardware, System, Others. But all of them are empty. And if i try an click on the 'Help' button at the bottom-left corner, the window closes saying to the terminal: "xfce4-settings-manager: symbol lookup error: xfce4-settings-manager: undefined symbol: xfce_dialog_show_help"
I don't know if this may be somehow related or not at all.

Last edited by chikitulfo (2013-02-24 23:10:12)


#2 2013-02-25 00:00:40

From: Canada
Registered: 2011-06-02
Posts: 4,371

Re: [Solved] libxfce4panel-1.0.so.4 no such file - Xfce 4.10 from source

Try adding /usr/local/lib to your library path.

1. Edit/etc/ld.so.conf.d/x86_64-linux-gnu.conf (looks like your running a 64-bit install - the file is different for a 32-bit install)
2. Add '/usr/local/lib' to the beginning of the file (so that directory is processed first)
3. Run 'sudo ldconfig'

This way the libraries in /usr/local/lib (that are required by 4.10) will be accessed before the older (4.8) libraries.

You might also want to have a look at this Xfce 4.10 PPA: https://launchpad.net/~xubuntu-dev/+archive/xfce-4.10 - it provides the *buntus with the Xfce 4.10 packages in an easier-to-manage solution.

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks


#3 2013-02-25 08:15:53

Registered: 2013-02-24
Posts: 2

Re: [Solved] libxfce4panel-1.0.so.4 no such file - Xfce 4.10 from source

Yes, my system was x86_64, I forgot to mention it.

Nice!, adding /usr/local/lib to the library path solved both problems!

Now I have a couple other questions: ¿Should I uninstall previous 4.8 packages, or would that cause some conflict?
In case I wanted to uninstall the manually installed 4.10, how would I need to do it?

I saw already that ppa, but i wanted to try doing it by myself big_smile

Thank you very much for your help!

Last edited by chikitulfo (2013-02-25 08:46:37)


Board footer

Powered by FluxBB