Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-03-19 17:38:33

graysky
Member
Registered: 2011-08-14
Posts: 26

Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

Hi gang.  If I am running the 4.4.x series or 4.5.x series of kernels, xfce4 does not allow my monitor to wake from standby or suspend mode.  The only way to wake it is to drop to a TTY and restart lxdm.  Interestingly, if I downgrade my kernel to 4.3.6, everything works as it should.  This bug is only under xfce4 for me.  I have tested both gnome and cinnamon under the 4.4.x and 4.5.x series of kernels and the monitor behaves as expected. 

I don't want stop using xfce4 nor do I want to continue to use an EOL kernel. 

I did open a bug report against Xfce4-power-manager but it hasn't seen much traffic beyond another user experiencing the same problem.  Any suggestions to figure this out are welcomed.  Thanks!

Offline

#2 2016-03-19 18:11:13

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

Hi graysky. I've seen the same bug reports and don't know if I have much to offer.

What might be interesting is comment #8 from https://bugzilla.xfce.org/show_bug.cgi?id=11627. Can you confirm the same is happening in your case where the device isn't being properly enabled after resume by X?

I know you're active on the Arch boards so I'm assuming this is about your Arch system. In which case, are you fully updated and using the new xrandr 1.5 - it fixed some other non-related issues on my setup.

And finally, does executing:

xrandr --auto

...after you resume bring everything back?

Also interesting might be to run xfce4-power-manager in debug mode to see what is happening during the suspend/resume cycle. To do so:

xfce4-power-manager -q
xfce4-power-manager --no-daemon --debug > ~/power.log 2>&1

...then sleep/resume. See if the log file has anything interesting.

Offline

#3 2016-03-19 21:14:24

graysky
Member
Registered: 2011-08-14
Posts: 26

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

ToZ wrote:

What might be interesting is comment #8 from https://bugzilla.xfce.org/show_bug.cgi?id=11627. Can you confirm the same is happening in your case where the device isn't being properly enabled after resume by X?

Regarding 11627 -- My solution to that was switching from a DVI cable to an HDMI cable.  I'm not sure what you mean about

ToZ wrote:

I know you're active on the Arch boards so I'm assuming this is about your Arch system. In which case, are you fully updated and using the new xrandr 1.5 - it fixed some other non-related issues on my setup.

Yes, fully updated and even tried enabling [testing] to pull down the latest Xorg + intel driver.  No difference.

ToZ wrote:

And finally, does executing:

xrandr --auto

...after you resume bring everything back?

Well, when I drop down to a TTY and run that command, it complains that it has no active screen.  I tried appending a :0 to the end of it but same.

ToZ wrote:

Also interesting might be to run xfce4-power-manager in debug mode to see what is happening during the suspend/resume cycle. To do so:

xfce4-power-manager -q
xfce4-power-manager --no-daemon --debug > ~/power.log 2>&1

...then sleep/resume. See if the log file has anything interesting.

Good idea.  I did it but saw nothing written to the log file upon resuming (waking the monitor) which as expected, just came on for a sec and then off again.  All the output from the below was written before powersavings kicked in; nothing was written after I tried waking.

% xfce4-power-manager --no-daemon --debug > ~/power2.log 2>&1
(xfce4-power-manager:983): xfce4-power-manager-WARNING **: could not map keysym 1008ffa8 to keycode

TRACE[xfpm-main.c:192] xfpm_start(): Starting the power manager
TRACE[xfpm-xfconf.c:631] xfpm_xfconf_init(): lock screen TRUE
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for critical-power-level
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for show-brightness-popup
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for critical-power-action
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for hibernate-button-action
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for sleep-button-action
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for lid-action-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for lid-action-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-level-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-slider-min-level
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for dpms-on-battery-sleep
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for dpms-on-battery-off
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for dpms-sleep-mode
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-sleep-mode-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-sleep-mode-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for logind-handle-power-key
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for logind-handle-suspend-key
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for logind-handle-hibernate-key
TRACE[xfpm-polkit.c:314] xfpm_polkit_init_data(): Using unix session polkit subject
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.power-off is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.reboot is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.suspend is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.hibernate is authorized=TRUE
TRACE[xfpm-power.c:214] xfpm_power_check_polkit_auth(): using logind suspend backend
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.suspend is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.hibernate is authorized=TRUE
TRACE[xfpm-power.c:1449] xfpm_update_blank_time(): Timeout: 10
TRACE[xfpm-power.c:1449] xfpm_update_blank_time(): Timeout: 10
TRACE[xfpm-power.c:1449] xfpm_update_blank_time(): Timeout: 0
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 124 : ((XfpmButtonKey) BUTTON_POWER_OFF)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 213 : ((XfpmButtonKey) BUTTON_HIBERNATE)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 150 : ((XfpmButtonKey) BUTTON_SLEEP)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 233 : ((XfpmButtonKey) BUTTON_MON_BRIGHTNESS_UP)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 232 : ((XfpmButtonKey) BUTTON_MON_BRIGHTNESS_DOWN)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 244 : ((XfpmButtonKey) BUTTON_BATTERY)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 238 : ((XfpmButtonKey) BUTTON_KBD_BRIGHTNESS_UP)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 237 : ((Xfp
** (xfce4-power-manager:983): WARNING **: No outputs have backlight property
xfce4-power-manager-Message: Set kernel brightness switch to 1

(xfce4-power-manager:983): xfce4-power-manager-WARNING **: Failed to get keyboard max brightness level : No such interface 'org.freedesktop.UPower.KbdBacklight' on object at path /org/freedesktop/UPower/KbdBacklight

It almost behaves as if once it goes to sleep, it tries to look for an active video signal but none is found, so the monitor happily goes back to sleep hmm  What is clear is that it is unique to xfce4 with the latest kernels.

Offline

#4 2016-03-19 22:09:26

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

graysky wrote:
ToZ wrote:

What might be interesting is comment #8 from https://bugzilla.xfce.org/show_bug.cgi?id=11627. Can you confirm the same is happening in your case where the device isn't being properly enabled after resume by X?

Regarding 11627 -- My solution to that was switching from a DVI cable to an HDMI cable.  I'm not sure what you mean about

The commenter noted that when he returned from suspend, the active status of the secondary display was not set. I was wondering if the same exists for you. He has a command there that you can use to grab the xrandr outputs:

LOG=/tmp/xrandr.log; while ( true ); do date>>$LOG; xrandr >> $LOG; sleep 20;done;

Its really interesting that it works on 4.3 but not on the 4.4 or 4.5 kernels. Since xfce4-power-manager hasn't changed, then some change in the kernel has caused this. Given that it works on Gnome but not in Xfce, it might be helpful to figure out what changed in the kernel and how Gnome deals with it differently than Xfce.

ToZ wrote:

And finally, does executing:

xrandr --auto

...after you resume bring everything back?

Well, when I drop down to a TTY and run that command, it complains that it has no active screen.  I tried appending a :0 to the end of it but same.

xrandr has to be run from within X. Try mapping it to a keyboard shortcut, and after suspend press the keyboard shortcut. If you have a screen locker enabled on suspend, either temporarily disable it or blindly authenticate.

ToZ wrote:

Also interesting might be to run xfce4-power-manager in debug mode to see what is happening during the suspend/resume cycle. To do so:

xfce4-power-manager -q
xfce4-power-manager --no-daemon --debug > ~/power.log 2>&1

...then sleep/resume. See if the log file has anything interesting.

Good idea.  I did it but saw nothing written to the log file upon resuming (waking the monitor) which as expected, just came on for a sec and then off again.  All the output from the below was written before powersavings kicked in; nothing was written after I tried waking.

"Nothing was written when I tried waking"
This is odd - I continue to get debug feedback on wake.
Can you confirm that xfce4-power-manager is still running?

Can you also disable lxdm and try when you boot straight into X/Xfce?

One final thing, Arch still runs xfce4-power-manager 1.4.4. It is currently at 1.6.0. The AUR has a 1.5.2 version you can try, or you can use ABS to build 1.6.0 (though there weren't any changes in 1.6.0 that would affect this issue).

Offline

#5 2016-03-20 11:27:54

graysky
Member
Registered: 2011-08-14
Posts: 26

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

OK!  I have some answers and more questions smile

I ran command that logs xrandr to a file as you suggested; output is here.  The monitor was put to suspend at 7:16:20 AM.  I woke it up with the keyboard shortcut you recommended (well, I had to hit it twice to get the effect).  I don't see anything in the log that's different when the monitor is sleeping... do you?  Note that /usr/bin/xfce4-display-settings was running upon the monitor waking up (not a function of me running the `xrandr --auto` keyboard shortcut)!

I confirmed that xfce4-power-manager was running and continued to run (ps aux | grep xfce4-power).  Below is the log file

(xfce4-power-manager:1372): xfce4-power-manager-WARNING **: could not map keysym 1008ffa8 to keycode

TRACE[xfpm-main.c:192] xfpm_start(): Starting the power manager
TRACE[xfpm-xfconf.c:631] xfpm_xfconf_init(): lock screen TRUE
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for critical-power-level
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for show-brightness-popup
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for critical-power-action
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for hibernate-button-action
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for sleep-button-action
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for lid-action-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for lid-action-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-level-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-slider-min-level
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for dpms-on-battery-sleep
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for dpms-on-battery-off
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for dpms-sleep-mode
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-sleep-mode-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for inactivity-sleep-mode-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-on-ac
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for brightness-on-battery
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for logind-handle-power-key
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for logind-handle-suspend-key
TRACE[xfpm-xfconf.c:164] xfpm_xfconf_load(): Using default configuration for logind-handle-hibernate-key
TRACE[xfpm-polkit.c:314] xfpm_polkit_init_data(): Using unix session polkit subject
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.power-off is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.reboot is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.suspend is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.hibernate is authorized=TRUE
TRACE[xfpm-power.c:214] xfpm_power_check_polkit_auth(): using logind suspend backend
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.suspend is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.hibernate is authorized=TRUE
TRACE[xfpm-power.c:1449] xfpm_update_blank_time(): Timeout: 10
TRACE[xfpm-power.c:1449] xfpm_update_blank_time(): Timeout: 10
TRACE[xfpm-power.c:1449] xfpm_update_blank_time(): Timeout: 0
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 124 : ((XfpmButtonKey) BUTTON_POWER_OFF)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 213 : ((XfpmButtonKey) BUTTON_HIBERNATE)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 150 : ((XfpmButtonKey) BUTTON_SLEEP)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 233 : ((XfpmButtonKey) BUTTON_MON_BRIGHTNESS_UP)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 232 : ((XfpmButtonKey) BUTTON_MON_BRIGHTNESS_DOWN)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 244 : ((XfpmButtonKey) BUTTON_BATTERY)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 238 : ((XfpmButtonKey) BUTTON_KBD_BRIGHTNESS_UP)
TRACE[xfpm-button.c:183] xfpm_button_xevent_key(): Grabbed key 237 : ((Xfp
** (xfce4-power-manager:1372): WARNING **: No outputs have backlight property
xfce4-power-manager-Message: Set kernel brightness switch to 1

(xfce4-power-manager:1372): xfce4-power-manager-WARNING **: Failed to get keyboard max brightness level : No such interface 'org.freedesktop.UPower.KbdBacklight' on object at path /org/freedesktop/UPower/KbdBacklight
xfce4-power-manager-Message: Restored brightness switch value to: 1
mButtonKey) BUTTON_KBD_BRIGHTNESS_DOWN)
TRACE[xfpm-manager.c:643] xfpm_manager_inhibit_sleep_systemd(): Inhibiting systemd sleep: handle-power-key:handle-suspend-key:handle-hibernate-key:handle-lid-switch
TRACE[xfpm-backlight.c:259] xfpm_backlight_brightness_on_ac_settings_changed(): Alarm on ac timeout changed 9
TRACE[xfpm-backlight.c:280] xfpm_backlight_brightness_on_battery_settings_changed(): Alarm on battery timeout changed 120
TRACE[xfpm-polkit.c:251] xfpm_polkit_free_data(): Destroying Polkit data
TRACE[xfpm-manager.c:490] xfpm_manager_alarm_timeout_cb(): Alarm inactivity timeout id 2
TRACE[xfpm-polkit.c:417] xfpm_polkit_changed_cb(): Auth changed
TRACE[xfpm-power.c:1013] xfpm_power_polkit_auth_changed_cb(): Auth configuration changed
TRACE[xfpm-power.c:214] xfpm_power_check_polkit_auth(): using logind suspend backend
TRACE[xfpm-polkit.c:314] xfpm_polkit_init_data(): Using unix session polkit subject
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.suspend is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.hibernate is authorized=TRUE
TRACE[xfpm-polkit.c:417] xfpm_polkit_changed_cb(): Auth changed
TRACE[xfpm-power.c:1013] xfpm_power_polkit_auth_changed_cb(): Auth configuration changed
TRACE[xfpm-power.c:214] xfpm_power_check_polkit_auth(): using logind suspend backend
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.suspend is authorized=TRUE
TRACE[xfpm-polkit.c:406] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.login1.hibernate is authorized=TRUE
TRACE[xfpm-manager.c:490] xfpm_manager_alarm_timeout_cb(): Alarm inactivity timeout id 2
TRACE[xfpm-polkit.c:251] xfpm_polkit_free_data(): Destroying Polkit data
TRACE[xfpm-main.c:71] xfpm_quit_signal(): sig 2
TRACE[xfpm-manager.c:942] xfpm_manager_stop(): Stopping
TRACE[xfpm-manager.c:265] xfpm_manager_quit(): Exiting

Next, I have the following as my ~/.xinitrc but I cannot boot to a TTY and then issue `xinit` for some reason.

#!/bin/sh
exec cinnamon-session

Here is the output I get:

% xinit
X.Org X Server 1.18.1
Release Date: 2016-02-08
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.2.5-1-ARCH x86_64
Current Operating System: Linux ease 4.4.6-1-ARCH #1 SMP PREEMPT Fri Mar 18 15:50:30 EDT 2016 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=8e32471f-5597-42fb-9f49-6bcb18af39b6 rw quiet scsi_mod.use_blk_mq=1
Build Date: 11 February 2016  09:57:03AM

Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version. 
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/squishy/.local/share/xorg/Xorg.0.log", Time: Sun Mar 20 07:32:18 2016
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Fatal server error:
(EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)
Please consult the The X.Org Foundation support at http://wiki.x.org for help.
(EE) Please also check the log file at "/home/facade/.local/share/xorg/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

And here is /home/facade/.local/share/xorg/Xorg.0.log

Next, I did build xfce4-power-manager from the AUR so I had 1.6.0 but I got the same result.

Finally, totally disabling xfce4-power-manager and letting xscreensaver do the shutdown causes the same result!  As does stopping xfce4-power-manager and using `xset dpms force suspend` ... it certainly seems like something within xfce4 is to blame, but what?

Last edited by graysky (2016-03-20 11:38:26)

Offline

#6 2016-03-20 14:31:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

The xrandr log file shows the exact same thing as the commenter from bug #11627. When you wake up from suspend, the external monitor is not shown as active. Example:
- Before suspend:

HDMI1 connected 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+

- On wake from suspend:

HDMI1 connected (normal left inverted right x axis y axis)
   2560x1440     59.95 +

...notice the missing asterisk - the indicator of current mode. I'm not sure what the cause is, but for some reason either X or Xfce is not resetting the current mode. Since it works in Gnome, perhaps this is the underlying problem somewhere in Xfce. Maybe this is the underlying bug.

If the "xrandr --auto" keyboard shortcut worked to restore the HDMI screen, then you can temporarily add it to as a systemd suspend resume hook (as a workaround until it gets fixed). See "Hooks in /usr/lib/systemd/system-sleep" at https://wiki.archlinux.org/index.php/Power_management. You can use a script like (/usr/lib/systemd/system-sleep/90-wakeup-monitor.sh):

#!/bin/sh
case $1/$2 in
  pre/*)
    ;;
  post/*)
    DISPLAY=:0 xrandr --auto
    ;;
esac

...make sure the script is executable.

------

To get X to work from the console, try the following:
- contents of .xinitrc:

#!/bin/bash

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

startxfce4

...and start X via:

startx -- -keeptty -nolisten tcp

Offline

#7 2016-03-20 17:43:46

graysky
Member
Registered: 2011-08-14
Posts: 26

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

@ToZ - Thank you very much for your kind time investment in my post.  I applied the patch from the bug report you mentioned and found that my monitor does in fact wake up now under 4.4.6 (twice tried, twice awakened).  More testing is called for before I will call it solved.  I will update this thread as I do it.

...is it expected that xfce4-display-settings pops up each time I awake?  I do have the "configure new displays when connected" checked ... I will uncheck it and try again.

EDIT: Unchecking it seems to have kept it from showing.  I will post to the bug report referencing mine.  Thanks again!

Last edited by graysky (2016-03-20 17:45:47)

Offline

#8 2016-03-20 18:55:51

graysky
Member
Registered: 2011-08-14
Posts: 26

Re: Monitor does not wake under xfce4 and kernel 4.4.x or 4.5.x series

It's been 10 cycles of either standby, suspend, or, off and in all 10 cases, the monitor has awakened with the patch.  I opened FS#48647 against xfce4-settings requesting the patch for Arch.  Thanks again for your help!

Offline

Board footer

Powered by FluxBB