Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-05-12 12:52:32

faabrizio
Member
Registered: 2007-02-17
Posts: 15

How to set up alt+mouse wheel behavior

Hello,

Alt + mouse wheel (over a window decoration) used to modify transparency for that window. Now the zoom is activated.

I would like to go back to the old behavior. But mainly I'd like to know how to change what is assigned to the control.

Regards

Last edited by faabrizio (2014-05-13 08:43:33)

Offline

#2 2014-05-12 20:13:46

jesuzphreak
Member
Registered: 2009-12-06
Posts: 3

Re: How to set up alt+mouse wheel behavior

You can use xbindkeys for control of the scrollwheel and keys. Take a look at http://wiki.ubuntuusers.de/xbindkeys for configuration.

J.

Last edited by jesuzphreak (2014-05-12 20:14:53)

Offline

#3 2014-05-13 08:42:38

faabrizio
Member
Registered: 2007-02-17
Posts: 15

Re: How to set up alt+mouse wheel behavior

Thank you for the hint, that's an interesting alternative.

Nonetheless, xbindkeys cannot grab my mouse events. A quick search on google did not give me anything.

But still, that would not let me unset the current use of alt+wheel (or will it?). So, if someone knows where this feature setting resides, let me know.

Offline

#4 2014-05-13 12:54:53

faabrizio
Member
Registered: 2007-02-17
Posts: 15

Re: How to set up alt+mouse wheel behavior

For the record, this feature can be disabled by going to "Window Manager Tweaks" configuration panel, "Accessibility" section, and setting "none" as the "Key used to grab and move windows". But it will also disable the grab/move with [key]+mouse feature.

When disabled, it appears that the transparency setting feature (alt+mouse wheel) is still present. So it's is just "hidden" by the new zoom feature.

Offline

#5 2014-05-14 04:48:20

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 340
Website

Re: How to set up alt+mouse wheel behavior

For me zooming uses ctrl + scroll, alt + scroll gives transparency. This is in 4.11.1 on Korora (Fedora remix). I think it was like this on 4.10 too.

I've seen the behaviour you describe reported for Xubuntu with 4.11 but not other distros.

Offline

#6 2014-05-14 07:12:29

faabrizio
Member
Registered: 2007-02-17
Posts: 15

Re: How to set up alt+mouse wheel behavior

$ xfwm4 --version
This is xfwm4 version 4.11.1 (revision 2b800f4) for Xfce 4.10

This behavior appeared when upgrading Xubuntu to 14.04 which embeds xfce4 version: 4.10.1 (apt package version)

Can I ask where you see this reported ?

Offline

#7 2014-05-14 19:34:41

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 770

Re: How to set up alt+mouse wheel behavior

ozjd wrote:

alt + scroll gives transparency.

That's the way it used to work for me (IOW, correctly). But recently(?) I have noticed the same abhorrent behavior that faabrizio describes. It's a shame when people screw up good software by making changes that serve no purpose other than to cause damage to it. Oh, wait, I forgot: They changed it, so they MUST have improved it, right?[/SARCASM]

Regards,
MDM
Running Mint 14 XFCE - which once worked fine (alas, someone decided to improve it).


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#8 2014-05-15 01:33:45

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 340
Website

Re: How to set up alt+mouse wheel behavior

faabrizio wrote:

$ xfwm4 --version
This is xfwm4 version 4.11.1 (revision 2b800f4) for Xfce 4.10

This behavior appeared when upgrading Xubuntu to 14.04 which embeds xfce4 version: 4.10.1 (apt package version)

Can I ask where you see this reported ?

I saw mentioned in a couple of places when I searched for it, this is one - http://ubuntuforums.org/showthread.php?t=2208553. Interestingly some see it working while some see the previous functionality. Don't know where the quote in the first post is from, not from the release notes on Xfce mailing list anyway.

Edit: Actually found it, it was added in 4.11.1 - http://xfce.10915.n7.nabble.com/ANNOUNC … 42841.html. Not sure why it is stated that zooming is a new added feature when it has worked for many versions on ctrl - scroll.

As it seems to have been done on purpose I suggest you create a bug / feature request to reverse this to the previous behaviour. If you do please give a link to it here so others can comment on it.

Last edited by ozjd (2014-05-15 01:44:55)

Offline

#9 2016-04-15 21:20:21

Beebee
Member
Registered: 2016-04-15
Posts: 1

Re: How to set up alt+mouse wheel behavior

Hello,

This solved the issue for me :

From the Xfce Menu, choose Settings > Setting Editor. In the Channel pane select ‘xfwm4’ and in the right pane scroll all the way down to ‘zoom_desktop’. Uncheck the Value box.

Found here

Cheers,
B.

Offline

Board footer

Powered by FluxBB