Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-30 10:27:26

zezollo
Member
Registered: 2018-07-30
Posts: 3

[SOLVED] thunar: how to not force symbolic icons?

Hello everyone,


First, many thanks to developers for their lightweight yet awesome, efficient and beautiful desktop environment!

Recently, I have seen that icons for go-home, go-previous, go-next (also zoom-in, zoom-out etc.) have gone symbolic and that this is now hardcoded, and that it seems to follow the gnome recommendations for applications.

Yet this is quite ugly now in thunar and it's a bit *like* the theme is ignored (it is not ignored, of course, but I mean selecting one theme or another doesn't change much, because symbolic icons are all either quite gray or black and white...). And I prefer to use XFCE over Gnome, so, as a user, I don't mind their recommendations too much... hence, having a way to not force symbolic icons would be nice.

If I am not wrong, there is no way to setup this differently now (like a hidden setting).

So, should I file a feature request asking to choose to not force symbolic icons? (Is bugzilla the right place to do this? I cannot see any feature requests there and I couldn't find this in the documentation either).

Or, is there any workaround that I didn't figure out yet?

Thanks, and have a nice day!


Zz

Last edited by zezollo (2018-07-30 14:31:41)

Offline

#2 2018-07-30 10:50:32

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,740

Re: [SOLVED] thunar: how to not force symbolic icons?

Hello and welcome.

Try adding:

.thunar {
-gtk-icon-style: regular;
}

...to ~/.config/gtk-3.0/gtk.css. You may need to quit thunar: "thunar -q" and restart it for it to take effect.

Offline

#3 2018-07-30 11:32:07

zezollo
Member
Registered: 2018-07-30
Posts: 3

Re: [SOLVED] thunar: how to not force symbolic icons?

Awesome! Color is back! Many thanks for this quick and efficient answer!!

If I may ask, I must say I don't really understand how this work because the icon names are still ending with '-symbolic' (and they remain a bit small). Even though, the color is back.

Now, I have seen this guide: https://developer.gnome.org/gtk3/stable … rview.html but for instance '-gtk-icon-style' is not mentioned on this page.

I have run the gtkinspector, that's really useful and could find the -gtk-icon-style property. How can I know what values are correct, though? (How could I know I can set 'regular'? What are other possible values?) (Or, for instance, if I want to change other attributes/fields, like -gtk-icon-transform, that is set to scale(0.75), what can I write? I tried scale(1), but it does not work, it's ignored.) My question is not about these two examples settings particularly, but: where can I find the possible values for css attributes/fields, by myself?

Offline

#4 2018-07-30 13:44:58

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,740

Re: [SOLVED] thunar: how to not force symbolic icons?

Have a look at the GTK+ CSS Properties document. It gives a (somewhat terse but complete) description of these properties. Also: https://mail.gnome.org/archives/gtk-dev … 00020.html.

However, as to the specifics of the parameters and values, right now its a google hunt to figure it out.

So for example, to use -gtk-icon-transform, based on the input from a fellow forum member, the following seems to work:

.thunar > grid > toolbar* {
	-gtk-icon-style: regular;
	-gtk-icon-transform: scale(.6);
}

It would be really nice if this was all documented in one place and easy to find. One could only hope.

Offline

#5 2018-07-30 14:31:01

zezollo
Member
Registered: 2018-07-30
Posts: 3

Re: [SOLVED] thunar: how to not force symbolic icons?

Excellent! Thank you very much for these hints and the example too!

Have a nice day!

Offline

Board footer

Powered by FluxBB