Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-10-29 01:59:35

IpreferXfce
Member
Registered: 2016-02-25
Posts: 22

Can Not Seem To Get The Clock The Way I Like

I think I'm running xfce 4.12 on Linux Mint 19 and on Linux Lite 4.0. 

Linux Mint 18.3 Panel Version: 4.12.0-3ubuntu2

Linux Mint 19 Panel Version: 4.12.2-1ubuntu1mint1

Reason for complaining about this.  I got used to using the clock on the panel this way.  It helps me to always see the time and date at a quick glance.  Many times I want to type in the date, and that always helped me to do that.

This Example was taken from Linux Mint 18.3 Xfce.
01-Mint-18.3-XFCE-DateTime.png

Then came along Linux Lite 4.0 and Linux Mint 19.  Xfce.
04-Mint-19-XFCE-DateTime.png

Believe it or not both of these examples are using the exact same fonts!

Linux Mint 18.3
02-Mint-18.3-XFCE-DateTime.png

Linux Mint 19
03-Mint-19-XFCE-DateTime.png

I've tried making the theme the same but that didn't change it enough to solve this problem.  So I didn't bother trying to make the theme the same for the screen shots, since this Linux 19 is a fresh install.

The only difference I was able to discover is the version of xfce4-datetime-plugin

Mint 18.3 has version 0.6.2-2ubuntu2 installed and Linux Mint 19 has version 0.7.0-1ubuntu1.

I'm able to change the font size and even make it bold with version 0.7.0-1ubuntu1.  But it isn't using the space around the numbers correctly.  What happens is if you enlarge the font then you got to enlarge the entire xfce panel to make it fit.  Otherwise the numbers get pushed off the bottom of the screen!

I tried the default clock that comes with xfce and I couldn't get it configured the way I wanted.  Then I tried Orage Pannel Clock and I couldn't get it to work right either.  I posted about this issue in the Linux Mint forums but currently nobody has stepped up the plate and gave me a working solution.  The best suggestion I got so far is to try other xfce panel clocks.  But I only know of these three.  Are there others?

Offline

#2 2018-10-29 02:01:18

Mellowbob
Member
Registered: 2011-10-16
Posts: 134

Re: Can Not Seem To Get The Clock The Way I Like

Did you try resizing the panel? It might just be that you need a panel with more height?

Offline

#3 2018-10-29 02:09:09

IpreferXfce
Member
Registered: 2016-02-25
Posts: 22

Re: Can Not Seem To Get The Clock The Way I Like

Mellowbob wrote:

Did you try resizing the panel? It might just be that you need a panel with more height?

Yes I did but I don't like it because it takes up too much of my screen on my laptop, and it doesn't even look right to the size of the numbers on the clock!

You can see how the numbers go right off the screen if you just enlarge the font.

Bigger-Numbers.png

Last edited by IpreferXfce (2018-10-29 02:20:05)

Offline

#4 2018-10-29 04:36:34

Misko_2083
Member
Registered: 2015-10-13
Posts: 77
Website

Re: Can Not Seem To Get The Clock The Way I Like

Well, you could try with the custom format

Clock applet: Custom Format

<span font="Noto bold 8">%I : %M %P%n%m/%d/%Y</span>

Clock supports pango markup, sou you can set even the color. You can use pango markup on the whisker menu's title as well.

Datetime: set to "Date only" and use the custom format:

%I : %M %P%n%m/%d/%Y

Offline

#5 2018-10-29 05:58:13

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 495
Website

Re: Can Not Seem To Get The Clock The Way I Like

Check if you have a ~/.gtkrc-2.0 on one machine and if it contains any panel settings. Test by renaming the file and logging out and back in.

Offline

#6 2018-10-30 18:46:53

CwF
Member
Registered: 2018-01-28
Posts: 17

Re: Can Not Seem To Get The Clock The Way I Like

Misko_2083 wrote:

Clock supports pango markup, sou you can set even the color. You can use pango markup on the whisker menu's title as well.

This is helpful. Thanks

Offline

#7 2018-11-04 02:34:51

IpreferXfce
Member
Registered: 2016-02-25
Posts: 22

Re: Can Not Seem To Get The Clock The Way I Like

Misko_2083 wrote:

Well, you could try with the custom format

Clock applet: Custom Format

<span font="Noto bold 8">%I : %M %P%n%m/%d/%Y</span>

Clock supports pango markup, sou you can set even the color. You can use pango markup on the whisker menu's title as well.

I just tested and it seems that this one has a chance at working.

Misko_2083 wrote:

Datetime: set to "Date only" and use the custom format:

%I : %M %P%n%m/%d/%Y

If you only want the date that works.

Last edited by IpreferXfce (2018-11-04 02:38:24)

Offline

#8 2018-11-04 17:58:25

IpreferXfce
Member
Registered: 2016-02-25
Posts: 22

Re: Can Not Seem To Get The Clock The Way I Like

Update:  11/04/2018 @ 12:56 pm

I gave up on DateTime plug in.

I tweaked Misko_2083 code for the clock plugin.

My Code: 

<span font="Noto bold 8">%I:%M:%S %P%n%m/%d/%Y</span>

That gave me this!

Clock-Code.png

Offline

Board footer

Powered by FluxBB