Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-12-15 13:50:42

ineuw
Member
From: Canada
Registered: 2015-11-24
Posts: 62

Unable to disable transpareny in xfce4-notes 1.8.1

Below are the contents of my /home/ineuw/.config/xfce4 files. Whatever I tried, to get rid of the transparency, didn't work.  What am I am doing wrong? Please help.

I am using Linux Mint Cinnamon 19.2.

xfce4-notes.gtkrc

gtk_color_scheme = "notes_fg_color:#6acc639cee1d\nnotes_bg_color:#000000000000\nnotes_base_color:#6acc639cee1d\nnotes_text_color:#000000000000\nnotes_selected_bg_color:#2953268b5c24\nnotes_selected_fg_color:#6acc639cee1d"
include "/usr/share/xfce4-notes-plugin/gtk-2.0/notes.gtkrc" 

xfce4-notes.rc

[Notes]
PosX=618
PosY=242
Width=807
Height=380
TabsOrder=Notes;Notes 2;Notes 3;Notes 4;
LastTab=1
Above=false
Sticky=true
Transparency=0
Visible=false

Dual boot Windows 10 and Linux Mint 19.2

Offline

#2 2019-12-15 15:11:18

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,235

Re: Unable to disable transpareny in xfce4-notes 1.8.1

Setting "Transparency=0" in xfce4-notes.rc should work. Make sure you restart the xfce4-notes program/process for it to take effect (or log out and back in again).

Offline

#3 2019-12-16 02:25:51

ineuw
Member
From: Canada
Registered: 2015-11-24
Posts: 62

Re: Unable to disable transpareny in xfce4-notes 1.8.1

ToZ, thanks for the reply, but nothing works. It is still transparent. Logged out and in, as well as rebooted.  It's also interesting that it has no 'Quit' control, and the app hasn't been updated since 2015.  It's a pity because I like it's simplicity. sad


Dual boot Windows 10 and Linux Mint 19.2

Offline

#4 2019-12-16 03:07:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,235

Re: Unable to disable transpareny in xfce4-notes 1.8.1

I'm not that familiar with Cinnamon. Does it have some functionality that makes windows transparent? Perhaps it is overriding the built-in feature.

Offline

#5 2019-12-16 04:34:00

MrEen
Member
Registered: 2019-04-19
Posts: 135

Re: Unable to disable transpareny in xfce4-notes 1.8.1

I think I know what might be wrong.

According to this bug report, the Transparency=0 setting works for xfce4-notes, but not for xfce4-notes-plugin.

ineuw, are you sure you installed xfce4-notes, and not xfce4-notes-plugin?

I've installed xfce4-notes and confirmed the xfce4-notes.rc fix does work on Mint Xfce 19.3. Just tested the plugin, and indeed the .rc file has no effect. I tried creating a xfce4-notes-plugin.rc file but that didn't work either.

Offline

#6 2019-12-16 04:56:59

ineuw
Member
From: Canada
Registered: 2015-11-24
Posts: 62

Re: Unable to disable transpareny in xfce4-notes 1.8.1

It definitely says 1.8.1 xfce4-notes on the 'About notes',  but Preferences title says say 'Notes' and under it 'configure the plugin'.


Dual boot Windows 10 and Linux Mint 19.2

Offline

#7 2019-12-16 05:10:40

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,235

Re: Unable to disable transpareny in xfce4-notes 1.8.1

MrEen wrote:

According to this bug report, the Transparency=0 setting works for xfce4-notes, but not for xfce4-notes-plugin.

Interesting catch. It looks like if you add the plugin to the panel via the Add Items method, then the rc file that is used is the one located in the ~/.config/xfce4/panel directory. Setting Transparency=0 there will work then.

Note: you need to quit the panel (xfce4-panel -q), change the transparency value and then restart the panel. Or make the change when not logged in.

Offline

#8 2019-12-16 13:21:45

alcornoqui
Member
Registered: 2014-07-28
Posts: 579

Re: Unable to disable transpareny in xfce4-notes 1.8.1

To add just one thing, I use a dedicated keyboard shortcut to disable transparency temporarily per window. Just assign your desired key combination (in Settings > Keyboard > Application shortcuts) to this command:

xprop -f _NET_WM_WINDOW_OPACITY_LOCKED 32c -set _NET_WM_WINDOW_OPACITY_LOCKED 1

The mouse cursor will turn into a crosshair, and the next window you click on will become opaque for the time running. I use it mainly for video or paired windows situations.

(I gather that you'd prefer to make it permanent for the notes app, but that seems solved per ToZ's last post, I just thought it's an interesting related fact.)

Sources: https://forum.xfce.org/viewtopic.php?id=9121 & https://forum.xfce.org/viewtopic.php?pid=29984

Offline

#9 2019-12-16 17:14:29

ineuw
Member
From: Canada
Registered: 2015-11-24
Posts: 62

Re: Unable to disable transpareny in xfce4-notes 1.8.1

I really appreciate everyone's input but the posted info is unclear.

The first time 'xfce4-notes' was installed through the terminal, and checked Synaptic. Only the notes app was installed without the plugin.  The "~/.config/xfce4" folder contained the two .rc files (listed in the first post)  and .xml files. The transparency = 0 setting in the xfce4-notes.rc didn't work. So, I purged xfce4-notes completely, to start from the beginning.

This time I only installed the xfce4-notes-plugin, but this also installed xfce4-notes. Now, there is no "~/.config/xfce4/panel" folder and the "xfce4-notes.rc" (which has the transparency setting) doesn't exist. These are the current folders and and files.

ineuw@lm192dt:~/.config/xfce4$ ls -R -la

-rw-rw-r--  1 ineuw ineuw  281 Dec 16 11:38 xfce4-notes.gtkrc
drwxr-xr-x  3 ineuw ineuw 4096 Dec 16 10:36 xfconf

./xfconf:
drwx------ 2 ineuw ineuw 4096 Dec 16 10:37 xfce-perchannel-xml

./xfconf/xfce-perchannel-xml:
-rw-r--r-- 1 ineuw ineuw  404 Dec 16 10:37 xfce4-panel.xml


Dual boot Windows 10 and Linux Mint 19.2

Offline

#10 2019-12-20 06:42:38

ineuw
Member
From: Canada
Registered: 2015-11-24
Posts: 62

Re: Unable to disable transpareny in xfce4-notes 1.8.1

Updating Linux Mint to 19.3 fixed the issue.


Dual boot Windows 10 and Linux Mint 19.2

Offline

Board footer

Powered by FluxBB