Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-11-19 19:44:42

strider
Member
Registered: 2010-08-31
Posts: 3

Xfce 4.14 font not correct with Nvidia proprietary driver [SOLVED]

Hi,
I have a 27 inch monitor in Quad HD resolution (2560*1440) driven by a Nvidia Card.
I use the proprietary driver which recognizes the correct resolution and correctly derives the dpi via EdId as I notice in my Xorg log :

NVIDIA(0): DPI set to (108, 107); computed from "UseEdidDpi" X config

However when I, after logon, right click the desktop to bring up the menu, I noticed that my fonts are not correctly scaled : they are larger then should be (I have set my font size via xfce settings to 9 dots which is a pretty small).

However I can get to correct font size by doing the following :
- Go to the appearance section of xfce settings
- Click on the 'custom dpi setting' (I see the value of 108 which corresponds to the Xorg log)
- Un-select the 'custom dpi setting' : any open application than gets the font size of 9 and also the desktop menu is correct.

I also noticed that at startup the command 'xrdb -query'  does not return a 'Xft.dpi' setting. When I click the 'custom dpi setting' and run the same command, I see the 'Xft.dpi' setting to the value I set (108). Unselect make it disappear again.

It's like the Xft setting triggers X to use my dpi setting for font scaling (for the X root window and any other windows). Unsetting it falls back on the dpi setting my nvidia driver has determined. But I'm just guessing here.

Any thoughts ?

PS. I use an up-to-date Arch linux install.

Last edited by strider (2020-01-10 16:58:29)

Offline

#2 2020-01-10 16:57:31

strider
Member
Registered: 2010-08-31
Posts: 3

Re: Xfce 4.14 font not correct with Nvidia proprietary driver [SOLVED]

I finally found a solution. It turns out that this odd behaviour was due to the font itself I used : the google noto fonts. I have now installed liberation as my system font and all is well. I had to specifiy a different DPI though : 108 DPI since I use a Quad HD monitor (4 times 720p resolution).

Will mark this thread as solved.

Offline

#3 2020-01-10 20:06:02

Aravisian
Member
Registered: 2019-08-17
Posts: 406

Re: Xfce 4.14 font not correct with Nvidia proprietary driver [SOLVED]

Thanks for coming back to share your solution. smile

Offline

Board footer

Powered by FluxBB