Xfce Forum

Sub domains

You are not logged in.

#1 2020-01-15 02:00:04

Registered: 2020-01-15
Posts: 1

X-Air-Edit (digital mixer control) won't work with XFCE

Please, help me find what changes I have to make so this (xairedit 1.5-2) will work on my desktop.

Currently I use Manjaro XFCE, kernel 5.4 and 4.19.
I initialize the program, the UI just wont do anything. I can still open extra windows with function keys, but I can't close those extra windows with mouse-click. (They are not using the system's WM, only the main window does.) The whole thing just wont interact with my mouse-clicks. The hover-over effects are showing on Setup/Utility etc UI elements but that's it.

I get no errors when I run it from the terminal.

I've found similar question on Ubuntu Studio 19.10: https://askubuntu.com/questions/1201381 … dio-19-10#

It does not matter if I run this AUR version, or the one I downloaded from Behringer's page.

Thanx for any help!

Some extra information:

$ pamac info xfwm4
Név                      : xfwm4
Verzió                   : 4.14.0-1.3

$ ldd X-AIR-Edit
	linux-vdso.so.1 (0x00007ffea4df3000)
	libasound.so.2 => /usr/lib/libasound.so.2 (0x00007fba5cba8000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fba5cad8000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fba5c998000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fba5c980000)
	libGL.so.1 => /usr/lib/libGL.so.1 (0x00007fba5c8f8000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fba5c8f0000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fba5c8c8000)
	librt.so.1 => /usr/lib/librt.so.1 (0x00007fba5c8b8000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fba5c6c8000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007fba5c580000)
	libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fba5c560000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007fba5c398000)
	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007fba5ccc8000)
	libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fba5c380000)
	libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007fba5c348000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007fba5c328000)
	libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007fba5c220000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fba5c1f0000)
	libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007fba5c138000)
	libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007fba5c100000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007fba5bfd8000)
	libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007fba5bfb0000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fba5bfa8000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fba5bfa0000)
	libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007fba5bf28000)
$ file X-AIR-Edit 
X-AIR-Edit: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=1c6f75d573e5d96af7f0f6fee59cb4452afd55fb, not stripped
$ uname -a
Linux XY-Manjaro 5.4.6-2-MANJARO #1 SMP PREEMPT Tue Dec 24 15:55:20 UTC 2019 x86_64 GNU/Linux

journalctl does not show me anything related.

I have switched to another VT.
I started the program with

xinit ./X-AIR-EDIT -- :1 vt5

It started, and I was able to move faders, click mutes, etc.
I am not sure what does this prove though. :smiley: Is this something XFCE related?

I managed to kinda crash xfwm4 with

xfwm4 --replace

Now it's terrible but if I start X-AIR-EDIT, it works perfectly.

Last edited by WhereAbe (2020-01-15 02:02:15)


Board footer

Powered by FluxBB